Subject: Re: SDP>PRO Proposal for TIPSI-like protocol

From: Roger K Debry <[email-masked]>
Date: Thu, 7 May 1998 08:54:44 -0400

I agree completely with Don.  Implementation experience with TIP/SI
and with IPDS over TCP/IP has shown that there is benefit to having
a "packet header".

Roger K deBry
Senior Technical Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

[email-masked] on 05/07/98 04:46:54 AM
Please respond to [email-masked]
To: [email-masked]
cc: [email-masked]
Subject: SDP>PRO Proposal for TIPSI-like protocol

Your assumption might be correct if....

1) 1284.4 was a standard and not just a work in progress
2) 1284.4 was deployed in all parallel environments
3) 1284.4 was deployed in other non-TCP/IP, direct connect environments
     - USB
     - 1394
     - Serial

For the small amount of overhead that a packet header provides, I think it
is worth the price.

Don

**********************************************
* Don Wright                 [email-masked] *
* Product Manager, Strategic Alliances       *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

To:   [email-masked]
cc:   [email-masked] (bcc: Don Wright)
bcc:  Don Wright
Subject:  SDP,  IPP>PRO Proposal for TIPSI-like protocol

I just finished scanning IEEE 1284.3 and IEEE1284.4.  The most interesting
part is Chapter 8 "Service Provider Interface (SPI)" in IEEE 1284.4.  This
chapter describes a "Berkeley Sockets-compatible interface for clients and
servers to access the services provided by 1284.4".
So if I understand the intent of 1284.4, it is to provide a layer that
supports sockets over parallel connections. All we need to do in IPP is
reference sockets for TCP/IP and 1284.4 and we don't have to worry about
the
issues at that layer.
So, I conclude that we don't need to packetize IPP or do much of what is
proposed in Roger and Harry's paper. Instead, we can send IPP directly on
sockets layered on top of TCP/IP or 1284.4.  There are a few easy-to-solve
dangling
issues, such as chunking for document data and intermediate acknowledgement
when attributes are verified for PrintJob. But otherwise IPP stays as is.
If you disagree with my conclusions, I would like to know what the
TIPSI-like packetizing layer provides that sockets don't also provide?
Bob Herriot

---

From: Jay Martin <[email-masked]>
Date: Wed, 13 May 1998 18:24:34 -0400

Roger,

I'd like to comment on your latest draft, but the published
version doesn't have line numbers.  Would it be possible for
you to republish a version with line numbers as soon as
possible so comments can be posted before next week's meeting?

Thanks in advance,

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------