Subject: RE: PMP> Error Status Reporting - Does it need to be fixed?

From: "Caruso, Angelo" <[email-masked]>
Date: Mon, 27 Oct 1997 07:51:32 PST

Lloyd,

I thought we were past the question of whether the MIB is broken or not.
Yes, it's broken. I think most implementers, including myself,
recognized a long time ago that Host MIB solution to printer status is
simplistic and inadequate. I think it is also possible that we may not
be able to identify a solution that can guarantee 100% backward
compatibility with existing management apps. But, if we're going to
re-issue as a Proposed Standard we need to fix the problem.

Thanks,
Angelo

---

From: Bob Pentecost <[email-masked]>
Date: Tue, 28 Oct 1997 13:23:14 -0700

I would not say that the current error-status reporting mechanism is broken in the Printer MIB, but I would have to agree that it is deficient. We have written our management application to use the RFC1759 methods, but I'm sure it could be improved if the objects were improved. 

I'm not really keen to reopen the Printer MIB since we have already put aside some proposals in order to achieve closure. I would be satisfied to see the current draft be a Proposed Standard and then if work is to continue, let's open it up for improvements in status and error reporting, as well as localization and other issues. Harry's proposal is a good starting point but I'd need to do some checking with our developers to make sure everything is covered.

Bob Pentecost
HP 

P.S. For the record, if I had known there would be Printer MIB issues on the agenda, I would have made the trip to Boulder.

----------
From:  [email-masked][SMTP:[email-masked]]
Sent:  Saturday, October 25, 1997 8:41 AM
To:  [email-masked]
Subject:  PMP> Error Status Reporting - Does it need to be fixed?

There has been some discussion that the current Error Status
Reporting mechanism in the Printer MIB is not sufficient.
There have been solutions already proposed to the problem
but I would like for this thread to discuss is the current
mechanism broken? Harry, Jay and Tom have already stated
Yes - it is broken. I would like to hear from other people
as well.
Regards,
Lloyd

------------------------------------------------------------
Lloyd Young                       Lexmark International, Inc.
Senior Program Manager            Dept. C14L/Bldg. 035-3
Strategic Alliances               740 New Circle Road NW
internet: [email-masked]     Lexington, KY 40550
Phone: (606) 232-5150             Fax: (606) 232-6740