Subject: PMP> Re: URGENT: SYNTHESIS proposal on definition of OCTET STRING to allow superset of ASCII

From: [email-masked]
Date: Mon, 04 Aug 1997 11:40:58 +0200

This sounds interesting.....
questions three:

- is it now clear that a SINGLE variable defines the localizations for
  ALL localized strings within the Printer MIB?
- is it better to define "LocalizedString" as a Textual Convention
  rather than using OCTET STRING and having the localization in the
  description of the variable?
- I forgot what the third one was :-)

I think this is good, and since there is the variable, it *is*
possible to determine the charset in use, as per the AD's admonition.

If the group has consensus on this approach, I think I'll use it as an
example in my presentation on charset policy in the Thursday plenary....

                     Harald A
               back from holidays

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Mon, 4 Aug 1997 08:07:18 PDT

Hi Harald,

Sorry to tell you that the group did NOT reach concensus on Tom's last
SYNTHESIS proposal.  There is no new object for the character set
and the existing 'prtGeneralCurrentLocaliztion' does NOT control
the charset for the several dozen strings still marked OCTET
STRING.  The latest text does include Tom's suggested text based
around charsets which are supersets of US-ASCII (like Unicode
in UTF-8 encoding) for all of the OCTET STRINGs, but the charset
is unknown (note that this permits the existing HP PC8 and Lexmark
PC 850 implementations of RFC 1759 to be compliant with the
Printer MIB v2).

Best Regards,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839
  906-494-2434

----------------------------- Harald's note ---------------------------
>From [email-masked] Mon Aug  4 05:53:28 1997
From: [email-masked]
To: Tom Hastings <[email-masked]>
Cc: [email-masked], Keith Moore <[email-masked]>
Subject: PMP> Re: URGENT: SYNTHESIS proposal on definition of OCTET STRING to allow 
 superset of ASCII 
Date: Mon, 4 Aug 1997 02:40:58 PDT
Sender: [email-masked]
Status: R

                     Harald A
               back from holidays