Subject: PMP> Localization changes to the Printer MIB

From: Bob Pentecost <[email-masked]>
Date: Fri, 27 Jun 1997 16:03:14 -0600

Lloyd and Chris,

In earlier messages I have requested the localization changes requested by Ira McDonald not be put in the Printer MIB. The main reason for not putting the change in the document is the lack of time to make sure we have the correct solution. The proposal has been changed very recently with the addition of the fourth textual convention, showing that it is still evolving. Additionally, Ira has proposed another solution in his 6-26 email message.

During the recent PWG meeting, there were several discussions about the addition of the localization changes to the 6-25-97 version of the Printer MIB. A clear majority of those interested in the subject felt that the changes should not be in the document. I encourage people to post their concerns and/or support to the mail reflector.

A general concern that I voiced was the problem of document turmoil when making changes at the last minute. Then, as if to prove my point, I found that pmib-062797.txt has the console localization object defined twice (see prtConsoleLocalization and prtGeneralConsoleLocalization). 

We have already missed one deadline and the new deadline is now endangered by the addition of these localization changes. Please back out the changes and let's get the Printer MIB completed.

Bob Pentecost
HP

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Sun, 29 Jun 1997 09:49:12 PDT

Hi Bob,

I'm disappointed that you characterize the new Printer MIB as being
'endangered by the addition of these localization changes'.  A fairly
long list of changes (NOT localization) was posted by Lloyd last week.

My suggestions (virtually ignored for the last three months on the
mailing list) for localization are of two types:

1)  Use of textual convention synonyms for OCTET STRING to
    clarify which string objects are under what localization
    control - this use of a synonym for clarity is common
    in IETF standard MIBs and HARMLESS (typos aside, of course).

2)  Addition of one (or per Angelo, possibly three) new objects
    to allow the managed printer or print server to 'export'
    it's knowledge of the 'static locale' of the vast majority
    of string objects which were NOT so clarified in the
    original Printer MIB (RFC 1759).

The changes are separable.  The first has no impact on any
existing implementation - it just makes sure that the SYNTAX
clauses clearly identify the relevant localization and NOT
mere comments in the DESCRIPTION clauses of the string objects.

Given the market realities (vendors have to build new systems
and make them backward compatible, whenever possible) and the
IETF organizational realities (I-D's expire quickly, working
group charters are SUPPOSED to expire quickly), if my item (1)
clarifications don't make it into the new Printer MIB now,
they probably won't see the light of day before the year
1999 or 2000.  This would be a serious setback for the
Printer MIB in non-English/non-ASCII environments.  

The rest of you lurkers, PLEASE send meaningful technical
criticisms (and NOT unsupported 'opinions') on the updates
to clarify localization (or any of the other dozen recent
updates).  After some version of new Printer MIB text
is submitted to the IETF/IESG  in early July, it will get
a LOT harder for PWG members to influence changes (ie,
strictly technical comments will be entertained by the IETF).

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839
  906-494-2434

----------------------------- Bob's note ------------------------
>From [email-masked] Sun Jun 29 12:04:17 1997
From: Bob Pentecost <[email-masked]>
To: "'Young, Lloyd PWG'" <[email-masked]>,
        "'Wellens, Chris (PWG)'" <[email-masked]>
Cc: "'PWG-pmp'" <[email-masked]>
Subject: PMP> Localization changes to the Printer MIB
Date: Fri, 27 Jun 1997 15:03:14 PDT
Sender: [email-masked]
Status: R

Lloyd and Chris,

In earlier messages I have requested the localization changes requested =
by Ira McDonald not be put in the Printer MIB. The main reason for not =
putting the change in the document is the lack of time to make sure we =
have the correct solution. The proposal has been changed very recently =
with the addition of the fourth textual convention, showing that it is =
still evolving. Additionally, Ira has proposed another solution in his =
6-26 email message.

During the recent PWG meeting, there were several discussions about the =
addition of the localization changes to the 6-25-97 version of the =
Printer MIB. A clear majority of those interested in the subject felt =
that the changes should not be in the document. I encourage people to =
post their concerns and/or support to the mail reflector.

A general concern that I voiced was the problem of document turmoil when =
making changes at the last minute. Then, as if to prove my point, I =
found that pmib-062797.txt has the console localization object defined =
twice (see prtConsoleLocalization and prtGeneralConsoleLocalization).=20

We have already missed one deadline and the new deadline is now =
endangered by the addition of these localization changes. Please back =
out the changes and let's get the Printer MIB completed.

Bob Pentecost
HP