Subject: PMP> prtAlertTime issue

From: Randy Turner <[email-masked]>
Date: Fri, 06 Jun 1997 10:17:39 -0700

Lloyd referenced an earlier mail message by Bob Pentecost reflecting a
request by Bob as to
what value should be returned by a GET for prtAlertTime if the printer
didn't know the time.
Values for INTEGER types have (other) and (unknown) as possible values.
The 'TimeTicks'
object has no such equivalents. prtAlertTime is now mandatory, and is
based on sysUpTime
from MIB-II. If someone performs a GET on prtAlertTime (according the
curent definition),
then it MUST return a valid value. There are no alternative 'other' or
'unknown' scenarios
for an object like prtAlertTime, with type 'TimeTicks' that is based on
MIB-II sysUpTime.

Randy

---

From: Bob Pentecost <[email-masked]>
Date: Fri, 6 Jun 1997 13:52:25 -0600

When we discussed whether or not to make prtAlertTime mandatory, I was 
assured by several committee members that there was a value that could be 
provided if the value of sysUpTime was not available (for our printers it 
is a case of sysUpTime being provided by the NIC and, as discussed for 
several areas of the MIB, "the NIC doesn't know everything about the 
printer and the printer doesn't know everything about the NIC").

Therefore, I request that wording be added as follows:
"A value of zero indicates the alert occurred at an unknown time."

Bob Pentecost
HP

----------
From:  Randy Turner[SMTP:[email-masked]]
Sent:  Friday, June 06, 1997 11:18 AM
To:  [email-masked]
Subject:  PMP> prtAlertTime issue

Randy

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Fri, 6 Jun 1997 14:10:39 PDT

Hi Bob,

Yes, I agree with your wording below.  This is consistent with
other practice where a 'TimeTicks' value is unknown.

I would observe that the source of 'prtAlertTime' is the
'sysUpTime' object in the (mandatory) System group in MIB-II
(RFC 1213), so of course nobody would be without an internal
clock...

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc

----------------------------
>From [email-masked] Fri Jun  6 16:08:46 1997
From: Bob Pentecost <[email-masked]>
To: "[email-masked]" <[email-masked]>
Subject: RE: PMP> prtAlertTime issue
Date: Fri, 6 Jun 1997 12:52:25 PDT
Encoding: 39 TEXT
Sender: [email-masked]
Status: R

Bob Pentecost
HP

----------

Randy