Subject: PMP> jmGeneralLeastActiveIndex

From: Harry Lewis <[email-masked]>
Date: Wed, 9 Apr 1997 19:21:17 -0400

Classification:
Prologue:
Epilogue: Harry Lewis - IBM Printing Systems

There was quite a bit of discussion upon adding this to the jmGeneral table
last week in Austin. After reviewing back here, we still don't see how this
value serves it's purpose. Does someone have a write-up of exactly what this
object is supposed to do?

We feel another object is also required... basically something like
jmGeneralHighestActiveIndex otherwise it is very difficult to avoid walking the
whole table.

We feel that these should be named

 jmGeneralOldestActiveIndex
 jmGeneralNewestActiveIndex

this helps get around the wrap problem.

Using these two objects, an application should be about to determine where to
start in the table (Oldest) and where to stop (Newest) and should also know
there will be a wrap if Newest is a smaller number than oldest.

I don't think we felt we'd fully solved this problem in Austin. If we did, can
someone explain how it works?

Harry Lewis.

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Wed, 9 Apr 1997 20:25:18 PDT

Hi Harry,

I agree with your suggestion for two objects (and with their names
and postulated semantics).  In a number of standard (and proprietary)
MIBs, there is a 'highestActiveIndex' object.  But anytime that the
rows are actually quite volatile, the wrap problem makes this object
nearly useless.

Cheers,
- Ira McDonald (outside consultant at Xerox)

PS - I can't reach the PWG server in the last two-and-a-half days,
to retrieve your posting about the 'grand entente' between Tom
Hastings, Ron Bergman, and yourself.  Is there something wrong at
the PWG server end?  Could you mail to the two '.pdf' files to
[email-masked]', so that Joe and I could look at them?
Thanks.

>--------------------- Included Message -----------------------------<
>From [email-masked] Wed Apr  9 20:25:04 1997
From: Harry Lewis <[email-masked]>
To: <[email-masked]>
Subject: PMP> jmGeneralLeastActiveIndex
Date: Wed, 9 Apr 1997 16:21:17 PDT
Sender: [email-masked]
Status: R

Classification:
Prologue:

Harry Lewis.