Subject: PMP> Top 25 Alert Comments

From: Bob Pentecost <[email-masked]>
Date: Tue, 29 Apr 1997 02:35:02 -0600

During the 4/22 phone conference, I promised to post my concerns 
with the proposed Appendix D - Overall Printer Status Table. My 
initial concern was for the Offline condition having an alert 
table entry, which the group agreed was necessary.

While it may seem that I have a lot here, I think many are just in 
need of discussion/clarification since Chuck really did a good 
first pass. Also, I have a fair amount of duplication. It should 
be noted that while some of this is based on HP's implementation, 
much if it is empirical (meaning I think our implementation could 
use a little tweaking :-).

Instead of repeating the table here, I've listed the columns and 
then put "Okay" if I agree with the document as posted, or I've 
put a comment. The original document can be found at:
   ftp://ftp.pwg.org/pub/pwg/pmp/contributions/err3.doc
   ftp://ftp.pwg.org/pub/pwg/pmp/contributions/err3.pdf

Normal or idle    
(no binary alerts): Okay

Printing          
(no binary alerts): Okay

Off-line          
(no binary alerts)
   hrDeviceStatus: Okay
   hrPrinterStatus: Okay
   hrPrinterDetectedErrorState: Okay
   prtAlertGroup: channel(14)
   prtAlertCode: subunitOffline(32)
   Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                    CriticalAlert + Offline 
                                    (1+16+32)

Standby or Power  
Saver Mode        
(no binary alerts)
   hrDeviceStatus: Okay 
   hrPrinterStatus: other(1) [per page 20 of MIB]
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: marker(10)
   prtAlertCode: subunitPowerSaver(23)
   Group Status: prtMarkerStatus = Available&Standby(2)

Initial Power Up  
(no binary alerts 
(while warming up): All Okay 

Warming Up        
(no binary alerts): All Okay

Jam               
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Jammed(4) [per definition]
   prtAlertGroup: Jammed (4) [per definition]
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Cover/Door        
Open (listed      
in cover table)   
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: DoorOpen(8) [per definition] + 
                                Offline(2)
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Input Tray        
Missing           
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Input Tray        
Empty             
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Output Tray       
Missing           
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Output Tray       
Full              
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Marker Supply     
Missing           
( toner missing,  
  ink missing )   
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: NoToner(16) + Offline(2)
   prtAlertGroup: Marker(10) [corresponds better with Group status 
                              Marker]
   prtAlertCode: Okay if markerTonerCartridgeMissing(1115)
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Marker Supply     
Empty (i.e.,      
 toner empty,     
 ink low)         
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: NoToner(16) + Offline(2)
   prtAlertGroup: Okay (Does markerSupplies imply that 
                        prtMarkerStatus is the corresponding 
                        subunit?)
   prtAlertCode: Okay 
   Group Status: Why 'On-line'? Why 'Transitioning'?
   Add Offline Alert 
      prtAlertGroup: channel(14)
      prtAlertCode: subunitOffline(32)
      Group Status: prtChannelStatus = Unavailable&OnRequest + 
                                       CriticalAlert + 
                                       Offline (1+16+32)

Input Tray        
Low               
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Add inputMediaSupplyLow(807)
   Group Status: Why 'Transitioning'?

Output Tray       
Almost Full       
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

Marker Supply     
Almost Empty      
(i.e., toner low, 
 ink low)         
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

Input Tray        
Missing (when n-1 
trays are missing 
with linking)     
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

Input Tray        
Empty (when n-1   
trays are empty   
with linking)     
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

Output Tray       
Missing (when n-1 
trays are missing 
with linking)     
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

Output Tray       
Full (when n-1    
trays are full    
with linking)     
   hrDeviceStatus: Okay 
   hrPrinterStatus: Okay 
   hrPrinterDetectedErrorState: Okay 
   prtAlertGroup: Okay 
   prtAlertCode: Okay 
   Group Status: Why 'Transitioning'?

---

From: JK Martin <[email-masked]>
Date: Tue, 29 Apr 1997 12:12:41 -0400 (EDT)

Bob,

Thanks for the exhaustive comments on the latest "Top 25 Alert Table"
draft.  Your documentation approach is quite readable for review.

I have some significant questions regarding your issues surrounding
the notion of "Offline" for various alert conditions.  I will be
sending a separate message on this topic, as a new thread for this
issue is probably necessary.

As far as your other comments/issues go, I pretty much agree with you.
In particular, it seems that we should not be pointing to the
"MarkerSupplies" group when a more natural target is the "Marker" itself.
Hopefully we can discuss this more generally in our telecon later today.

Nice review, Bob.  Very much appreciated.

	...jay