Subject: Re[2]: PMP> What exactly is the definition of "Offline"?

From: [email-masked]
Date: 30 Apr 97 12:43:17 EDT

Jay,
     
     Should we take it a step further?  For PrtSubUnitStatusTC, is On-line 
     needed at all?  Can anyone think of an example where the On-line value 
     provides information that is not supplied by Availability and/or 
     Critical?  
     
     Stuart Rowley
     Kyocera Electronics

______________________________ Reply Separator _________________________________
Subject: Re: PMP> What exactly is the definition of "Offline"?
Author:  INTERNET:[email-masked] at CSERVE
Date:    4/29/97 6:29 PM

Sender: [email-masked]
Received: from uscore.underscore.com (uscore.underscore.com [199.125.69.1]) by 
dub-img-4.compuserve.com (8.6.10/5.950515)
     id SAA22804; Tue, 29 Apr 1997 18:28:05 -0400
Received: (from jkm@localhost) by uscore.underscore.com (8.8.4/8.7.2) id 
SAA28909; Tue, 29 Apr 1997 18:27:47 -0400 (EDT)
Date: Tue, 29 Apr 1997 18:27:47 -0400 (EDT) 
From: JK Martin <[email-masked]>
Message-Id: <[email-masked]> 
To: [email-masked]
Subject: Re: PMP> What exactly is the definition of "Offline"? 
Cc: [email-masked]
X-Sun-Charset: US-ASCII
     
Stuart,
     
Yes, I see where one would be confused about the definition of "Online" 
in your example.
     
How about the rest of the folks?  Should we change "Intended" to "Current" 
as Stuart proposes?  (I tend to agree with his proposed change.)
     
     ...jay
     
----- Begin Included Message -----
     
>From [email-masked] Tue Apr 29 15:35 EDT 1997 
From: [email-masked]
Date: 29 Apr 97 15:32:33 EDT
To: <[email-masked]>
Subject: Re: PMP> What exactly is the definition of "Offline"?
     
     Jay,
     
     I have been baffled by the use of Online in PrtSubUnitStatusTC.  The 
     text is:
     
     On-Line
     
                      Intended state is On-Line       0
                      Intended state is Off-Line      32
     
     I thought this value was NOT indicating the current state of the 
     device, but rather the intended state (although I couldn't think of 
     any devices with intended states of Off-line).  If this is to indicate 
     current state, "Intended" should be changed to "Current".
     
     I also agree that what constitutes an Off-line state should be 
     clarified.
     
     Stuart Rowley
     Kyocera Electronics

----- End Included Message -----

---

From: Ron Bergman <[email-masked]>
Date: Wed, 30 Apr 1997 16:38:59 -0700 (PDT)

Stuart,

You are correct, the online condition is identical to "Avaliable and
Idle" or "No Critical Alerts".  Don't forget that PrtSubUnitStatusTC
is a bit map, and a null entry (i.e. Online) is required for each
value group.

Let's leave well-enough-alone.

	Ron Bergman
	Dataproducts Corp.