Subject: Re: PMP> Questions on RFC1759

From: Lloyd Young <[email-masked]>
Date: 17 Mar 97 9:05:27 EST

Harish,
I can answer one of your questions:

> 3.  In mib walk interop test results what does NV stand for ?

NV stands for No Value (the product being tested did not return a value
for that object.

Lloyd Young

---

From: JK Martin <[email-masked]>
Date: Tue, 18 Mar 1997 13:04:09 -0500 (EST)

I, too, agree with Bill's recollections of SMIv2 vs. SNMPv2.

	...jay

----- Begin Included Message -----

>From [email-masked] Tue Mar 18 12:55 EST 1997
Date: Tue, 18 Mar 1997 12:51:56 -0500
From: Matt King <[email-masked]>
Mime-Version: 1.0
To: Bill Wagner <[email-masked]>, [email-masked]
Cc: [email-masked]
Subject: Re: PMP> Questions on RFC1759
Content-Transfer-Encoding: 7bit

Bill, Harish,

I should have made the point in my reply that SNMPv2 and SMIv2 are
unreleated.  I just assumed that what Harish ment was SMIv2.  I believe
that Bill is absolutely correct (Not that I am a guru).

--Matt

Bill Wagner wrote:
> 
>      Perhaps some SNMP guru will correct me, but my understanding is that
>      RFC1759 presented a MIB in compliance with SMI v2 not SNMPv2. I
>      believe that a VI agent does just fine with the  MIB. Indeed the trap
>      is defined in both SNMPv1 and v2 form. A management application
>      unfamiliar with SMI V2 does have problems compiling the MIB. The
>      Printer Working Group  did disseminate an unguaranteed VI version of
>      the MIB about 1-1/2 years ago and this should be in the PWG archives.
> 
>      Bill Wagner
> 
> ______________________________ Reply Separator _________________________________
> Subject: Re: PMP> Questions on RFC1759
> Author:  [email-masked] at Internet
> Date:    3/17/97 8:44 AM
> 
> Harish nachnani wrote:
> >
> > 1. RFC1759 follows snmpv2 format conventions. What if the
> > agent only supported snmpv1. Is there a v1 version of 1759.mib ?
> 
> I don't think there has been one published, however, I believe that
> there are a few tools out there that will convert MIBs to v1 format.
> The Pro version of SMICng is supposed to (www.snmpinfo.com) and I
> believe that there used to be some agents on the internet to which you
> could send a MIB to have it converted.  Also, a few well written emacs
> macros will do the trick (that is how I converted the MIB to v1 format
> some time back).
> 
> Can anyone else help on this?
> 
<Lines erased>
-- 
Matt King                                     Opinions are my own and
Staff Engineer                                    are not necessarily
Lexmark International, Inc.                          those of Lexmark
[email-masked]

----- End Included Message -----