Subject: PMP> Minutes of the "Top-25" call

From: "Harry Lewis <[email-masked]>" <[email-masked]>
Date: Wed, 5 Mar 97 15:23:22 MST

I posted minutes of today's call at
ftp://ftp.pwg.org/pub/pmp/minutes/mar05cal.txt. Text only.
I hope I caught most of it. Chuck Adams will have more detail in his revised
chart.

Here's the same minutes if you don't want to go to the FTP server...

 =====================================================================

Minutes of the Mar-05-1997 conference call on Stardust Interoperability
test results - specifically the "top 25 alerts" and printer status discussion:

Present:  Lloyd Young/Matt King/Evan
               Ron Bergman
               Stuart Rawley
               Chuck Adams
               Harry Lewis
               Jay Martin
               Bob Pentecost (In the Tampa airport heading for Denver)  ARE THESE GUYS DEDICATED
               Bill Wagner (In the SanJose airport arriving from Boston - presumably)  OR WHAT!?
               Gail Songer

Review of Chuck Adamñs ÊTop 25¾ event and/or status conditions chart.

Accept the majority of Chucks chart - (Thanks Chuck for the great work!). Chuck marked up his copy of
the chart as we discussed, so has any detailed changed that these minutes may miss.

Review comments by Harry Lewis.
 - Agree to follow hrMIB definition for PrinterStatus=Other when DeviceStatus=Down
 - 2 minor corrections to the hrPrinterDetectedErrorState decimal values
 - Generalize the Jam table entry with a note that indicates the prtAlertGroup should reflect the subUnit
    which has the Jam.
 - Tray missing hrPrinterDetectedErrorState 128 vs. 64. Undecided. Hoping to define new Tray Missing bit.
 - Recommendation for 5 new hrPrinterDetectedErrorState bits. Agree to pursue. Should be easy. Lloyd will
   approach IETF. If not quick and easy, fall back to defining from existing set of bits.

Review Evanñs proposal for cross association of paperOut with WARNING and paperLow with DOWN.
 - Good reasoning (legal tray could be EMPTY, default tray full but printer is effectively DOWN if
    someone tries to use legal.
 - However, hrDeviceStatus, hrPrinterStatus and hrPrinterDetectedErrorState should be used just to
   provide a quick highlevel view of printer condition. Thus, a DOWN condition should not be indicated
   unless the printer wonñt print at all, under any circumstances. In Evanñs example, the overall condition
   of the printer is WARNING, at least until someone tries to print.
 - We did clarify that if the last sheet was used from the printer (every input is empty) a DOWN condition	
    should be indicated as soon as it is possible to detect it, not necessarily waiting for demand to occur.
    Otherwise, this inevitable DOWN condition may have been corrected prior to the next submission.
 - Gail will post her review of the Stardust results in this area. Gail claims several mfgs disassociated
    hrDeviceStatus and hrPrinterDetectedErrorState already.

Review Jay Martinñs proposal
 - Accept the proposal that hrPrinterStatus should be (5) warm-up not (1) other when coming out of
   PowerSaverMode, even though hrDeviceStatus is still (5) down.

Discuss Stuart Rawleyñs topic of calling out an input or output subunit in the alert table when the alert	
is ÊCover Open¾
 - This is not recommended. Mainly, it is difficult to correlate subUnitStatus with the proper prtAlertGroup
    in this case

Discuss Harry Lewis proposal to all Jams to reference the cover group in prtAlertGroup.
 - Also not recommended. Same reasons as above.

Bill Wagnerñs questions regarding MIB-II
 - We didnñt cover MIB-II at the interoperability test, so there are holes in our understanding of
    how vendors implemented the Systems and Interfaces groups.
 - We know some vendors implemented the Interfaces groups in the NIC, providing a view of that NIC
    only, and others implemented MIB-II in the printer, providing an Interfaces table which pertains to
   all NICs in the printers.
 - There is emphasis on the hrMIB to uniquely identify the printer. Why do we need the Systems Group?
 - Could we do away with all MIB-II references in the Printer MIB since a NIC needs to do MIB-II
    anyway.
 - If we do (above), can we supplement the printer MIB with a simple table of interfaces, supplying
   only the information useful to printing applications?
 - Bill will make a proposal.

Active/Busy
 - It is not absolutely clear how Active/Busy maps to each subUnitStatus.
 - This is where I got numb.	

Harry Lewis

---

From: Chris Wellens <[email-masked]>
Date: Mon, 10 Mar 1997 15:27:09 -0800 (PST)

As a follow up to this request that was part of the 3/5/97

>    approach IETF. If not quick and easy, fall back to defining from existing set of bits.

Where we stand on this is that we have a good opportunity to
make minor modifications to the HR MIB, such as the one above.
However, this will not happen until after the April IETF meeting.  
Please go ahead and assume that these five bits can be added,
and we will have final confirmation by late April/early May.