Subject: PMP> Printer MIB draft ready (pretty much)

From: Randy Turner <[email-masked]>
Date: Sun, 23 Mar 1997 16:48:34 -0800

I made all the corrections we talked about in teleconference,
including all of the editorial comments that were emailed
out as well.

It looks real good, EXCEPT within Word 7.0 when I click
Print Preview, the document looks great, first page to 
last, including the right page breaks with respect to
headers and footers. Everythings ok.

However, when I select the printer "Generic/Text-Only" and
print it to a file and print it on the printer, the page
breaks are horrible, with no respect for my headers,footers
or page numbers.

There is some kind of special characters however in the
document where you would expect form-feeds (FF) to go to
produce the correct page breaks. I'm not sure what the
character is but when you bring up the windows/95
"Wordpad" Utility to display the document, they show up
as some kind of weird graphic character. Anyway, when
I "print to file" using the generic-text printer device
something doesn't work, even though "Print-preview" 
while still inside of Word looks great! Besides page
breaks everything translated into generic/Text fine.

Anybody got any ideas?

What I would like Word to do (for the generic/text printer)
is generate form-feeds at each page break (where the funny
characters are in my current draft). The funny graphics
characters are obviously not form-feeds because they show
up on the printed page as yet another funny character.

I could let it go as is, but I wanted to see if anyone on
the list could help first. Is there some Word printing
option I'm missing? Gee, you'd thing form-feeds would be
easy...

Randy

-- 
Randy Turner
Network Architect
Sharp Laboratories of America
[email-masked]

---

From: Tom Hastings <[email-masked]>
Date: Mon, 24 Mar 1997 15:44:28 PST

Randy,

Try setting your left margin to 0 and right margin to 1.3 per
my instructions in Appendix D of the Job Monitoring MIB (and
my recent mail).  Then you can get exactly 72 characters per line
at 10 characters per inch (Courier New 12 point).
Also set the top and bottom margins to 0.

You want to fool the generic driver into producing text that has no
leading spaces.

Tom