Subject: P1394> SBP-2 Logins

From: Robert Morford <[email-masked]>
Date: Tue, 30 Jun 1998 13:29:57 -0600

In revision 0.40 of the PWG 1394 profile, section 24 (Login),
it states that Microsoft has implemented their SBP-2 driver
to login at power-up and not logout until shutdown.  According
to my notes, Microsoft indicated that they are set up to
do this for disk, but that it wasn't necessary for printers.

Does anyone else have information that supports or 
contradicts this statement in the profile? 

-- 
Bob Morford ([email-masked])
SIS Microelectronics, Inc.
A Subsidiary of Aspec Technology, Inc.
1831 Lefthand Cir., Suite #E
Longmont, CO 80501
303-776-1667 x226

---

From: Greg Shue <[email-masked]>
Date: Tue, 30 Jun 1998 12:51:08 -0700 (PDT)

> contradicts this statement in the profile? 

I think the statement in the profile is out-of-date.

What I recall is essentially the same as your notes.
The Microsoft driver does a login at powerup for disk devices.

It will do dynamic login/logout for printers as needed.
I **think** I was told that they will login when the print
queue for the device becomes non-empty, and they will logout
when the queue becomes empty.

I don't know which policy they will use for scanners.
I hope they will not follow the disk paradigm.

-- 
Greg Shue
Hewlett-Packard Company
All-in-One Division			        [email-masked]
----------------------------------------------------------------