Subject: RE: P1394> May 1394 PWG Definitions

From: "Atsushi Nakamura" <[email-masked]>
Date: Mon, 25 May 1998 11:48:22 +0900

I had thought that units were equated to drivers from the discussions
in Virginia and it sounded good to me. (Sorry if I misunderstood) 

Greg said : 

>We equated a function to a unit directory. We called it a 'Unit' to equate 
>it to the 1212 unit definition.

but Greg ALSO said : 

>A printer (Function) may be implemented with one or more protocols (Units) 

Your comments seems to say function==unit==protocols. 

No personal offense. In fact, you stated one of my initial concerns when I saw 
the 1212 definition of units for the first time, and how 1394 uses it. I felt some
inconsistency with the 1212 definition of units, and actual usage.
I do not intend to take this up as a problem, but I feel 1394 protocols
(current actual usage) do not equate units with functions, but as
protocols. (ex. AV/C unit, SBP-2 unit, etc.)
Under this circumstances and understanding, equating units to drivers seemed
to fit. 

--
Anyway, I think the following comments will make sense either way.
(units==drivers and units==functions)

Greg said : 
>I think we need to expand the idea of function : unit on a 1:1 ratio

True. Another point is 
1) function : unit on a 1:n ratio......1 function using/supported by one or more protocols
                                                                                                (unit dir level)
2) function : unit on a n:1 ratio......one or more functions supported by 1 protocol.
                                                                                                (unit dir level)

Though the PWG profile may allow  only 1), both have to be allowed  
looking from the point of 1212 (and any protocols).

So...
My 2nd try at "function" : 
'The higher level capability of the Module / node which is accessed by
one or more units, e.g., mass storage, CD-ROM or printer. 
A function is usually a collection of services that are user identifiable.
A function can be accessed by multiple units, and multiple functions can 
be accessed by one unit.'
--

The "function_class entry" of  FDS will represent :
an (physical) instance model of a function

Ats

-----Original Message-----

>I think we need to expand the idea of function == unit on a 1:1 ratio
>
>More like function == unit on a 1:n ratio
>
>Isn't this where we came up with the term Function in the beginning?
>
>A physical device (functional unit) or portion thereof (MFP case)
>that uses one or more protocols (unit dir[s] level)
>and has a 'unit architecture' which is represented in 
>Configuration ROM by one or more Unit Directory entries
>which contain one or more service entry points.
>
>GregL
>
>
>-----Original Message-----
>From: [email-masked] [SMTP:[email-masked]]
>Sent: Friday, May 22, 1998 2:04 PM
>To: [email-masked]
>Cc: [email-masked]; [email-masked]; [email-masked]
>Subject: RE: P1394> May 1394 PWG Definitions
>
>     Sounds to me like Greg is starting to zone in on what a function is.
>
>     Only part that does not quit gel is that since a function can be made up of 
>     one or more units then do we differ from the 1212 function == unit view?
>
>     Alan
>
>______________________________ Reply Separator _________________________________
>Subject: RE: P1394> May 1394 PWG Definitions
>Author:  Non-HP-gleclair ([email-masked]) at HP-Roseville,uugw3
>Date:    5/22/98 9:15 AM
>
>
>We equated a function to a unit directory. We called it a 'Unit' to equate 
>it to the 1212 unit definition.
>     
>If we need to include function from the point of view of 1212r - (based on 
>what we've been discussing)
>     
>A printer (Function) may be implemented with one or more protocols (Units) 
>which may allow access to one or more services (LUNs)
>     
>Therefore, the definition of function would seem to be
>'The higher level capability of the Module / device which is accessed by 
>one of the Units. A singular function may be supported by more than one 
>Unit.'
>     
>Comments?
>     
>Greg
>     
>     
>     
>-----Original Message-----
>From:   [email-masked] 
>[SMTP:[email-masked]] 
>Sent:   Friday, May 22, 1998 8:23 AM
>To:     [email-masked]
>Cc:     [email-masked]; [email-masked] 
>Subject:        RE: P1394> May 1394 PWG Definitions
>     
>I am still unclear about the definition of a function vs unit & service.
>     
>I do believe that since the PWG has found 1212 to be normative the 1212 
>definition and the PWG definition should serve the same purpose.
>     
>     Alan
>     
>     
>______________________________ Reply Separator 
>_________________________________
>Subject: RE: P1394> May 1394 PWG Definitions
>Author:  Non-HP-atsnaka ([email-masked]) at HP-Roseville,mimegw3 
>Date:    5/22/98 12:14 AM
>     
>     
>First of all,
>The defintion of "function" is for p1212r FDS purposes.
>We may not even have to define "function" for the PWG profile, but it is 
>needed
> for FDS.
>I apologize if I should of done this in the 1212 reflector.
>     
>Alan said;
>>
>>The definition of a function seems to indicate that a function is a unit. 
>>
>     
>It CAN be considered that way in a ceratin implementation, but we CONNOT 
>say that is the ONLY way we have to see it.
> (Especially in the case of FDS, where we have to start thinking
>about other protocols.)
>At one point in the discussison, Brian had mentioned that some people may 
>consider a service as a function, and visa-versa. I agree to this idea, and 
>I gu
>ess
>we are not allowed to give an answer (restriction) to the relationship 
>between a
>function and a  unit.
>We agreed a unit corresponds to a driver (in the case of the PWG profile). 
>If so, the relationship of a driver to a function is implementation 
>specific.
>     
>The only restrictions I think I can make for "function" are :
>     
>1) A part of the unit architecture (not meaning a part of the unit, but 
>meaning
>    a part of this architecture i.e. part of a node, module, or whatever)
>2) A collection(meaning 1 or more) of services 
>3) User identifiable
>     
>I cannot think of more resrtictions to add and still make the definition 
>consist
>ant
>within 1212
>     
>ats
>     
>>
>>by Atsushi Nakamura
>>----
>>My shot at definition of "function":
>>A function is part of the unit architecture and is an instance of a device 
>>model, e.g.,   mass storage, CD-ROM or printer. A function is usually a 
>>collection of services that are user identifiable.
>>-----
>>
>>The definition of a function seems to indicate that a function is a unit. 
>>
>     
>     
>
>
>
>

---

From: Greg Shue <[email-masked]>
Date: Tue, 26 May 1998 10:11:04 -0700 (PDT)

> Under this circumstances and understanding, equating units to drivers seemed

The big struggle I have with current 1212 definitions is that
they do equate *_SW_VERSION with a monolithic driver (where *
could be either Module, Node, or Unit), and they don't provide a
way of encoding arbitrary number of layers of drivers into the
Config ROM.  Under this idea, all other layers would have to
be queried using the identified driver.  And this makes sense
when we remember that 1212 is a Control and Status REGISTER
Architecture.  Now we're trying to encode things well beyond
the register layer.  :-)

> looking from the point of 1212 (and any protocols).

We may also need to look at the problem of how to encode multiple
layers of protocols needed to access a function.

-- 
Greg Shue
Hewlett-Packard Company
Office Products Division			[email-masked]
----------------------------------------------------------------