Subject: RE: P1394> Agenda Items - Presentations etc.

From: "Atsushi Nakamura" <[email-masked]>
Date: Fri, 15 May 1998 09:34:43 +0900

Please add FDS review and usage examples to the agenda.
Thank you.

Ats Nakamura

-----Original Message-----
差出人 : Gregory A. LeClair <[email-masked]>
宛先 : '1394 PWG' <[email-masked]>
日時 : 1998年5月15日 7:06
件名 : P1394> Agenda Items - Presentations etc.

>Pardon my lateness.
>
>If anyone has specific agenda ideas, needs, etc. please let me know.
>I'm putting together the agenda for WASH / VA meeting now.
>
>My rough idea follows:
>
>Thanks,
>Greg LeClair
>[email-masked]
>
>================
>Rough Ideas
>
>Discussion items
> - Monterey PWG mtg.
> - PWG-C / PWG mtg.
> - p1212r colocation for Monterey mtg.
>
> - p1212r activities - Greg / Others?
> - ip/1394 activities 
> - Rev 0.3 profile issues - Alan?
> - Dynamic LUNs - Alan
> - Config ROM - Greg
> - SBP-2 Model Issues - Alan
> - Profile Publication
> - Need RAC assigned number
> - Schedule next meeting / telecon
>
>
>
>
>

---

From: Nagasaka Fumio <[email-masked]>
Date: Fri, 15 May 1998 09:48:57 +0900

Hi Greg,

Please add short review for SBP-2 printing under current OS in the
agenda.

Some consumer OS do not support unsolicited status, thus we need to
discuss whether we shall define reverse direction without unsolicited
status
or not. Also please see my PDF file attached previous e-mail,

Thank you,
--------------------------------------------
-------------------------------
Fumio Nagasaka
Epson Software Development Laboratory Inc.
Tel +81 268 25 4111,  Fax +81 268 25 4627
E-mail to [email-masked]

	-----Original Message-----
	From:	Gregory A. LeClair [SMTP:[email-masked]]
	Sent:	Friday, May 15, 1998 6:59 AM
	To:	'1394 PWG'
	Subject:	P1394> Agenda Items - Presentations etc.

	Pardon my lateness.

	If anyone has specific agenda ideas, needs, etc. please let me
know.
	I'm putting together the agenda for WASH / VA meeting now.

	My rough idea follows:

	Thanks,
	Greg LeClair
	[email-masked]

	================
	Rough Ideas

	Discussion items
	 - Monterey PWG mtg.
	 - PWG-C / PWG mtg.

---

From: "Eric Anderson" <[email-masked]>
Date: 17 May 98 22:16:24 -0700

In my opinion, if an OS does not support unsolicited status, then
that OS does not support SBP-2.  I cannot imagine that a consumer
OS would not have full SBP-2 support.  I suggest that you should
ask the OS vendor to support unsolicited status, or to explain how
it can be used.

Mac OS will have full support for unsolicited status in SBP-2.

--------------------------------------
Eric Anderson            [email-masked]
Apple Computer, Inc.      408-974-8187
--------------------------------------

---

From: Nagasaka Fumio <[email-masked]>
Date: Mon, 18 May 1998 20:24:44 +0900

Hi Eric,

Thanks for your comment.

I think this unsolicited status problem is not a problem of SBP-2 driver
layer.

In Macintosh OS, a PDEF code resource of a higher level printer driver
usually
uses PBWrite(&pb, Async) and PBRead(&pb, Async).

In Windows OS, a SPOOLER user mode application usually uses WriteFile()
and ReadFile().

As PBRead() or ReadFile() is higher level interface, naturally these
APIs are
abstracted from a specific device level driver. In Mac OS8, a Printer
Expert or
PDEFs shall be abstracted from the FSL. Also in Windows, a SPOOLER
shall be abstracted from the SBP-2 Class Driver. Usually these input
functions
are associated with input queues for normal reverse data path from
peripherals.

---

From: Nagasaka Fumio <[email-masked]>
Date: Tue, 19 May 1998 13:19:13 +0900

[Re-send]

My previous mail was broken. I am sorry for inconvenience. 

-----Original Message-----
From:	Nagasaka Fumio 
Sent:	Monday, May 18, 1998 8:25 PM
To:	'Eric Anderson'; [email-masked]
Subject:	RE: P1394> Agenda Items - Presentations etc.

Hi Eric,

Thanks for your comment.