Subject: RE: P1394> May 1394 PWG Definitions

From: "Gregory A. LeClair" <[email-masked]>
Date: Fri, 22 May 1998 09:15:53 -0700

We equated a function to a unit directory. We called it a 'Unit' to equate 
it to the 1212 unit definition.

If we need to include function from the point of view of 1212r - (based on 
what we've been discussing)

A printer (Function) may be implemented with one or more protocols (Units) 
which may allow access to one or more services (LUNs)

Therefore, the definition of function would seem to be
'The higher level capability of the Module / device which is accessed by 
one of the Units. A singular function may be supported by more than one 
Unit.'

Comments?

Greg

-----Original Message-----
From:	[email-masked] 
[SMTP:[email-masked]]
Sent:	Friday, May 22, 1998 8:23 AM
To:	[email-masked]
Cc:	[email-masked]; [email-masked]
Subject:	RE: P1394> May 1394 PWG Definitions

I am still unclear about the definition of a function vs unit & service.

I do believe that since the PWG has found 1212 to be normative the 1212 
definition and the PWG definition should serve the same purpose.

     Alan

______________________________ Reply Separator 
_________________________________
Subject: RE: P1394> May 1394 PWG Definitions
Author:  Non-HP-atsnaka ([email-masked]) at HP-Roseville,mimegw3
Date:    5/22/98 12:14 AM

First of all,
The defintion of "function" is for p1212r FDS purposes.
We may not even have to define "function" for the PWG profile, but it is 
needed
 for FDS.
I apologize if I should of done this in the 1212 reflector.

Alan said;
>
>The definition of a function seems to indicate that a function is a unit.
>

It CAN be considered that way in a ceratin implementation, but we CONNOT
say that is the ONLY way we have to see it.
 (Especially in the case of FDS, where we have to start thinking
about other protocols.)
At one point in the discussison, Brian had mentioned that some people may
consider a service as a function, and visa-versa. I agree to this idea, and 
I gu
ess
we are not allowed to give an answer (restriction) to the relationship 
between a
function and a  unit.
We agreed a unit corresponds to a driver (in the case of the PWG profile).
If so, the relationship of a driver to a function is implementation 
specific.

The only restrictions I think I can make for "function" are :

1) A part of the unit architecture (not meaning a part of the unit, but 
meaning
    a part of this architecture i.e. part of a node, module, or whatever)
2) A collection(meaning 1 or more) of services
3) User identifiable

I cannot think of more resrtictions to add and still make the definition 
consist
ant
within 1212

ats

>
>by Atsushi Nakamura
>----
>My shot at definition of "function":
>A function is part of the unit architecture and is an instance of a device 
>model, e.g.,   mass storage, CD-ROM or printer. A function is usually a
>collection of services that are user identifiable.
>-----
>
>The definition of a function seems to indicate that a function is a unit.
>

---

From: [email-masked]
Date: Fri, 22 May 1998 14:04:25 -0700

Sounds to me like Greg is starting to zone in on what a function is.

     Only part that does not quit gel is that since a function can be made up of 
     one or more units then do we differ from the 1212 function == unit view?

     Alan

______________________________ Reply Separator _________________________________
Subject: RE: P1394> May 1394 PWG Definitions
Author:  Non-HP-gleclair ([email-masked]) at HP-Roseville,uugw3
Date:    5/22/98 9:15 AM

     

Comments?
     
Greg

-----Original Message-----

     
     Alan

First of all,
     
Alan said;

     

ats