Subject: P1394> Minutes Posted

From: [email-masked]
Date: Mon, 10 Nov 97 13:26:24 -0800

The minutes from Boulder on 10/27 and 10/28 have been posted.

     Greg

---

From: "Atsushi Nakamura" <[email-masked]>
Date: Tue, 11 Nov 1997 16:51:33 +0900

I apologize for not attending the Denver PWG meeting.

I would like to clarify understanding of the current FDS06 proposal.
(FDS06 is just re-wording of FDS05. Nothing has changed contents-wise.)

The 3 contents of FDS is as follows;

1: A function class list (1 function class entry per function)
2: A supported-protocol list (Information on protocolS supported by EACH function.)
3: A pointerand/or location for further function information 
   (ex. function model ID etc...)

Corresponding directories in FDS06 is as follows;

1. =>Function Class Directory
2. =>Function Descriptor Directory
3. =>Function Unit Info Block (Directory)

>From reading the minutes from PWG Denver, I have impression that 
   2; A supported-protocol-list =>Function Descriptor Dir
has been neglected, and the 
Function Unit Info Block has been renamed the
Function Descriptor Dir..   

All entries of this protocol list,
 which includes a unit(funct.)_spec_id and 
 unit(funct.)_sw_ver, and the pointer to corresponding unit directory
 for EACH protocol supported by the function,
is necessary because;

This directory, with the Unit(funct.)_spec_id and
Unit(funct.)_sw_ver entries of all the supported protocols
included will inform ALL of the protocols supported by the function
IN A SINGLE BLOCK READ (and the pointer to the unit directory,
in case you find the matching protocol).
This will be VERY EFFICIENT in reading out the ROM, and will make full
use of block reads, which was suggested for ROM read-out at the 
1394TA. 

Just pointers will require you to read each individual unit directories
until you find the matching protocol.

We all are assuming by now that printers will support at least 2 protocols,
and the block read will be efficient.

If the function descriptor directory exists as it was origionally define 
(as above), it is unnatural to point to it from the unit directories, it should be the
function unit info block that has possiblilty to be pointed from the unit diorectory,
and this is for discussion.

One last item, SDD defines a entry for model vendor and model ID.
Would it be wise to define the same contents in the unit directory ?

p.s. My personal impression of the TA on the subject of FDS,
     There was no "TA feedback", the presentation was just informative,
     and the opinions were personal, as far as I know

Atsushi Nakamura
BJ Printing Technology Development 22
Canon Inc.
------------------------------------
 [email-masked]
 [email-masked]

----------
> ·ol : [email-masked]
> ˆ¶æ : [email-masked]
> Œ–¼ : P1394> Minutes Posted
> ‘—M“úŽž : 1997”N11ŒŽ11“ú 6:26
> 
>