Subject: P1394> RE:Results of IEEE MSC Meeting on 7/14

From: "Atsushi Nakamura" <[email-masked]>
Date: Thu, 17 Jul 1997 10:50:54 +0900

First, I 'd like to thank Greg and other attendeees from PWG for
the effort at MSC.

Some confirmation for my understanding ;

------------
Since the MSC has agreed to take the function discovery 
issue up at the IEEE1212 revision working group,
does that mean;

1) The MSC sees the function discovery issue as a 
    IEEE1212 problem, not only a IEEE1394 issue?
    (PCI....etc?)

2) The MSC sees the origional intent of the 
    IEEE1212's definition of the unit directory
    IS protocol discovery after all, not function discovery.

OR,
Is this just the beginning of this disscusion?
Was there any technical disscusion to backup the idea 
for the function discovery be incorporated with 1212? 
I am afraid that we will have to start taking other buses 
(using IEEE1212) into consideration.

------------
>      It was agreed that Greg LeClair would chair the group tasked with
>      making a proposal to the IEEE 1212 working group for function unit
>      discovery

This group would be the PWG/PWG-C, not a new group,right?

--------------------------------------------
Atsushi Nakamura
BJ Printing Technology Development 22
Canon Inc.
email: [email-masked]

---

From: "gregory leclair" <[email-masked]>
Date: Wed, 16 Jul 97 19:19:02 PDT

Ats Nakamura wrote:
==================  

GL>The intent was that some information may fit into 1212.

GL>If it does, it should be proposed within the context of the 1212 spec. 
GL>Since 1212 is up for reaffirmation, this is the time to make requests known.

GL>We need to identify what information, if any, can/should be put into 1212 
GL>space that will solve the function discovery problem.

GL>Yes

GL>Some

GL>They may feel the same way.

GL>This is part of the 1212 WG - we're merely a task group. 
GL>My plan is that this will be discussed at PWG meetings.
GL>I can't speak for PWG-C or DSI-WG or 1394 TA.

     Greg LeClair
     
     >>>>>>------------------------------------------->>>>>> 
     EPSON IMAGING TECHNOLOGY CENTER      [email-masked]  
     2833 Junction Ave., Suite 200        408.474.0500.x3610
     San Jose, CA 95134                   408.474.0511  FAX

---

From: Atsushi_Nakamura <[email-masked]>
Date: Thu, 17 Jul 1997 17:46:32 +0900

Greg,

Is my understanding right that IF in the course of disscusion,
it turns out that the contents of Function discovery is 
more suitable for the 1394 spec and not 1212, 
the target of our proposal may change ? 
 
I believe that we already have general concensus on what 
information (not yet how....) should be put in the Function
discovery scheme.(In Japan)
 
P.S.
Many PWG-C members would like to know how this Function discovery
turned out to be a 1212 issue, not a 1394 issue.

> GL>space that will solve the function discovery problem.

-----------------------------------------
Atsushi Nakamura
-----------------------------------------
BJ Printing Technology
Develpoment 22,
Canon Inc.
tel:+81-3-5482-8396
fax:+81-3-3756-6052
email-1:[email-masked]
email-2:[email-masked]
-----------------------------------------

---

From: "Oktay, Ozay" <[email-masked]>
Date: Thu, 17 Jul 1997 15:34:48 -0700

I agree with Nakamura-san..

The disadvantages of involving another group (ie 1212) will definitely
outweigh the advantages. The Functional Discovery issue should be dealt
with under 1394..

Best Regards
Ozay Oktay

Canon Information Systems
[email-masked]

>----------
>From: 	Atsushi_Nakamura[SMTP:[email-masked]]
>Sent: 	Thursday, July 17, 1997 1:46 AM
>To: 	[email-masked]
>Subject: 	Re: P1394> RE:Results of IEEE MSC Meeting on 7/14
>
>Greg,
>

---

From: [email-masked]
Date: Thu, 17 Jul 1997 20:13:16 -0400

At the Nashua meeting, I said that because of where we want function
discovery to operate, i.e. at the ROM level using the directories, etc. as
defined by IEEE Standard 1212, there was a real chance that this would be
perceived as really a part of 1212.  Because 1212 is currently open for
revision (it is 5 years old and there are a handful of things that need to
be updated and fixed) the MSC believed that creating a 1212.x standard
which is effectively a supplement to 1212,  would be rejected by the IEEE
New Standards Committee.  For this same reason, it was the opinion of the
MSC that this is not a 1394 specific standard but should be applied to all
the projects (e.g. FutureBus) which also uses 1212.

The structure of this work was specifically divided to prevent our group
from being loaded down with the base 1212 changes.  The PWG/PWG-C are
considered a task group that are only charged with working on the function
discovery issues.  Our changes and additions will be applied into the
standard by the 1212 editor.  By the way, the 1212 work is on an
accelerated schedule and because we won't have to create an entire standard
from scratch we will probably be able to pull this off faster.
Additionally, because the 1212 chair, David James, is working on this as
well (along with Peter Johansson, and others) we have some built in
advisors to keep us on the right track.

I hope this helps to explain what went on.

Don

**********************************************
* Don Wright                 [email-masked] *
* Manager, Strategic Alliances and Standards *
* Lexmark International                      *
* 740 New Circle Rd                          *
* Lexington, Ky 40550                        *
* 606-232-4808 (phone) 606-232-6740 (fax)    *
**********************************************

---

From: Larry Stein <[email-masked]>
Date: Fri, 18 Jul 1997 08:16:52 -0700

Hello to all,

Sorry I missed the last meeting.

With regards to this issue of 1212 vs 1394 I have a few comments.
I think that the 1394PWG was well represented at the MSC meeting.  Greg,
Don and I were there for the discussion.  

For the past few 1394PWC/PWG-C meetings we have focused on the 1212
standard as the method to implement the Device and Function Discovery.  A
number of times the question was raised as to whether this is a 1212 or
1394 issue.  This subject was discussed at length at the MSC meeting.  The
committee felt that this was best placed under 1212 for the following reasons:

1- This methodology can be applied to interfaces other than 1394
2- Since the 1212 spec is open for reaffirmation this gives us more 
   flexibility in defining the discovery mechanism.
3- We don't have the overhead of creating a new IEEE committee for this.
   This means we could go to ballot before the end of the year.
   There is a push to have this done by December.  Impossible as a new 
   IEEE committee.
4- There are just a few additional minor 1212 issues.  So there will be very 
   little impact on what we are doing.
5- As the only 1212 "task group", we will meet just as we are now.  No 
   change in our procedure.
6- This doesn't effect the printing protocol part of our discussions.

For these reasons it seems to me that this is a good way to proceed.  If
two months from now we find that we need a separate path then that is still
available.

Thanks,
Larry

>>> GL>space that will solve the function discovery problem.
*****************************************************************************
Larry A. Stein			Phone: (619)292-2740
Warp Nine Engineering		Fax:	(619)292-8020
					Web: 	http://www.fapo.com
*****************************************************************************