Subject: JMP> jmTimeStamp

From: Harry Lewis <[email-masked]>
Date: Mon, 13 Oct 1997 19:40:42 -0400

We've run into an observation, here, regarding the units and range of TimeStamp
(seconds) and the range of sysUpTime.
The jmTimeStampTC  can count to appx 68 years, in seconds,  while sysUpTime
represents time in 100ths of a second and, resets appx every 1.36 years

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Tue, 14 Oct 1997 05:47:10 PDT

Hi Harry,

Are you suggesting that 'JmTimeStampTC' be changed to units of
'TimeTicks' like 'sysUpTime' (in MIB-II)?  I think the rationale
for units of seconds was to avoid the appearance of demanding
accuracy in 'TimeTicks' for processing info on print jobs,
which is unlikely to be of use to client applications anyway.

Separately, by a poor design decision, TimeTicks was made a
fundamentally different syntax (over-the-wire) in SMIv1 and
SMIv2, so that it CAN'T be stored in an 'INTEGER' type
(in the job attribute table).  So if we change the units
of 'JmTimeStampTC' to hundredths of a second, we STILL
need the TC, to avoid trying to use ACTUAL 'TimeTicks'
syntax for job attributes.

Does your implementation team think we should align the
units?  While an SNMP agent may know time in 'TimeTicks',
a print language interpreter may NOT have available
such accuracy (to supply the values for job attributes).

Cheers,
- Ira McDonald (outside consultant at Xerox)
-------------------------- Harry's note --------------------------
>From [email-masked] Mon Oct 13 19:44:46 1997
From: Harry Lewis <[email-masked]>
To: <[email-masked]>
Subject: JMP> jmTimeStamp
Date: Mon, 13 Oct 1997 16:40:42 PDT
Sender: [email-masked]
Status: R

We've run into an observation, here, regarding the units and range of T=
imeStamp
(seconds) and the range of sysUpTime.
The jmTimeStampTC  can count to appx 68 years, in seconds,  while sysUp=
Time
represents time in 100ths of a second and, resets appx every 1.36 years=

---

From: Harry Lewis <[email-masked]>
Date: Tue, 14 Oct 1997 10:52:53 -0400

Ira, I considered recommending a change back to TimeTicks but I feel it is too
late to suggest such a change and then there are the problems Ira mentioned.
Rather, I just wanted to point out the difference in range and precision and
clarify that a printer implementation is most likely to divide sysUpTime by
100, thus never utilizing a great portion of the specified range. So, I suggest
documenting a shorter range.

Harry Lewis

----- Ira's Note ----

[email-masked] on 10/14/97 06:56:07 AM
Please respond to [email-masked] @ internet
To: [email-masked] @ internet, Harry Lewis/Boulder/IBM@ibmus
cc:
Subject: Re:  JMP> jmTimeStamp

Hi Harry,

Cheers,