Subject: JMP> ACTION: Please do protocol mapping as part of your JMP review

From: Tom Hastings <[email-masked]>
Date: Fri, 13 Jun 1997 10:04:20 PDT

Its time to do the job submission protocol mapping to the JMP Job Monitoring
MIB spec as part of the review of the MIB.  Please do this before
the upcoming meeting, so that we can review the mappings as part of the
JMP review.  This is a "paper bake off".

I've put a new template into:

ftp::/ftp.pwg.org/pub/pwg/jmp/protomap/
-rw-r--r--   1 pwg      pwg        46592 Jun 13 16:43 jmtmplt2.doc

The following people have been assigned to do the mappings.  If you cannot
do your assignment, please respond to me with a substitute name.

Job Submission  file name	Responsible person
Protocol	
AppleTalk PAP	applepap.doc	Ron Bergman
IPDS	        ipds.doc	Harry Lewis
ISO DPA	        iso-dpa.doc	Tom Hastings
LPR/LPD 	lpr-lpd.doc	Ron Bergman
NDPS	        ndps.doc	Scott Isaacson
PJL	        pjl.doc	        Bob Pennacost
PostScript	ps.doc	        Bob Setterbo
PSERVER	        pserver.doc	Scott Isaacson
RPRINTER	rprinter.doc	Scott Isaacson
SMB	        smb.doc	        Bob Setterbo
TIPSI/NPAP	tipsi.doc	Don Wright

I've put each object and attribute from the Table of contents into
the template, along with the page number from the jmp-mibv.pdf version (0.82
that corresonds to the Internet-Draft 01) which is the file you should be 
using.

So get out the template, look at the page number and read the MIB spec
to see if that attribute or object is settable or queriable in your
job submission protocol.

Put the name of the attribute in your protocol next to the JMP object
or attribute.  Put any comments, questions, data conversion, issues in the 
Notes column.

I've listed each of the jobState and jobStateReasons1 values as well.

Thanks,
Tom

Here are the detaile instructions from the template:

1. Copy jmtmplt2.doc from ftp://ftp.pwg.org/pub/pwg/jmp/protomap/jmtmplt1.doc.
2. Fill in the first five lines of information about your job submission
protocol immediately after the "cut here" line.
3. Delete the template before and including the "cut here".
4. Please go read each attribute, so that you are sure that the mapping is
correct and to be part of the review process on the MIB itself.  The page
numbers correspond to the line numbered version with variable pitch font
(jmp-mibv.pdf, V0.82), which is the one we should be using for review.  If
you find a description that is unclear or ambiguous, please make a note and
send as e-mail or enter it in the Notes column here.  We need to fix
ambiguities now, not after we are a proposed standard.
 
5. Edit in the name of each of the job submission protocol attributes that
corresponds to each of the object/attribute in the table below.  For the
attributes that are read-only in your job submission protocol, such as
jmGeneralNumberOfActiveJobs, jobState, and pagesConsumed, enter the name of
the attribute in your job submission protocol, if it is querable with your
job submission protocol, otherwise leave blank.
6. For objects/attributes that do not have a corresponding attribute in your
job submission protocol, please leave blank.
7. If you aren't sure whether the job attribute you found is correct, put a
question mark after the name of your job submission protocol attribute.
8. Add any notes to the last column labeled NOTES.
9. Rename your file to the xxx.doc file name indicated below for your job
submission protocol.
10. Post your file in:
    ftp://ftp.external.hp.com/snmpmib/jobs-mib/protomap/xxx.doc
11. Send mail to the jmp list indicating that you have posted your mapping.

---

From: Bob Pentecost <[email-masked]>
Date: Tue, 24 Jun 1997 21:13:02 -0600

I forgot to send this to JMP as well as to Tom. Oops!

----------
From:  Bob Pentecost[SMTP:[email-masked]]
Sent:  Tuesday, June 24, 1997 11:45 AM
To:  'Tom Hastings'
Subject:  RE: JMP> ACTION: Please do protocol mapping as part of your JMP review

I have completed the job submission protocol mapping to the JMP Job Monitoring MIB spec as part of the review of the MIB. Tom had requested that I do:
PJL	        pjl.doc	        Bob Pennacost
(at least I think he was referring to me via the creative spelling of my name :-).

You can find the file at:
ftp://ftp.pwg.org/pub/pwg/jmp/protomap/pjl.doc
(I think Tom wanted it there and not on ftp.external.hp.com where he said to put it).

I have included PJL along with HP's proprietary MIB objects in the table.

I will also bring copies to the JMP meeting on Friday.

Bob Pentecost
HP

----------
From:  Tom Hastings[SMTP:[email-masked]]
Sent:  Friday, June 13, 1997 11:04 AM
To:  [email-masked]
Subject:  JMP> ACTION: Please do protocol mapping as part of your JMP review

Thanks,
Tom

---

From: Tom Hastings <[email-masked]>
Date: Tue, 24 Jun 1997 23:36:11 PDT

Bob,

Thanks for posting.  I hope that others have contributions.

I put a .pdf file there too:

ftp://ftp.pwg.org/pub/pwg/jmp/protomap/
-rw-r--r--   1 pwg      pwg        33792 Jun 24 17:32 pjl.doc
-rw-r--r--   1 pwg      pwg        34232 Jun 25 06:34 pjl.pdf

Sorry about your name being misspelled and the old URL for posting.
I cut and pasted from a year old file when the PWG server was hosted
by HP.

Tom

At 20:13 06/24/97 PDT, Bob Pentecost wrote:
>I have completed the job submission protocol mapping to the JMP Job
Monitoring MIB spec as part of the review of the MIB. Tom had requested that