Subject: Re: JMP> Re: IPP> MOD JobState suggestion

From: Tom Hastings <[email-masked]>
Date: Thu, 5 Jun 1997 08:38:50 PDT

I agree that canceled can be entered from any state and that a system
might (but need not) abort a stopped job.

The definition of the aborted state for IPP and JMP supports your
idea with the weasil word "usually" in the definition:

aborted:
The job has been aborted by the system, usually while the job was in the
processing state.

So how does this picture look to you for IPP and JMP (IPP wouldn't
have the enums and wouldn't have the "active/in-active" line, since
it is a JMP-only term).

Running arrows from every state to canceled and from stopped to
aborted would look like this:

>>              +--------->----------+------>------+--> canceled(7)
>>              |                    |             |
>>     +---> pending(3) -------> processing(5) -------> completed(9)
>>     |        ^                    ^  \          |
>> --->+        |                    |   +------------> aborted(8)
>>     |        v                    v  /          |
>>     +---> held(4)             stopped(6)        |
                |                    |             |
                +--------->----------+------>------+
>> 
>>           <-------------- active ------------>|<-- in-active -->|
>> 

Is this figure ok?

At 12:49 06/04/97 PDT, Harry Lewis wrote:
>I think there is a problem with the state diagram
>
>
>                                                +--> canceled(7)
>                                               /
>    +---> pending(3) ----> processing(5) -----+----> aborted(8)
>    |        ^                    ^            \
>--->+        |                    |             +--> completed(9)
>    |        v                    |
>    +---> held(4)    processing-stopped(6)
>
>In that it does not show the ability to cancel a job from Held or
>Needs-Attention (processing-stopped) states. It is also quite possible
>that a job in Needs-Attention state would ultimately abort.
>
>I recommend the following changes to the diagram...
>
>
>                                                +--> canceled(7)
>                                               /
>    +---> pending(3) ----> processing(5) ---+-+----> aborted(8)
>    |        ^                    ^         |  \
>--->+        |                    |         |   +--> completed(9)
>    |        v                    v         |
>    +---> held(4)    processing-stopped(6)  |
>             |                    |         |
>             +--------------------+---------+
>
>
>
>Harry Lewis - IBM Printing Systems
>
>

---

From: Ron Bergman <[email-masked]>
Date: Thu, 5 Jun 1997 10:05:35 -0700 (PDT)

Tom,

I agree that you new revised figure is correct.  But it has so 
many lines and lines crossing that I doubt it is useful.

I propose that we keep the original figure, but show the two paths
to "Aborted", with the added text:

"The Canceled state can be entered from the Pending, Pending-Held, 
Processing, or Processing-Stopped states."

	Ron Bergman
	Dataproducts Corp.