Subject: Re: JMP> Re: IPP> MOD JobState suggestion

From: Tom Hastings <[email-masked]>
Date: Thu, 5 Jun 1997 16:52:37 PDT

Sounds simpler.  So how is this for JMP:

JmJobStateTC ::= TEXTUAL-CONVENTION
STATUS      current
DESCRIPTION
"The current state of the job (pending, processing, completed, etc.).

The following figure shows the normal job state transitions:

                                                    +--> canceled(7)
                                                   /
    +---> pending(3) --------> processing(5) -----+----> completed(9)
    |        ^                      ^              \
--->+        |                      |               +--> aborted(8)
    |        v                      v              /
    +---> pendingHeld(4)   processingStopped(6) --+

        <--------------- active -----------------> <--- in-active --->
                Figure 4 - Normal Job State Transitions

Normally a job progresses only from left to right.  Other state transitions
are unlikely, but are not forbidden.  The canceled state can be entered from
the pending, pendingHeld, processing, or processingStopped states."

-- This is a type 2 enumeration.  See Section 7.1 on page 25.
SYNTAX      INTEGER {
other(1),		

At 10:05 06/05/97 PDT, Ron Bergman wrote:
>Tom,
>
>I agree that you new revised figure is correct.  But it has so 
>many lines and lines crossing that I doubt it is useful.
>
>I propose that we keep the original figure, but show the two paths
>to "Aborted", with the added text:
>
>"The Canceled state can be entered from the Pending, Pending-Held, 
>Processing, or Processing-Stopped states."
>
>
>	Ron Bergman
>	Dataproducts Corp.
>
>
>On Thu, 5 Jun 1997, Tom Hastings wrote:
>
>> I agree that canceled can be entered from any state and that a system
>> might (but need not) abort a stopped job.
>> 
>> The definition of the aborted state for IPP and JMP supports your
>> idea with the weasil word "usually" in the definition:
>> 
>> aborted:
>> The job has been aborted by the system, usually while the job was in the
>> processing state.
>> 
>> So how does this picture look to you for IPP and JMP (IPP wouldn't
>> have the enums and wouldn't have the "active/in-active" line, since
>> it is a JMP-only term).
>> 
>> Running arrows from every state to canceled and from stopped to
>> aborted would look like this:
>> 
>> >>              +--------->----------+------>------+--> canceled(7)
>> >>              |                    |             |
>> >>     +---> pending(3) -------> processing(5) -------> completed(9)
>> >>     |        ^                    ^  \          |
>> >> --->+        |                    |   +------------> aborted(8)
>> >>     |        v                    v  /          |
>> >>     +---> held(4)             stopped(6)        |
>>                 |                    |             |
>>                 +--------->----------+------>------+
>> >> 
>> >>           <-------------- active ------------>|<-- in-active -->|
>> >> 
>> 
>> Is this figure ok?
>
>
>

---

From: Ron Bergman <[email-masked]>
Date: Thu, 5 Jun 1997 18:12:12 -0700 (PDT)

Tom,

Looks good.  Any objections from anyone else?

	Ron Bergman