Subject: JMP> Should jobStateReasons1 be mandatory?

From: Harry Lewis <[email-masked]>
Date: Fri, 23 May 1997 14:40:03 -0400

Yes, I'm saying that jobStateReasons is something a DPA server might know about
but not (practically) many printers.

>Your comments lead me to believe you're saying that it's too damn
>difficult for the printer agent to say what the current "reason" is.
>Is this true?  If it is, then I think we're in real deep water here.

There are 4 sets of jobStateReasons... just look at the first (presumably
most importatn?) set...

 canceledByUser, canceledByOperator, abortedBySystem, logfilePending,
 jobRetained etc.

>I just went thru the V0.81 draft, but couldn't find 7.5 pages of
>Job State Reasons in the MIB.  Can you give me a better pointer?
>(Am I looking at the proper draft?)  I did find some tables on
>various Reasons (pp. 57-58), but I guess I don't see the problem.

In v0.81 the PDF version (I think) see pages 49-56.

Harry Lewis - IBM Printing Systems

---

From: Tom Hastings <[email-masked]>
Date: Tue, 27 May 1997 14:38:12 PDT

Harry,

It was on this mail and Jay's that I concluded we had JMP agreement on
making jobStateReasons1 attribute mandatory and I made the second
step of moving it to the jmJobTable, as we agreed for all mandatory
attributes in San Diego.  Making it mandatory also agrees with IPP.

Tom

---

From: Harry Lewis <[email-masked]>
Date: Tue, 27 May 1997 20:16:41 -0400

So, let me understand...

>Tom

You are proposing that jmJobTable contain a mandatory OID for
jobStateReasons1.  But, if, of the 20 reasons specified, a printer
can only "detect" the 4 that I have marked with (*), below, that's acceptable,
right?

*other
*unknown
*no reason (all zeros)
 documentsNeeded
 jobHoldSet
 jobProcessAfterSpecified
 requiredResourceNotReady
*successfulCompletion
 completedWithWarnings
 completedWithErrors
 canceledByUser
 canceledByOperator
 abortedBySystem
 logfilePending
 logfileTransferring
 jobPreProcessing
 jobPaused
 jobInterrupted
 jobRetained
 jobHoldUntil

---

From: Tom Hastings <[email-masked]>
Date: Wed, 28 May 1997 08:56:21 PDT

>can only "detect" the 4 that I have marked with (*), below, that's acceptable,

Almost.  Even though the jmJobStateReason1 object is mandatory because
its in a Mandatory group, we get to decide on a enum by enum basis
which ones are mandatory (agent shall implement whether printer has or not)
which are conditionally mandatory (agent shall implement, but only if the
                                   printer has that behavior)
and which ones are optional (agent doesn't have to imlement, even if the
                                   printer has that behavior)

Most of the reasons are conditionally mandatory.  The mandatory ones
are indicate below with "Man":

Please use the list in the joint IPP/JMP jobstate.* files that I posted
yesterday:

    JMP jobStateReasons1 values
    other
    unknown
Man jobIncoming
OPT jobOutgoing
    jobHeld
    jobHoldSpecified, jobHeld
    jobHoldUntilSpecified, jobHeld
    jobHoldUntilResourcesAreReady,jobHeld
    jobProcessAfterSpecified, jobHeld
OPT deviceStoppedPartly
MAN deviceStopped
OPT jobPrinting
    jobCanceledByUser
    jobCanceledByOperator
OPT logfilePending
OPT logfileTransferring
MAN jobCompletedSuccessfully
MAN jobCompletedWithWarnings
MAN jobCompletedWithErrors
    jobPaused
    jobInterrupted
    jobRetained

---

From: Harry Lewis <[email-masked]>
Date: Wed, 28 May 1997 19:54:09 -0400

I'll repeat ... I don't see how we can make a particular state mandatory
but for the sake of discussion... how can we possibly label "jobPrinting"
as Optional but jobCompletedWithWarnings and jobCompletedWithErrors
Mandatory? I can guarantee it will be easier for some printer job agents
to be aware that the job is Printing then to know whether or not warnings
or errors were encountered on the way to the stacker!

---------------------- Forwarded by Harry Lewis/Boulder/IBM on 05/28/97 05:35 PM
 ---------------------------

        [email-masked]
        05/28/97 10:31 AM
Please respond to [email-masked] @ internet

To: Harry Lewis/Boulder/IBM@IBMUS
cc: [email-masked] @ internet
Subject: Re: JMP> Should jobStateReasons1 be mandatory?