Subject: Re: JMP> Re: RFC 2119, March 1997 has conformance language s

From: Harry Lewis <[email-masked]>
Date: Thu, 22 May 1997 18:09:05 -0400

In my opinion, it doesn't matter if these words are capitalize or not. I
recommend against their use entirely.
The very fact that these words need an RFC to define them indicates, to me,
that they are too vague for
use in a specification.

As an example:

Rather than say  "... the Job Submission Attributes SHALL overide the PDL job
attributes" it would be more
concise to say "... the Job Submission Attributes overide the PDL job
attributes".

But, alas, I'm probably dabbling in IETF or Standards heresy, here, so ... on
to other mail messages.

Harry Lewis - IBM Printing Systems

------ Forwarded by Harry Lewis/Boulder/IBM on 05/22/97 03:43 PM ------

        [email-masked]
        05/22/97 10:27 AM
Please respond to [email-masked] @ internet

To: [email-masked] @ internet
cc: [email-masked] @ internet
Subject: Re: JMP> Re: RFC 2119, March 1997 has conformance language s

Tom,

I would recommend that these terms be capitalized only if absolutely
required or if strongly recommended by Scott Bradner.  Otherwise, lets
leave well-enough alone.

 Ron Bergman

On Thu, 22 May 1997, Tom Hastings wrote:

> I just read the RFC and it defines the following terms and suggests that
> the following phrase be put early in the document:
>
>      The key words "MUST", "MUST NOT", "REQUIRED", "SHALL", "SHALL
>       NOT", "SHOULD", "SHOULD NOT", "RECOMMENDED",  "MAY", and
>       "OPTIONAL" in this document are to be interpreted as described in
>       RFC 2119.
>
> Happily, the "shall", "should", and "may" terms are as the PWG has been using
> in its Printer MIB, Job Monitoring MIB, and IPP documents.
>
> It also has "must" as a synonym for "shall".  I suggest that we continue
> to use "shall", rather than switching over or using a mixture, in order
> to keep our PWG standards using the same terminology.  Ok?
>
> It also says: "These words are often capitalized."
> I've sent mail to Scott Bradner asking whether it is recommended to
> capitalize.  Seems like it would make these terms stand out more.
>
> Should I capitalize SHALL, SHOULD, MAY (and NEED NOT) in the Job Monitoring
> MIB?  What about IPP documents?
>
> Thanks,
> Tom
>
> At 23:46 05/21/97 PDT, Tom Hastings wrote:
> >Thanks Larry,
> >
> >Tom
> >
> >>Return-Path: <[email-masked]>
> >>Date: Wed, 21 May 1997 23:08:45 PDT
> >>From: Larry Masinter <[email-masked]>
> >>Organization: Xerox PARC
> >>To: Tom Hastings <[email-masked]>
> >>Subject: Re: IPP> MOD - 5/14 mintues
> >>References: <[email-masked]>
> >>
> >>RFC 2119: Key words for use in RFCs to Indicate Requirement Level. S.
> >>Bradner. March 1997. (Format: TXT=4723 bytes) (Updated by BCP0014)
> >>--
> >>
> >>Larry
> >>--
> >>http://www.parc.xerox.com/masinter
> >>
> >>
> >
> >
> >
>
>

---

From: Tom Hastings <[email-masked]>
Date: Fri, 23 May 1997 12:37:59 PDT

>concise to say "... the Job Submission Attributes overide the PDL job

The problem is that your second sentence is stated as declaration of fact
or a definition of "Job Submission Attribute", rather than of something that 
is required that an implementation do in order to conform to the standard.

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Sat, 24 May 1997 08:04:58 PDT

Hi Harry and Tom,

To amplify Tom's point below, a well-written standard is structured
around statements like:

"Conforming management [agents|stations] [shall|should|may]
perform some action..."

You want to state conformance requirements on implementations,
not on the mere semantics/behavior of objects.

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839

>--------------------------- Included Message ---------------------------<
>From [email-masked] Fri May 23 15:51:16 1997
Date: Fri, 23 May 1997 12:37:59 PDT
To: [email-masked], Harry Lewis <[email-masked]>
From: Tom Hastings <[email-masked]>
Subject: Re: JMP> Re: RFC 2119, March 1997 has conformance language s
Sender: [email-masked]
Status: R