Subject: JMP> List of updated JMP objects and attributes

From: Tom Hastings <[email-masked]>
Date: Sun, 25 May 1997 02:42:53 PDT

I've edited the list of Job Monitoring MIB objects and attributes
according to the San Diego meeting and subsequent e-mail.

Please review and make any comment ASAP.  I'm editing these changes now.

ftp://ftp.pwg.org/pub/pwg/jmp/contributions/
-rw-r--r--   1 pwg      pwg        31232 May 25 09:32 obj-attr.doc
-rw-r--r--   1 pwg      pwg        17717 May 25 09:31 obj-attr.pdf
-rw-r--r--   1 pwg      pwg         4377 May 25 09:38 obj-attr.txt

The .doc and .pdf files have revision marks.  The .txt file does not and
is also attached:

SUBJ:  UPDATED JOB MONITORING MIB OBJECT/ATTRIBUTE LIST
From:  Tom Hastings
Date:  5/24/97
File:  obj-attr.doc
The list of agreed additions, deletions, and changes to the
list of Job Monitoring MIB objects and attributes is shown
below with revision marks since the Internet-Draft version
00 which corresponds to version 0.81.  I've included some of
the discussion that has occured on the e-mail list, since
the 5/16/97 JMP meeting in San Diego.  The table of contents
indicates the Mandatory groups and attributes.  If you have
any comments, please send them ASAP, as this is what I'm
editing the MIB to produce.

11. MIB SPECIFICATION
Textual conventions for this MIB module
   JmTimeStampTC - simple time in seconds
   JmJobSourcePlatformTypeTC - operating system platform
   definitions
   JmFinishingTC - device finishing definitions
   JmPrintQualityTC - print quality
   JmPrinterResolution TC - printer resolution
   JmTonerEconomyTC - toner economy setting
   JmMediumTypeTC - medium type definitions
   JmJobStateTC - job state definitions
   JmAttributeTypeTC - attribute type definitions
      other
      unknown
     Job State attributes
      jobStateReasons2
      jobStateReasons3
      jobStateReasons4
      deviceAlertCode
      processingMessage
     Job Identification attributes
      serverAssignedJobName
      jobName
      jobServiceTypes
      jobOwner (mandatory)
      jobAccountName
      jobSourceChannelIndex
      jobSourcePlatformType
      submittingServerName
      submittingApplicationName
      jobOriginatingHost
      deviceNameRequested
      queueNameRequested
      physicalDevice
      numberOfDocuments
      fileName
      documentName
      jobComment
      documentFormatIndex
      documentFormatType
     Job Parameter attributes
      jobPriority
      jobProcessAfterDateAndTime
      jobHoldUntil
      outputBin
      sides
      finishing
     Image Quality attributes (requested and used)
      printQualityRequested
      printQualityUsed
      printerResolutionRequested
      printerResolutionUsed
      tonerEcomonyRequested
      tonerEcomonyUsed
      tonerDensityRequested
      tonerDensityUsed
     Job Progress attributes (requested and consumed)
      jobCopiesRequested
      jobCopiesCompleted
      documentCopiesRequested
      documentCopiesCompleted
      jobKOctetsTransferred
     Impression attributes (requested and consumed)
      impressionsSpooled
      impressionsSentToDevice
      impressionsInterpreted
      impressionsCompletedCurrentCopy
      fullColorImpressionsCompleted
      highlightColorImpressionsCompleted
     Page attributes (requested and consumed)
      pagesRequested
      pagesCompleted
      pagesCompletedCurrentCopy
     Sheet attributes (requested and consumed)
      sheetsRequested
      sheetsCompleted
      sheetsCompletedCurrentCopy
     Resource attributes (requested and consumed)
      mediumRequested
      mediumConsumedName
      colorantRequested
      colorantConsumed
     Time attributes (set by server or device)
      jobSubmissionToServerDateAndTime
      jobTimeSinceSubmissionToDevice
      jobStartedBeingHeldTimeStamp
      jobTimeSinceStartedProcessing
      jobTimeSinceCompleted
      jobProcessingCPUTime
   JmJobServiceTypesTC - bit encoded job service type
   definitions
   JmJobStateReasons1TC - additional information about job
   states
   JmJobStateReasons2TC - More additional information about
   job states
   JmJobStateReasons3TC - More additional information about
   job states
   JmJobStateReasons4TC - More additional information about
   job states
The General Group (Mandatory)
   jmGeneralNumberOfActiveJobs
   jmGeneralOldestActiveJobIndex
   jmGeneralNewestActiveJobIndex
   jmGeneralJobPersistence
   jmGeneralAttributePersistence
   jmGeneralJobSetName
The Job ID Group (Mandatory)
   jmJobSubmissionID
   jmJobSetIndex
   jmJobIndex
The Job Group (Mandatory)
   jmJobState
   jmJobStateReasons1
   jmNumberOfInterventingJobs
   jmJobKOctertsRequested
   jmJobKOctetsProcessed
   jmJobImpressionsRequested
   jmJobImpressionsCompleted
The Attribute Group (Mandatory)
   jmAttributeTypeIndex
   jmAttributeInstanceIndex
   jmAttributeValueAsInteger
   jmAttributeValueAsOctets

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Tue, 27 May 1997 06:39:29 PDT

Hi Tom,                                            Tuesday (27 May 1997)

>Date: Sun, 25 May 1997 02:42:53 PDT
>To: [email-masked]
>From: Tom Hastings <[email-masked]>
>Subject: JMP> List of updated JMP objects and attributes
>

Thanks for this summary list.  My comments:

1)  'jobSourceChannelType' - request we add this attribute parallel to
    'jobSourceChannelIndex' for support of systems which don't implement
    the Printer MIB - also much more useful attribute for accounting;

2)  'jmJobKOctertsRequested' - spelling error;

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839
  906-494-2434

---

From: Harry Lewis <[email-masked]>
Date: Tue, 27 May 1997 14:41:32 -0400

>Please review and make any comment ASAP.  I'm editing these changes now.

Here are my comments:

1. What is the difference between jmJobSourcePlatformType and
   jobOriginatingHost?
2. I notice you deleted jobStateReasons1 and now treat it as a mandatory
   object in the JobTable. I don't recall this agreement.
3. Why did you remove Index from Physical device, OutputBin, colorant,
   and removed type from mediumRequested? Is this due to the fact that
   we have value as integer and octets?

Harry Lewis - IBM Printing Systems

---

From: Tom Hastings <[email-masked]>
Date: Tue, 27 May 1997 13:05:45 PDT

>1. What is the difference between jmJobSourcePlatformType and

jobSourcePlatformType (and corresponding JmJobSourcePlatformTypeTC) is the 
type of system, and is an enum (one of the reasons that I like "Type" in the 
object or attribute name) e.g. UNIX, Windows, etc.

jobOriginatingHost is the name of the host, not its type, e.g., a string
that was assigned to the host by an administrator.  See IPP.  This was
one of the IPP attributes that we agree to pick up into JMP at San Diego.

>   object in the JobTable. I don't recall this agreement.

It was not agreed to at San Diego, but the resulting e-mail discussion
seemed to indicate that a few values are mandatory, so I moved it
from the attribute table to be a real object, since it was only an integer
following our agreed principle in San Diego of moving mandatory attributes
to the jmJobTable, at least the integer ones.

If there is a problem with this, then I can move it back.  But I think this
is also involved with the needsAttention state vs. deviceStopped 
jmJobStateReasons1 value disucssion.

>   we have value as integer and octets?

Yes, as we agreed in San Diego to combine these.  So I had to drop the
data type from the name.  Any other suggestions for the name?  Do you
find this confusing that the name doesn't indicate that there are two
possibl representations and that both can be used together?

---

From: Tom Hastings <[email-masked]>
Date: Tue, 27 May 1997 15:06:53 PDT

>    the Printer MIB - also much more useful attribute for accounting;

I wanted to combine these too, but they are both integers, so we can't.

We can only combine an integer attribute with an octets attribute.

>2)  'jmJobKOctertsRequested' - spelling error;

Thanks.

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Tue, 27 May 1997 18:27:12 PDT

Hi Tom,

I realize we can't combine two attributes of integer type.  My point
was that the (missing) attribute 'jobSourceChannelType' is generally
more interesting than 'jobSourceChannelIndex' anyway, so could we please
add it, separately?

Thanks

>-------------------------- Included Message ---------------------------<
>From [email-masked] Tue May 27 18:18:50 1997
Date: Tue, 27 May 1997 15:06:53 PDT
To: [email-masked] (Ira Mcdonald x10962)
From: Tom Hastings <[email-masked]>
Subject: Re: JMP> List of updated JMP objects and attributes
Cc: [email-masked]
Sender: [email-masked]
Status: R

Thanks.

---

From: Tom Hastings <[email-masked]>
Date: Wed, 28 May 1997 09:06:32 PDT

Anyone object if I add jobSourceChannelType as an attribute?

Probably conditionally mandatory like all attributes except jobOwner.

Or should it be OPTIONAL, since an implemenation that also
has the Printer MIB, already has the source channel type in the Printer MIB.

Tom

At 21:27 05/27/97 EDT, Ira Mcdonald x10962 wrote:
>Return-Path: <[email-masked]>
>Received: from zombi.eso.mc.xerox.com by snorkel.eso.mc.xerox.com
(4.1/XeroxClient-1.1)
>	id AA23083; Tue, 27 May 97 18:18:49 EDT
>Received: from alpha.xerox.com by zombi.eso.mc.xerox.com (4.1/SMI-4.1)
>	id AA08728; Tue, 27 May 97 18:16:11 EDT
>Received: from lists.underscore.com ([199.125.85.30]) by alpha.xerox.com
with SMTP id <16437(3)>; Tue, 27 May 1997 15:16:18 PDT
>Received: from localhost (daemon@localhost) by lists.underscore.com
(8.7.5/8.7.3) with SMTP id SAA03050 for <[email-masked]>; Tue, 27
May 1997 18:12:21 -0400 (EDT)
>Received: by pwg.org (bulk_mailer v1.5); Tue, 27 May 1997 18:10:28 -0400
>Received: (from daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) id
SAA02812 for jmp-outgoing; Tue, 27 May 1997 18:09:40 -0400 (EDT)
>Message-Id: <[email-masked]>
>X-Sender: hastings@zazen
>X-Mailer: Windows Eudora Pro Version 2.1.2
>Mime-Version: 1.0
>Content-Type: text/plain; charset="us-ascii"