Subject: JMP> Re: Comments on the Job MIB version 0.8

From: Tom Hastings <[email-masked]>
Date: Thu, 17 Apr 1997 14:38:17 PDT

Steve,

We had some questions about the Job Monitoring MIB.

I was copying the structure of the Printer MIB, but didn't know
why some things were done in the Printer MIB.

1. Why the extra level of OID for each Group and table.

If a group consists only of a table is it necessary to have the
extra OID level?  See below for extract of Printer MIB

2. Why was the first group assigned to printmib 5, instead of printmib 1?

(printmib 2 is assigned to Conformance at the end).

3. Should the Job Monitoring MIB do 1 and 2 the same as the Printer MIB or not?

Thanks,
Tom

>Date: Wed, 16 Apr 1997 00:22:12 -0700
>To: Ron Bergman <[email-masked]>
>From: Tom Hastings <[email-masked]>
>Subject: Re: Comments on the Job MIB version 0.8
>Cc: [email-masked],        [email-masked]
>
>At 18:12 04/15/97 PDT, Ron Bergman wrote:
>>These are just some comments on the structure of the MIB.  I believe
>>that the text will require some real "wordsmithing" and maybe this
>>can be best accomplished in a conference call.
>>
>> 1. We have the objects jmGeneral, jmJobId, jmJobState, and jmAttribute
>>    which appear to be just titles for the defined groups.  Each of
>>    these objects has an associated table.  I am not sure why these
>>    exist, as I have never noticed a similar structure in any other
>>    MIB.  These do add an extra number to every OID in the MIB.  What
>>    other purpose do these objects serve?
>>
>>    If there is not a valid justification for these objects, I would
>>    recommend that they be removed and have the tables at the level
>>    immediately below jobMonMib.
>
>I don't know why the extra level of OIDs is done, but I was just following
>the precedence in RFC 1759, which has for the General group (and all the
>other groups):
>
>-- The General Printer Group
>--
>-- The general printer sub-unit is responsible for the overall control
>-- and status of the printer.  There is exactly one general printer
>-- sub-unit in a printer.
>--
>-- Implementation of every object in this group is mandatory.
>
>prtGeneral  OBJECT IDENTIFIER ::= { printmib 5 }
>
>prtGeneralTable OBJECT-TYPE
>    SYNTAX     SEQUENCE OF PrtGeneralEntry
>    MAX-ACCESS not-accessible
>    STATUS     current
>    DESCRIPTION
>        "A table of general information per printer.
>        Objects in this table are defined in various
>        places in the MIB, nearby the groups to
>        which they apply.  They are all defined
>        here to minimize the number of tables that would
>        otherwise need to exist."
>    ::= { prtGeneral 1 }
>
>prtGeneralEntry OBJECT-TYPE
>    SYNTAX      PrtGeneralEntry
>    MAX-ACCESS  not-accessible
>    STATUS      current
>    DESCRIPTION
>
>>

---

From: Steve Waldbusser <[email-masked]>
Date: Thu, 17 Apr 1997 14:59:32 -0700 (PDT)

> extra OID level?  See below for extract of Printer MIB

Yes, every table MUST be structured prefix.table.entry.object. There is 
also a convention to have the MIB divided into groups, each with a 
subtree.

> (printmib 2 is assigned to Conformance at the end).

I don't remember. Did we delete some groups at the beginning?

> 3. Should the Job Monitoring MIB do 1 and 2 the same as the Printer MIB 

Definitely on #1, maybe on #2 (depends on whether it was for a good reason).

Steve