Subject: Re: JMP> Re: Comments on the Job MIB version 0.8

From: JK Martin <[email-masked]>
Date: Thu, 17 Apr 1997 18:09:36 -0400 (EDT)

Hi Steve,

No real issue with your statement below, only a bit of curiosity:

> Yes, every table MUST be structured prefix.table.entry.object. There is 
> also a convention to have the MIB divided into groups, each with a 
> subtree.

Can this rationale be briefly described?  Or perhaps a pointer to a
relevant discussion be given?

We know you're very busy, so anything you can say would be appreciated.

	...jay

---

From: Steve Waldbusser <[email-masked]>
Date: Thu, 17 Apr 1997 16:45:38 -0700 (PDT)

This is a requirement that is dictated by the SMI and is thus required by
MIB compilers. The rules dictate a structure that looks like:

          ifTable OBJECT-TYPE
              SYNTAX  SEQUENCE OF IfEntry
              ACCESS  not-accessible
              STATUS  mandatory
              DESCRIPTION
                      "A list of interface entries.  The number of
                      entries is given by the value of ifNumber."
              ::= { interfaces 2 }
 
          ifEntry OBJECT-TYPE
              SYNTAX  IfEntry
              ACCESS  not-accessible
              STATUS  mandatory
              DESCRIPTION
                      "An interface entry containing objects at the
                      subnetwork layer and below for a particular
                      interface."
              INDEX   { ifIndex }
              ::= { ifTable 1 }
 
          IfEntry ::=
              SEQUENCE {
                  ifIndex
                      INTEGER,
                  ifDescr
                      DisplayString,
                  ifType
                      INTEGER,
                  ifMtu
                      INTEGER,
		  ...
		}

Steve