Subject: JMP> Resource Type enums

From: "Harry Lewis <[email-masked]>" <[email-masked]>
Date: Mon, 3 Mar 97 16:38:46 MST

I can't find a full, contiguous list of Resource Type enumerations. I think
we're still building this list, so that's ok. The list I did find has several
enums with the same ID. Below, I've made a straight list of all the enums
I've found documented so far. I don't mind if someone wants to renumber these.

I have added suggestions for several more enums from 35-41.

I also note that we do not distinguish between collated and uncollated copies.
Should this be an issue?

1. Other
2. Unknown
3. fileName
4. documentName
5. jobCopiesRequested
6. jobCopiesCompleted
7. documentCopiesRequested
8. documentCopiesCompleted
9. sides
10. documentFormat
11. physicalDeviceIndex
12. physicalDeviceName
13. impressionsCompleted
14. sheetsCompleted
15. mediumRequested
16. mediaConsumed
17. impressionsSpooled
18. impressionsInterpreted
19. impressionsSentToDevice
20. impressionsCompletedCurrentCopy
21. pagesCompletedCurrentCopy
22. processingCPUTime
23. processingMessage
24. outputBin
25. colorantRequested
26. colorantConsumed
27. jobSourceChannelIndex
28. jobSubmissionTime
29. jobStartedPrintingTime
30. jobCompletedTime
31. jobComment
32. jobTotalKOctets
33. jobKOctetsCompleted
34. jobAccountName
35. finishingUsed
36. jobQualityRequested
37. jobQualityUsed
38. tonerEconomyRequested
39. tonerEconomyUsed
40. tonerDensityRequested
41. tonerDensityUsed

---

From: Tom Hastings <[email-masked]>
Date: Thu, 13 Mar 1997 09:30:10 PST

Harry,

I'm editing the job-mib with all of the comments so far.

Could you write up some proposed text to go with your proposed additional
enums?  

We discovered in the Printer MIB that "names do not a spec make".

So could you propose some text for each of:

35. finishingUsed
36. jobQualityRequested
37. jobQualityUsed

Make sure to include the units in the description, since we are now
doing that for all of the resource enums.

Thanks,
Tom