Subject: JMP> Job Type enumerations

From: Harry Lewis <[email-masked]>
Date: Mon, 17 Mar 1997 19:03:32 -0500

Classification:
Prologue:
Epilogue: Harry Lewis - IBM Printing Systems

Tom, thanks for all the great work on updating the Job MIB. Quick question.
Either there's been a change, or I'm noticing for the first time... but why are
there "holes" in the jmJobTypesTC list of type-2 enums? We've got

   1 - Other
   2 - Unknown
   4 - Print
   8 - Scan
 16 - faxIn
328 - faxOut
 64 - getFile
128 - putFile
256 - mailList.

Harry Lewis - IBM Printing Systems

---

From: Tom Hastings <[email-masked]>
Date: Mon, 17 Mar 1997 18:03:14 PST

Each bit is a power of 2 (except for my typo).  Thus a job can be
more than one.  A compound job (in the future) could be scanning and faxing,
for example.

I'll add more explantion.

Tom

>there "holes" in the jmJobTypesTC list of type-2 enums? We've got

Should have been 32, not 328.