Subject: JMP> Major Revision to MIB Introduction

From: Ron Bergman <[email-masked]>
Date: Sat, 15 Feb 1997 13:13:58 -0800 (PST)

I have completed a major rewrite of the Introduction/Goals sections
of the Job Monitoring MIB.  Sorry for the uglyness of the IS: part.
I will save of copy of this on the ftp server if anyone requests.

IS:
-----------------------------------------------------------------------
Introduction
The Job Monitoring MIB contains a set of objects for monitoring of the status and progress of print jobs 
and to obtain resource accounting data at the completion of a job using SNMP.
This MIB is intended to be implemented in printers or the server that supports one or more printers.  
Use of the object set is not limited to printing.  However, support for services other than printing is outside 
the scope of this Job Monitoring MIB.  
Goals
The following goals are copied from the charter:
1. The major goals of this MIB are to satisfy the needs of an agent in the printer and secondarily an agent 
in the server that submits jobs to printers and controls printers.  Implementations should place the agent 
as close to the processing of the print job as possible.  This MIB applies to printers that spool as well as 
those that don't.  This MIB is also designed so that servers are able find out about jobs in a printer that 
may have been submitted by other servers using any job submission protocol.  In most environments 
that support high function job submission/job control protocols, like ISO DPA, those protocols would 
be used to monitor and manage print jobs rather than using the Job Monitoring MIB.
 The following specific text was agreed to at the October 1996 JMP meeting:
 "The job monitoring MIB is for agents in the printer (spooling or non-spooling) or the first server 
closest to the printer where the printer is either:
 a. directly connected to the server only 
 --or-- 
 b. the printer does not contain the job monitoring MIB agent."
2. The job MIB is intended to provide the following information for the indicated Role Models (see 
Appendix D - Roles of Users in the Printer MIB draft update to RFC 1759).  A limited set of 
mandatory job and document objects for a printer, plus a set of conditionally mandatory objects, will 
be developed to provide this information.
User

(U1)
A timely notification that his job has completed and where.

(U2)
The current status of the user's job (user queries).

(U3)
Error and diagnostic information for jobs that did not 
successfully complete.

(U4)
Ability to identify the least busy printer.  The user will be 
able to determine the number and size of jobs waiting for 
each printer.  No attempt is made to actually predict the 
length of time that jobs will take.

Operator

(OP1)
A presentation of the state of all the jobs in the print 
system.

(OP2)
Which users submitted each job.

(OP3)
What resources does each job need.

(OP4)
For which physical printers are the jobs candidates.

(OP5)
Some idea of how long each job will take.  However, exact 
estimates of time to process a job is not being attempted.  Instead, 
objects are included that allow the operator to be able to make 
gross estimates.

Capacity Planner

(C1)
How busy are printers.

(C2)
What time of day are they used.

(C3)
How long do users' jobs wait before starting to print.

Accountant

(A1)
A record of resources used and printer usage data for charging 
users or groups for resources used.

The MIB will provide for printers that can contain more than one job at a time, but still be usable for low 
end printers that only contain a single job at a time.  In particular, the MIB shall meet the needs of Windows 
and other PC environments for managing low-end networked devices without unnecessary overhead or 
complexity, while also providing for higher end systems and devices.
3. The MIB will provide job resource accounting information after the printer has finished printing the 
job.  This resource accounting information is intended to be used by:
  A management station that is co-located with the printer to provide an enhanced console 
capability.
  End user job monitoring programs that provide status on progress and completion of jobs 
during the complete life cycle of the job, including a defined period after the job completes.
  System accounting programs that copy the completed job statistics to an accounting system. It 
is recognized that depending on accounting programs to copy MIB data during the job-
retention period is somewhat unreliable, since the accounting program may not be running (or 
may have crashed).
 Issue 1 - Should we add a standard SNMP RowStatus object to the jmJobTable and 
jmResourceTable?
 Should we add a standard SNMP RowStatus object to the jmJobTable and 
jmResourceTable so that an accounting program can delete a row in the table after the job is 
completed and the accounting program has copied the accounting data to an accounting log?  
Then no accounting data would get lost.
 Issue 2 - If we add RowStatus to the jmJobTable, should we add a 
jmGeneralTableOverflowPolicy object to the jmGeneralGroup?
 If we add RowStatus to the jmJobTable, should we add a jmGeneralTableOverflowPolicy 
object to the jmGeneralGroup that specified whether the printer stops when the table fills up 
or continues?  Then an administrator could decide whether it was more important to keep 
accurate accounting data or to keep the devices processing.
 Issue 3 -  If we add jmGeneralTableOverflowPolicy object should it be read-write?
 If we add jmGeneralTableOverflowPolicy object should it be read-write, so that the policy 
can be set by an NMS?
4. System usage statistics gathering programs that copy the completed job statistics to system usage logs.
5. The MIB will provide objects that represent a compatible subset of job and document attributes of the 
ISO DPA standard, so that coherence is maintained between the two protocols and information 
presented to end users and system operators.  However, the job monitoring MIB is intended to be used 
with printers that implement other job submitting and management protocols, such as IEEE 1284.1 
(TIPSI), as well as with ones that do implement ISO DPA.  So nothing in the job monitoring MIB shall 
require implementation of the ISO DPA protocol.
6. The MIB will be designed so that an additional MIB(s) can be specified in the future for monitoring 
multi-function (scan, FAX, copy) jobs.  The job MIB will be designed such that a future multi-function 
job monitoring MIB will be able to augment this MIB.
7. The MIB will not address any security issues.  Security provisions will be limited only to those 
provided by SNMP, in current or future versions.
8. The MIB will provide for the monitoring of jobs that clients submit directly to devices, to supervisor 
control programs, or to spooling systems.
9. The MIB will provide SNMP MIB access to jobs submitted to the device by any protocol, including 
devices that accept jobs using multiple protocols.

-----------------------------------------------------------------------

CHANGE TO:
-----------------------------------------------------------------------

Introduction

The Job Monitoring MIB is  intended for use by an agent within a printer 
or the first server closest to the printer, where the printer is either 
directly connected to the server only or the printer does not contain 
the job monitoring MIB agent.  It is recommended that implementations 
place the SNMP agent as close as possible to the processing of the print 
job.  This MIB applies to printers with and withoutspooling 
capabilities.  This MIB is designed to be compatible with most current 
comonly used job submission protocols.  In most environments that 
support high function job submission/job control protocols, like ISO 
DPA, those protocols would be used to monitor and manage print jobs 
rather than using the Job Monitoring MIB.
 
The job MIB is intended to provide the following information for the 
indicated Role Models (Refer to RFC 2XXX, Appendix D - Roles of Users).

  User:
    Provide the ability to identify the least busy printer.  The user 
    will be able to determine the number and size of jobs waiting for 
    each printer.  No attempt is made to actually predict the length of 
    time that jobs will take.

    Provide the ability to identify the current status of the job (user 
    queries).

    Provide a timely notification that the job has completed and where 
    it can be found.

    Provide error and diagnostic information for jobs that did not 
    successfully complete.

  Operator		
    Provide a presentation of the state of all the jobs in the print 
    system.

    Provide the ability to identify the user that submitted the print 
    job.

    Provide the ability to identify the resources required by each job.

    Provide the ability to define which physical printers are candidates 
    for the print job.

    Provide some idea of how long each job will take.  However, exact 
    estimates of time to process a job is not being attempted.  Instead, 
    objects are included that allow the operator to be able to make 
    gross estimates.

  Capacity Planner:
    Provide the ability to determine printer utilization as a function 
    of time.

    Provide the ability to determine how long jobs wait before starting 
    to print.

  Accountant:
    Provide information to allow the creation of a record of resources 
    used and printer usage data for charging users or groups for 
    resources used.

The MIB will support printers that can contain more than one job at a 
time, but still be usable for low end printers that only contain a 
single job at a time.  In particular, the MIB shall support the needs of 
Windows and other PC environments for managing low-end networked devices 
without unnecessary overhead or complexity, while also providing for 
higher end systems and devices.

The MIB will provide job resource accounting information after the 
printer has finished printing the job.  This resource accounting 
information is intended to be used by:

  - A management station that is co-located with the printer to provide 
  an enhanced console capability.

  - End user job monitoring programs that provide status on progress and 
  completion of jobs during the complete life cycle of the job, ncluding 
  a defined period after the job completes.

  - System accounting programs that copy the completed job statistics to
  an accounting system. It is recognized that depending on accounting 
  programs to copy MIB data during the job-retention period is somewhat 
  unreliable, since the accounting program may not be running (or 
  may have crashed).

The MIB provides a set of objects that represent a compatible subset of 
job and document attributes of the ISO DPA standard, so that coherence 
is maintained between the two protocols and information presented to 
end users and system operators.  However, the job monitoring MIB is 
intended to be used with printers that implement other job submitting 
and management protocols, such as IEEE 1284.1 (TIPSI), as well as with 
ones that do implement ISO DPA.  So nothing in the job monitoring MIB 
shall require implementation of the ISO DPA protocol.

The MIB is designed so that an additional MIB(s) can be specified in the 
future for monitoring multi-function (scan, FAX, copy) jobs as an 
augmentation to this MIB.

----------------------------------------------------------------------
	Ron Bergman
	Dataproducts Corp
	[email-masked]
	(805)578-4421

---

From: Bob Pentecost <[email-masked]>
Date: Tue, 25 Feb 1997 13:12:23 -0700

Again, because I can't make the phone conference, I'll put my comments 
here.

There are references to DPA at the end of the first paragraph and again in 
the second to last paragraph. Are these really needed? Can't this document 
stand on its own without DPA?

Under "User" it says "No attempt is made to actually predict the length of
time that jobs will take." Then, under "Operator" it says "Provide some 
idea of how long each job will take." Aren't these contradictory?

Bob Pentecost
HP

----------
From:  Ron Bergman[SMTP:[email-masked]]
Sent:  Saturday, February 15, 1997 6:14 AM
To:  [email-masked]
Subject:  JMP> Major Revision to MIB Introduction

IS:
<deleted>

CHANGE TO:

Introduction

  User:

  Operator		

  Capacity Planner:

  Accountant:

---

From: Ron Bergman <[email-masked]>
Date: Thu, 27 Feb 1997 08:15:29 -0800 (PST)

On 25-OCT-1997 Bob Pentecost wrote:

RB> In the re-write of the JMP MIB Introduction, I did not try to remove
RB> any of the ideas that were present in the original goals and charter
RB> for the project.  I share your concerns of becoming tied into the
RB> DPA philosophy of supporting everything possible and imaginable.
RB>
RB> I also recall a discussion in one of the PWG meetings of last year,
RB> that referenced an even earlier meeting, whereby it was agreed that
RB> all future PWG efforts would be based upon DPA.  The first DPA
RB> reference merely states that the Job Monitoring MIB is not intended
RB> to be used in pure DPA environment.  The second to last paragraph 
RB> states that the MIB objects "represent a compatible subset of job 
RB> and document attributes of the ISO DPA standard" but "nothing in the
RB> job monitoring MIB shall require implementation of the ISO DPA 
RB> protocol".  I justify the inclusion of the references as providing
RB> a reason for not being 100% DPA compatible.
RB> 
RB> You do raise a valid point, do we really need to reference DPA?
RB> Are there any others that feel this should be removed?

RB> Again, here is another area that we have discussed to death and I
RB> let this by!  I propose the paragraph under "Operator" be revised
RB> or removed (removed is preferred).  The paragraph presently reads:
RB>
RB>  Provide some idea of how long each job will take.  However, exact
RB>  estimates of time to process a job is not being attempted.  Instead,
RB>  objects are included that allow the operator to be able to make
RB>  gross estimates.