Subject: Re: IPP> Client usage of TCP port number selection

From: Carl-Uno Manros <[email-masked]>
Date: Thu, 9 Oct 1997 12:06:48 PDT

Randy,

I do not have any problem in formulating the requirements like you have
stated, but I have a couple of questions:

1) Are there any URI schemes that do NOT allow you to specify a port number
as part of the URI (just a wording question)?

2) I hope that we are not in conflict with the HTTP 1.1 spec if we allow an
HTTP server, providing IPP service, NOT to support the HTTP default port 80.

A couple of quotes from RFC 2068: 
"The default port is 80, but other ports can be used."
"If the port (in the URI) is empty or not given, port 80 is assumed."

This seems to indicate that an HTTP 1.1 server MAY be allowed to ONLY
listen to another port number, which I believe was the new part of Randy's
proposal.

Carl-Uno

At 11:06 AM 10/9/97 PDT, Turner, Randy wrote:
>
>I think we could include these rules into the model document, and echoed
>to the protocol document, if need be, for emphasis. The following steps
>would be taken, in order, to determine what port number should be used
>to contact an IPP server
>
>1. If the protocol scheme for the URI allows the port number to
>be explicity included in the URI string, and an explicit port number
>is specified, then that port number MUST
>be used by the client to contact the IPP server.
>
>2. If the protocol scheme for the URI does not allow an
>explicit port number specification, then the default port 
>number for the protocol should be used.
>
>3. Consult the appropriate IPP protocol mapping document to
>    determine alternamte port numbers for the protocol specified
>    in the server URI.
>
>Comments?
>
>Randy
>
>
>
>
>
>
>
Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Fri, 10 Oct 1997 00:26:21 PDT

>  I hope that we are not in conflict with the HTTP 1.1 spec if we allow an

It's done all the time.