Subject: IPP> MOD - Revised 'application/ipp' MIME type

From: [email-masked] (Ira Mcdonald x10962)
Date: Fri, 24 Oct 1997 09:42:21 PDT

Copies To:  [email-masked]
            [email-masked]
            [email-masked]

Hi folks,                                       Friday (24 October 1997)

At our IPP Telecon on Wednesday (22 October), I got the action item to
write up new text for registration of MIME media type "application/ipp".

This template came from the IETF MIME Part Four: Registration Procedures
(RFC 2048, November 1996).

Note_1: We need not actually apply for registration of this media-type
until the IPP/1.0 specs are accepted by the IESG onto the 'standards
track'.  The application is made by mail (see below) and need not be
supported by a separate Informational RFC.

Note_2: The 'Intended usage' of 'LIMITED USE' (rather than 'COMMON') is
based on advice earlier this month from Larry Masinter.

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839
  906-494-2434

------------------------------------------------------------------------

    To: [email-masked]
    Subject: Registration of MIME media type "application/ipp"

    MIME type name: application

    MIME subtype name: ipp

      A Content-Type of "application/ipp" indicates an Internet Printing
      Protocol message body (request or response).  Currently there is
      one version:  IPP/1.0, described in [IPP-MOD] and [IPP-PRO].

    Required parameters: none

    Optional parameters: none

    Encoding considerations:

      IPP/1.0 protocol requests/responses MAY contain long lines and
      ALWAYS contain binary data (for example attribute value lengths).

    Security considerations:

      IPP/1.0 protocol requests/responses do not introduce any security
      risks not already inherent in underlying transport protocols.

    Interoperability considerations:

      IPP/1.0 requests (generated by clients) and responses (generated
      by servers) MUST comply with all conformance requirements imposed
      by the normative specifications [IPP-MOD] and [IPP-PRO].  Protocol
      encoding rules specified in [IPP-PRO] are complete and unambiguous
      so interoperability between conforming implementations is ensured
      (although support for specific optional features is not ensured).
      Both the "charset" and "natural-language" of all IPP/1.0 attribute
      values of syntax "text" or "name" are explicit within IPP protocol
      requests/responses (without recourse to any external information
      in MIME, HTTP, or other message transport headers).

    Published specification:

      [IPP-MOD] R. deBry, T. Hastings, R. Herriot, S. Isaacson,
      P. Powell, "Internet Printing Protocol/1.0: Model and Semantics",
      work in progress <draft-ietf-ipp-model-06.txt>, October 1997.

      [IPP-PRO] S. Butler, R. Herriot, P. Moore, R. Turner,
      "Internet Printing Protocol/1.0: Protocol Specification",
      work in progress <draft-ietf-ipp-protocol-02.txt>, October 1997.

    Applications which use this media type:

      Internet Printing Protocol (IPP) print clients and print servers.

    Person & email address to contact for further information:

      Scott A. Isaacson
      Novell, Inc.
      122 E 1700 S
      Provo, UT  84606
 
      Phone: 801-861-7366
      Fax:   801-861-4025
      Email: [email-masked]

    or

      Robert Herriot
      Sun Microsystems Inc.
      901 San Antonio Road, MPK-17
      Palo Alto, CA  94303

      Phone: 650-786-8995
      Fax:   650-786-7077
      Email: [email-masked]

    Intended usage:

      LIMITED USE

------------------------------------------------------------------------

---

From: Tom Hastings <[email-masked]>
Date: Fri, 24 Oct 1997 16:22:35 PDT

Here is Larry's answer to my question as to what it means for the
application/ipp media type to be "limited use".

Sounds reasonable to me.

Tom

>Return-Path: <[email-masked]>
>Date: Fri, 24 Oct 1997 12:11:34 PDT
>From: Larry Masinter <[email-masked]>
>Organization: Xerox PARC
>To: Tom Hastings <[email-masked]>
>Cc: Ira Mcdonald x10962 <[email-masked]>
>Subject: Re: IPP> MOD - Revised 'application/ipp' MIME type
>
>Uh, this was an area where I was trying to set a pointer to
>'ask a real expert'. However, 'application/ipp' is not intended
>for use in email, in server PUSH, or in arbitrary applications
>that use MIME objects. You probably shouldn't expect
>to find files labelled as 'application/ipp' sitting in a document
>repository.  Since it is solely intended for use within
>the IPP protocol which is implemented by tunnelling through
>HTTP/1.1, it's applicability is limited. 
>
>Larry
>-- 
>http://www.parc.xerox.com/masinter
>
>