Subject: IPP> Client usage of TCP port number selection

From: "Turner, Randy" <[email-masked]>
Date: Thu, 9 Oct 1997 11:06:21 -0700

I think we could include these rules into the model document, and echoed
to the protocol document, if need be, for emphasis. The following steps
would be taken, in order, to determine what port number should be used
to contact an IPP server

1. If the protocol scheme for the URI allows the port number to
be explicity included in the URI string, and an explicit port number
is specified, then that port number MUST
be used by the client to contact the IPP server.

2. If the protocol scheme for the URI does not allow an
explicit port number specification, then the default port 
number for the protocol should be used.

3. Consult the appropriate IPP protocol mapping document to
    determine alternamte port numbers for the protocol specified
    in the server URI.

Comments?

Randy

---

From: "Turner, Randy" <[email-masked]>
Date: Thu, 9 Oct 1997 13:46:14 -0700

> -----Original Message-----
> From:	Carl-Uno Manros [SMTP:[email-masked]]
> Sent:	Thursday, October 09, 1997 12:07 PM
> To:	Turner, Randy; [email-masked]'
> Subject:	Re: IPP> Client usage of TCP port number selection
> 
> Randy,
> 
> I do not have any problem in formulating the requirements like you
> have
> stated, but I have a couple of questions:
> 
> 1) Are there any URI schemes that do NOT allow you to specify a port
> number
> as part of the URI (just a wording question)?
	[Turner, Randy]  
	Yes, the potential definitely exists; but if the protocol is
well defined and TCP/IP
	is a used, then the protocol should have a TCP port defined for
it, in which case
	rule #2 from my original mail message would be used to determine
the server
	port number.

> 2) I hope that we are not in conflict with the HTTP 1.1 spec if we
> allow an
> HTTP server, providing IPP service, NOT to support the HTTP default
> port 80.
	[Turner, Randy]  These rules do not preclude this. I think it
was Ira that stated
	(correctly) that all HTTP 1.1 servers must support 80, but may
support other
	port numbers, like your quote from 2068 says. This scenario is
covered by 
	following my proposed rules, in order.

> A couple of quotes from RFC 2068: 
> "The default port is 80, but other ports can be used."
> "If the port (in the URI) is empty or not given, port 80 is assumed."
> 
> This seems to indicate that an HTTP 1.1 server MAY be allowed to ONLY
> listen to another port number, which I believe was the new part of
> Randy's
> proposal.
> 
> Carl-Uno
> 
> At 11:06 AM 10/9/97 PDT, Turner, Randy wrote:
> >
> Carl-Uno Manros
> Principal Engineer - Advanced Printing Standards - Xerox Corporation
> 701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
> Phone +1-310-333 8273, Fax +1-310-333 5514
> Email: [email-masked]