Subject: Re: IPP> Default port (was Re: IPP> September Minutes)

From: [email-masked] (Dale Wick)
Date: Tue, 23 Sep 1997 17:28:42 -0400

Patrick Powell said:
> >           - While the conference call was still open, we discussed the
> >           use of a port besides 80.  It was the consensus that we
> >           would not mandate an alternative port number but we would
> >           not preclude some implementations from using alternative
> >           ports.  The protocol document should make a statement that
> >           by default IPP should be supported by servers and clients
> >           over port 80.
> > I think that this is a serious mistake.  What is happening here is you
> are adding required functionality to a HTTP port service without
> coordinating this with the folks doing the HTTP stuff.
> > In addition,  you are requiring non-printer vendors to supply
> a HTTP server that will not only do regular HTTP functionality
> but also provide support for IPP as well if they want to do GATEWAY
> support for the IPP protocol to other print systems.
>
> This is the part where I disagree strongly.
>
The falacy in this arguement is that IPP isn't an independent protocol
it is a protocol layered inside HTTP 1.1.  To have IPP default to anything
other than port 80 whould require that our printer URIs be in the form
of ipp://site/printer instead of http://site/printer which is not the
direction we chose, when we went for a layer under HTTP.  If port 80
at a site is occupied by a non-ipp http server, then use allow for printers to use a different port.

 Dale
--
Dale Wick
TrueSpectra Inc., Toronto, Ontario, Canada
"Excellence in Graphics"

---

From: [email-masked] (Dale Wick)
Date: Wed, 24 Sep 1997 16:30:02 -0400

> you know that http URLs allow supplying a different port
> in the URL, as in http://site:port/printer, e.g.,
> > http://printer.truspectra.com:4020/printer ?
> > Larry

Obviously my message was garbled.  The default port of http is clearly 80.  If IPP has a default port, then it must also be 80 for http://site/printer URIs.  If we state a port in the URI, then that will also clearly be honoured.  If the printer URI is an https://site/printer then the port will default to 443.  If we use
https://site:port/printer then that port will be honoured.

  Dale
"Excellence in graphics"