Subject: Re: IPP> MOD - ISSUES: Contents of "document-format" attribute = MIME Content-type Header Field value

From: Tom Hastings <[email-masked]>
Date: Tue, 23 Sep 1997 10:42:14 PDT

At 17:04 09/17/97 PDT, Larry Masinter wrote:
>>  Alternatively, we could add a separate
>> Printer description attribute: "content-transfer-encodings" supported.
>
>I suggest instead that you supply a single description attribute
>which is "accept headers" which describes the document formats
>and encodings that the printer will accept. This should take
>the same range as the accept headers of HTTP and the document format
>accept headers being proposed for Internet Fax.

If the MIME-type attributes include content-transfer-encodings as an
attribute, then we don't need to add the Printer description attribute.
Do they?

>
>Larry
>-- 
>http://www.parc.xerox.com/masinter
>
>

---

From: Larry Masinter <[email-masked]>
Date: Tue, 23 Sep 1997 11:22:16 PDT

The content-transfer-encoding (or, for that matter, the
transfer-encoding) is orthogonal to the content-type. Logically,
any content-transfer-encoding (in email) and any transfer-encoding
(in HTTP and, most likely, in IPP) can be used with any content-type.

MIME-type attributes (like charset, version, etc.) are, on the
other hand, type specific, and the type registration identifies
the optional & required parameters and their ranges.

Larry