Subject: RE: IPP> jobid (one more time)

From: Paul Moore <[email-masked]>
Date: Tue, 9 Sep 1997 18:25:16 -0700

My research (with the people who have written the code) shows that this
is not the case

> -----Original Message-----
> From:	Randy Turner [SMTP:[email-masked]]
> Sent:	Tuesday, September 09, 1997 5:05 PM
> To:	[email-masked]
> Subject:	Re: IPP> jobid (one more time)
> 
> Paul Moore wrote:
> > 
> > The new job MIB defines a 32-bit job identifier that persists as a
> way
> > of identifying a job.
> > 
> > The Win32 API does the same - used on the vast majority of the
> world's
> > desktops.
> > 
> > Bob H says that UNIX uses a 32 bit job ID in the same way.
> > 
> > It's not like I am suggesting that we use something obscure,
> > non-published or only used by 1% of the world. I am suggesting that
> we
> > may want to leverage some of the exisiting software in the world.
> 
> 
> From my research, you can't use the job-id returned by an IPP
> server to access the Win95 print spooler. You have to use the
> job-id (DWORD value) returned by the AddJob() API call. You will
> then have to maintain a mapping between this Win95-derived job-id
> and the job-id/job-uri returned by a remote IPP server. We are not
> proposing replacing the existing software in the world, just
> supplementing it.
> 
> I think the job MIB also specifies an octet string for supplemental
> job identification (is this right Tom H.?)
> 
> Randy

---

From: Randy Turner <[email-masked]>
Date: Tue, 09 Sep 1997 18:38:36 -0700

Could you elaborate on your statement a little?

Randy