Subject: RE: IPP> Supported URIs for print-by-reference

From: "Turner, Randy" <[email-masked]>
Date: Wed, 24 Sep 1997 15:47:42 -0700

That's true, but in the last meeting it seems liked we were
standardizing on "HTTP" and "FTP" schemes, and no other
scheme would be accepted. I guess I would like the wording
to say that these are the minimal schemes accepted, and
make sure that other schemes can be specified but not
guaranteed to be supported.

Now that I think about it, that may have been the accepted
text, but I left the meeting thinking that this might have been
left out.

Randy

> -----Original Message-----
> From:	Larry Masinter [SMTP:[email-masked]]
> Sent:	Wednesday, September 24, 1997 3:44 PM
> To:	Randy Turner
> Cc:	[email-masked]
> Subject:	Re: IPP> Supported URIs for print-by-reference
> 
> > But if the IPP server (or parent HTTP site) advertised the file then
> > I think the syntax should be acceptable to that particular site's
> > server.
> 
> Any URL that a site advertises should be acceptable to the site,
> then, and it doesn't matter if it is "file:" or "froofroo:", right?
> 
> Larry
> -- 
> http://www.parc.xerox.com/masinter

---

From: Scott Isaacson <[email-masked]>
Date: Thu, 25 Sep 1997 08:32:30 -0600

Randy,

I added the following to the model document:

If a Printer object supports this optional operation, it MUST support URIs
of the following type:
  'http':  The Printer object will perform an HTTP/1.1 GET operation
'ftp':  The Printer object will use an FTP 'get' operation.  If the URI does
not indicate a name or password in the URI itself, the Printer object will
use anonymous FTP generating (if prompted) some password in the form of an
Internet mail address.

I intended to add the phrase "The Printer object OPTIONALLY supports URIs of
other types."  but I forgot.  I will add it.  I thought this was the intent
of the
discussion:

if support for print-by-reference, then support for http:  and ftp: with
optional
support for uri's of other types.

Scott

>>> "Turner, Randy" <[email-masked]> 09/24 4:47 PM >>>
> I guess I would like the wording