Subject: IPP>MOD document object problem for SendURI

From: [email-masked] (Robert Herriot)
Date: Fri, 19 Sep 1997 18:40:29 -0700

We made a decision to eliminate all document attributes because we didn't want
to design the mechanism for returning one attribute per document for version 1.0.

I agree with that decision.  But now I have realized that SendURI has to send
a separate document-URI for each Send-URI operation which means there is a 
separate value of document-URI for each document.  

The following are possible solutions:

    1) bad idea: solve the multiple-document-attribute problem 

    2) OK maybe: document-URI is an operation attribute that does
       not stick to the job object. That is, Get-Attributes does not
       return a document-URI created by a Send-URI operation.
       Get-Attributes could return a document-URI value set by
       Print-URI but it might seem strange that document-URI is
       available for Print-URI jobs but not Create-Job/ Send-URI jobs.

    3) OK maybe: eliminate Send-URI in version 1.0, but keep Print-URI which
       doesn't have this problem.

#3 is probably a little bit better than #2.

Bob Herriot

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Sat, 20 Sep 1997 08:08:10 PDT

Hi Bob,

I vote for your option #3 - dump Send-URI entirely from IPP 1.0.
A little bit of document attributes is just as bad as lots.
If we don't go with option #3, then we certainly won't get out
'stable' IPP specs by the end-of-September to the IETF.

Cheers,
- Ira McDonald (outside consultant at Xerox)

------------------------- Bob's note -----------------------
>From [email-masked] Fri Sep 19 22:01:09 1997
Date: Fri, 19 Sep 1997 18:40:29 PDT
From: [email-masked] (Robert Herriot)
To: [email-masked]
Subject: IPP>MOD document object problem for SendURI
Sender: [email-masked]
Status: R

Bob Herriot

---

From: Scott Isaacson <[email-masked]>
Date: Wed, 24 Sep 1997 00:53:58 -0600

I noticed the same problem in the editing.  I vote for number 2.

Scott

>>> Ira Mcdonald x10962 <[email-masked]> 09/20 9:08 AM >>>
Hi Bob,

Cheers,

------------------------- Bob's note -----------------------
>From [email-masked] Fri Sep 19 22:01:09 1997
Return-Path: <[email-masked]>
Received: from zombi (zombi.eso.mc.xerox.com) by snorkel.eso.mc.xerox.com
(4.1/XeroxClient-1.1)
 id AA11123; Fri, 19 Sep 97 22:01:08 EDT
Received: from alpha.xerox.com by zombi (4.1/SMI-4.1)
 id AA01012; Fri, 19 Sep 97 21:57:10 EDT
Received: from lists.underscore.com ([199.125.85.31]) by alpha.xerox.com
with SMTP id <54288(1)>; Fri, 19 Sep 1997 18:57:12 PDT
Received: from localhost (daemon@localhost) by lists.underscore.com
(8.7.5/8.7.3) with SMTP id VAA26855 for <[email-masked]>; Fri, 19
Sep 1997 21:53:28 -0400 (EDT)
Received: by pwg.org (bulk_mailer v1.5); Fri, 19 Sep 1997 21:50:50 -0400
Received: (from daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) id
VAA26529 for ipp-outgoing; Fri, 19 Sep 1997 21:41:29 -0400 (EDT)
Date: Fri, 19 Sep 1997 18:40:29 PDT
From: [email-masked] (Robert Herriot)
Message-Id: <[email-masked]>
To: [email-masked] 
Subject: IPP>MOD document object problem for SendURI
X-Sun-Charset: US-ASCII
Sender: [email-masked] 
Status: R

We made a decision to eliminate all document attributes because we didn't
want
to design the mechanism for returning one attribute per document for version
1.0.

I agree with that decision.  But now I have realized that SendURI has to
send
a separate document-URI for each Send-URI operation which means there is a 
separate value of document-URI for each document.  

Bob Herriot