Subject: Re: IPP> MIME-types and alignment

From: Roger K Debry <[email-masked]>
Date: Tue, 19 Aug 1997 09:54:04 -0400

If we take Keith's direction, do we need to register new MIME types
to represent all of the PDLs currently in the model document? Who
owns the responsibility to do this?

Roger K deBry
Senior Technical Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

---------------------- Forwarded by Roger K Debry/Boulder/IBM on 08/19/97 07:46
AM ---------------------------

        ipp-owner @ pwg.org
        08/19/97 03:44 AM
Please respond to [email-masked] @ internet

To: masinter @ parc.xerox.com @ internet, don @ lexmark.com @ internet
cc: ipp @ pwg.org @ internet
Subject: Re: IPP> MIME-types and alignment

Don,

during the Application Area Chairs'' meeting in Munich last Wednesday, I
asked Keith to amplify on his request to use MIME types rather than enums.
This resulted in Keith stating that we should see this as a directive from
him in his role as our project advisor.

My interpretation is that it does not seem likely that we will be able to
avoid the MIME-types.

Carl-Uno

At 12:14 PM 8/18/97 PDT, [email-masked] wrote:
>I content that when the latest and in some cases the previous
>versions of printers from Lexmark, HP, IBM, Kyocera, Tektronix,
>and Xerox support the printer MIB including the enum list of
>printer interpreters then it is not simply "hypothetical" nor is
>it "...not widely deployed..."
>
>I suggest you might not want to base your conclusions on this
>obviously wrong set of facts.
>
>Don
>
>**********************************************
>* Don Wright                 [email-masked] *
>* Manager, Strategic Alliances and Standards *
>* Lexmark International                      *
>* 740 New Circle Rd                          *
>* Lexington, Ky 40550                        *
>* 606-232-4808 (phone) 606-232-6740 (fax)    *
>**********************************************
>
>
>
>
> (Embedded
> image moved   [email-masked]
> to file:      08/18/97 02:18 PM
> PIC31334.PCX)
>
>
>
>
>To:   [email-masked]
>cc:   [email-masked] (bcc: Don Wright)
>Subject:  IPP> MIME-types and alignment
>
>
>
>
>>     It was the opinion of Larry Masinter (chair of HTTP WG), Keith
>>     Moore, and most of the IETF audience that alignment with the
>>     Printer MIB was a mistake, and that we should focus on sticking
>>     with MIME-type specifications.
>To be more precise:
>When IPP is being used for transporting a message (document, print
>instructions) from a willing sender to a willing recipient, alignment
>with other widely implemented and deployed Internet protocols for
>message transmission (mail, fax, Web) is more useful than alignment with
>some hypothetical and not widely deployed protocol for system management
>and monitoring of the status of a device.
>
>
>
>
>Attachment Converted:
"C:\WINNT\profiles\cmanros\personal\Attach\PIC31334.PCX"
Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: Carl-Uno Manros <[email-masked]>
Date: Tue, 19 Aug 1997 07:23:43 PDT

>owns the responsibility to do this?

I expect that we need to take on the job, we may potentially want to
depricate some which are not in use any more.  Alternatively, the companies
that own the various formats could be asked to do their own, but this could
take quite a while.

Carl-Uno
Carl-Uno Manros