Subject: IPP> PRO - Comment on latest encoding proposal

From: Carl-Uno Manros <[email-masked]>
Date: Thu, 10 Jul 1997 09:53:25 PDT

>From Bob's text:

1.1 Syntax of Encoding

 The encoding consists of:

   .  version
   .  operation (for a request) or status (for a response)
   .  parameter-tag
   .  parameter-sequence
   .  attribute-tag
   .  attribute-sequence
   .  data-tag
   .  data (absent for some operations)

Bob<

I thought that the discussion in yesterday's phone conference indicated
that the attribute sequence could also be omitted.  Also, do we require the
attribute-tag and data-tag to always be present even if the
attribute-sequence or data are empty?

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: [email-masked] (Robert Herriot)
Date: Thu, 10 Jul 1997 14:02:13 -0700

Perhaps you overlooked the following paragraph in the description I emailed out yesterday.

 The parameter-tag and parameter-sequence may be omitted if the operation
 has no parameters. The attribute-tag and attribute-sequence may be
 omitted if the operation has no attributes or it may be replicated for
 an operation that contains attributes for multiple objects. The data-tag
 is present even when the data is omitted.

I believe that the mandatory data-tag makes it easier to decode because
with the mandatory tag, there is only a check of the tag in each cycle.
Without a mandatory data-tag, there would have to be a check  for both
some end-of data index and the contents of the next tag.

Bob Herriot

> From [email-masked] Thu Jul 10 11:17:15 1997
> X-Sender: cmanros@garfield
> X-Mailer: Windows Eudora Pro Version 3.0.1 (32)
> Date: Thu, 10 Jul 1997 09:53:25 PDT
> To: [email-masked]
> From: Carl-Uno Manros <[email-masked]>
> Subject: IPP> PRO - Comment on latest encoding proposal
> Mime-Version: 1.0
> Sender: [email-masked]
> X-Lines: 30
> 
> From Bob's text:
> 
> 1.1 Syntax of Encoding
>