Subject: RE: IPP> Identifying jobs in requests

From: Paul Moore <[email-masked]>
Date: Wed, 16 Jul 1997 18:44:32 -0700

The transport layer part of the client side needs to know the URL. The
application layer part needs to know the job IDs. These two layers
should be kept separate.

> -----Original Message-----
> From:	Larry Masinter [SMTP:[email-masked]]
> Sent:	Wednesday, July 16, 1997 5:30 PM
> To:	Paul Moore
> Cc:	[email-masked]'
> Subject:	Re: IPP> Identifying jobs in requests
> 
> > This has the advantage that the client only needs to know one URL
> for
> > all operations on a given printer.
> 
> Why is it an advantage to have to know the Job ID instead of
> the Job URL? What is the nature of the advantage?

---

From: Randy Turner <[email-masked]>
Date: Wed, 16 Jul 1997 19:18:32 -0700

> > the Job URL? What is the nature of the advantage?

It would seem to be more sound for Job-IDs to be included, if URLs were
basically
out of band to the fundamental IPP model; but the last time I checked,
the model document
considers URLs to be the primary identifiers for IPP objects (or has
this changed radically also?)

Randy