Subject: IPP>MOD Issue with localization

From: [email-masked] (Robert Herriot)
Date: Fri, 18 Jul 1997 19:36:25 -0700

Should we a make statement about which attributes should be localized.
I would expect the text attributes set by the manufacturer would be
localized. They are: job-state-message ,
printer-more-info-manufacturer, printer-state-message, and
printer-make-and-model. I would expect text attribute set by a site
would not be localized. They are job-message-from-operator,
printer-location, printer-description, printer-message-
from-the-operator

If we agree with the first paragraph, should there be a separate text
type called localized-text for the 4 attributes mentioned in the
previous issue that can be localized. The status-message parameter
would also have this type, as would notification messages.

Unless we do something, the localization issue is left very vague.

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Sat, 19 Jul 1997 13:11:41 PDT

Hi Bob,

Why would you expect the values set by the site NOT to be
localized (ie, to have their character set and language,
while static from device install, declared and available
to remote monitoring and client applications).

Cheers,
- Ira McDonald

PS - 
This business of the declared 'cooperative' locale of
management stations and on-system management agents (or
IPP print servers) is what Tom Hastings, Angelo Caruso,
and I have been trying to clarify since early April
for the Printer MIB v2 - at present, all strings which
are NOT localized are forced to 7-bit US-ASCII - in
IPP they would be forced to UTF-8 (by default), but
for environments where the ISO 8859-n or ISO 2020
(2022, oops) character sets are more appropriate, 
there is no reason to preclude in IPP having a printer
attribute which is the declared 'cooperative' static
locale for other text strings - or as Tom Hastings
has suggested for the Job Mon MIB, the dynamic (usser
specified) locale for remotely supplied strings in a
job specification.

-------------------------------------------------------------
>From [email-masked] Fri Jul 18 23:13:43 1997
Date: Fri, 18 Jul 1997 19:36:25 PDT
From: [email-masked] (Robert Herriot)
To: [email-masked]
Subject: IPP>MOD Issue with localization
Sender: [email-masked]
Status: R

---

From: [email-masked] (Robert Herriot)
Date: Mon, 21 Jul 1997 13:09:58 -0700

No, the question is: Why would you expect the values set by the site to
be localized?  Printer vendors have good reasons to localize their messages,
but there are few sites that have such a need.

For example, I recently visited the Munich web page. Some parts come
in English, but other parts, e.g. Bayerische Staatsoper are in German. 

It may to going too far to say that site specific text attributes
could not be localized, but I expect few would.

I expect that in most implementations, a user will receive text of printer
vendor attributes in his language and text of site attributes in the
language of the site.

Bob Herriot

> From [email-masked] Sat Jul 19 13:09:15 1997
> 
> Hi Bob,
> 
> Return-Path: <[email-masked]>
> Received: from zombi (zombi.eso.mc.xerox.com) by snorkel.eso.mc.xerox.com (4.1/XeroxClient-1.1)
> 	id AA13815; Fri, 18 Jul 97 23:13:43 EDT
> Received: from alpha.xerox.com by zombi (4.1/SMI-4.1)
> 	id AA22669; Fri, 18 Jul 97 23:10:30 EDT
> Received: from lists.underscore.com ([199.125.85.31]) by alpha.xerox.com with SMTP id <51920(3)>; Fri, 18 Jul 1997 20:10:36 PDT
> Received: from localhost (daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) with SMTP id XAA29253 for <[email-masked]>; Fri, 18 Jul 1997 23:06:43 -0400 (EDT)
> Received: by pwg.org (bulk_mailer v1.5); Fri, 18 Jul 1997 23:01:19 -0400
> Received: (from daemon@localhost) by lists.underscore.com (8.7.5/8.7.3) id WAA27791 for ipp-outgoing; Fri, 18 Jul 1997 22:35:48 -0400 (EDT)
> Message-Id: <[email-masked]>
> To: [email-masked]
> X-Sun-Charset: US-ASCII