Subject: Re: IPP>MOD - missing job template attributes

From: [email-masked] (Robert Herriot)
Date: Fri, 18 Jul 1997 12:41:42 -0700

> From [email-masked] Fri Jul 18 10:39:24 1997
> 
> As I have been reviewing the model document this morning,
> I looked to see what typical job properties we can associate
> with a job in some of our existing systems. There were a
> few that stood out.  I don't recall if there has been discussion
> of these in our model work or not.  If we discussed all of these
> and rejected them or handled them in some other manner
> please excuse my forgetfulness -- it's old age!
> 
> Here are the attributes that I don't see in IPP:
> 
> Orientation  (portrait or landscape)

This is suitable for conversion, e.g. text to PostScript but not
for printing PostScript directly. We dropped it when we dropped
all text conversion attributes, under the assumption that we would
not specify attributes that deal with conversion issues.

> 
> Color (print black and white on a color printer)

This is also a conversion issue and was a eliminated for the same
reason.

Bob Herriot

---

From: Jim Walker <[email-masked]>
Date: Fri, 18 Jul 1997 15:17:28 -0500

At 12:41 PM 7/18/97 -0700, Robert Herriot wrote:
>> ...

I disagree that `orientation' is not useful for printing PostScript
directly... remember that we also support `number-up'.  In the case
of number-up > 1, orientation can be a very useful hint for ordering
the logical pages on a physical page.  If you do not believe me, then
apply some naive number-up code to a portrait and a landscape document,
and look at the results.

This is admittably on the low 20% end of the solution scale, but it *is*
important as a hint if you are really going to support number-up processing.

...walker

--
Jim Walker <[email-masked]>
System Architect/DAZEL Wizard
DAZEL Corporation, Austin, TX