Subject: IPP>MOD - missing job template attributes

From: Roger K Debry <[email-masked]>
Date: Fri, 18 Jul 1997 13:25:49 -0400

As I have been reviewing the model document this morning,
I looked to see what typical job properties we can associate
with a job in some of our existing systems. There were a
few that stood out.  I don't recall if there has been discussion
of these in our model work or not.  If we discussed all of these
and rejected them or handled them in some other manner
please excuse my forgetfulness -- it's old age!

Here are the attributes that I don't see in IPP:

Orientation  (portrait or landscape)

Color (print black and white on a color printer)

Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

---

From: [email-masked] (Robert Herriot)
Date: Fri, 18 Jul 1997 14:03:30 -0700

If I understand your explanation, the orientation is not to specify
that the desired layout of the output, but rather to state how existing
pages are already laid out, and that this parameter is only used as a
hint to number-up so that it does proper rotation for 2-up.   If that
is the case, why not just invent some more number-up values, e.g.
2-up-landscape.  Then 2-up means 2-up-portrait.

Bob Herriot

> From [email-masked] Fri Jul 18 13:19:02 1997
> 
> At 12:41 PM 7/18/97 -0700, Robert Herriot wrote:
> >
> >> From [email-masked] Fri Jul 18 10:39:24 1997
> >> 
> >> ...
> >> 
> >This is suitable for conversion, e.g. text to PostScript but not
> >for printing PostScript directly. We dropped it when we dropped
> >all text conversion attributes, under the assumption that we would
> >not specify attributes that deal with conversion issues.
> 
> I disagree that `orientation' is not useful for printing PostScript
> directly... remember that we also support `number-up'.  In the case
> of number-up > 1, orientation can be a very useful hint for ordering
> the logical pages on a physical page.  If you do not believe me, then
> apply some naive number-up code to a portrait and a landscape document,
> and look at the results.
> 
> This is admittably on the low 20% end of the solution scale, but it *is*
> important as a hint if you are really going to support number-up processing.
> 
> ...walker
> 
> --
> Jim Walker <[email-masked]>
> System Architect/DAZEL Wizard
> DAZEL Corporation, Austin, TX
> 
>