Subject: IPP>MOD - Globally unique IDs

From: Roger K Debry <[email-masked]>
Date: Mon, 14 Jul 1997 09:11:58 -0400

AN IBM person reviewing the model document made the following observation --
comments anyone?

On page 20 Section 4.6, it says
        "... have an identifier attribute whose value is globally unique ..."
I think we have to say how this is done, don't we?

Roger deBry

---

From: [email-masked] (Ira Mcdonald x10962)
Date: Mon, 14 Jul 1997 07:56:11 PDT

Hi Roger,

Good catch!  The IETF Job Mon MIB has some attempts at 'reasonably
unique' client job submission ID formats (which can also be supplied
in any of the defined formats by a helpful agent who notices that
no client job id was submitted with the job).

Xerox has over three years experience with some additional 'really
unique' client job submission ID formats in our private Job Mon MIB
work (we needed them for active job management - when you toss missiles
it's nice to hit the right job...)

Nearly every protocol at an application layer says things about
'global unique IDs', but not many define how to generate them
(including issues of character sets - IPP w/ UTF-8 may not have
that problem).

Cheers,
- Ira McDonald (outside consultant at Xerox)
  High North Inc
  PO Box 221
  Grand Marais, MI  49839
  906-494-2434
  "Outside of a dog, a book is a man's best friend...
      Inside of a dog, it's too dark to read" - Groucho Marx

---

From: Scott Isaacson <[email-masked]>
Date: Mon, 14 Jul 1997 21:23:08 -0600

Roger,

Since these "globally unique identifiers" are really just URIs, I changed
the document to get rid of the term "globally unique" and just explicitly
state that the object's identifier is a URI.   Therefore we are only as
"globally unique" as URIs are and we don't have to say how or why, we let
the URI people worry about that.

Scott

>>> Roger K Debry <[email-masked]> 07/14 7:11 AM >>>

On page 20 Section 4.6, it says
        "... have an identifier attribute whose value is globally unique
..."
I think we have to say how this is done, don't we?

Roger deBry