Subject: IPP> printer-resolution standard values retrograded

From: Tom Hastings <[email-masked]>
Date: Thu, 5 Jun 1997 08:38:46 PDT

The 970512.doc had the following for printer-resolution, but the
latest I-D 970603 has reverted to earlier text that didn't have any standard
values listed.

Did any other attributes retrograde?

Tom

6.2.12	printer-resolution (type2 keyword)
This job attribute specifies the resolution that the Printer should use.
The values are type2 keywords which represent single integers or pair of
integers. The latter are to specify the resolution when the x and y
dimensions differ. When two integers are specified, the first is in the x
direction, i.e., in the direction of the shortest dimension of the medium,
so that the value is independent of whether the printer feeds long edge or
short edge first.
The standard values are:
normal
res-100
res-200
res-240
res-300
res-600
res-800
res-1200
res-1800
res-100x200
res-300x600
res-600x300
res-400x800
res-800x400
res-600x1200
res-1200x600
res-1800x600

---

From: Ron Bergman <[email-masked]>
Date: Thu, 5 Jun 1997 10:05:35 -0700 (PDT)

Tom,

I agree that you new revised figure is correct.  But it has so 
many lines and lines crossing that I doubt it is useful.

I propose that we keep the original figure, but show the two paths
to "Aborted", with the added text:

"The Canceled state can be entered from the Pending, Pending-Held, 
Processing, or Processing-Stopped states."

	Ron Bergman
	Dataproducts Corp.

On Thu, 5 Jun 1997, Tom Hastings wrote:

> I agree that canceled can be entered from any state and that a system
> might (but need not) abort a stopped job.
> 
> The definition of the aborted state for IPP and JMP supports your
> idea with the weasil word "usually" in the definition:
> 
> aborted:
> The job has been aborted by the system, usually while the job was in the
> processing state.
> 
> So how does this picture look to you for IPP and JMP (IPP wouldn't
> have the enums and wouldn't have the "active/in-active" line, since
> it is a JMP-only term).
> 
> Running arrows from every state to canceled and from stopped to
> aborted would look like this:
> 
> >>              +--------->----------+------>------+--> canceled(7)
> >>              |                    |             |
> >>     +---> pending(3) -------> processing(5) -------> completed(9)
> >>     |        ^                    ^  \          |
> >> --->+        |                    |   +------------> aborted(8)
> >>     |        v                    v  /          |
> >>     +---> held(4)             stopped(6)        |
>                 |                    |             |
>                 +--------->----------+------>------+
> >> 
> >>           <-------------- active ------------>|<-- in-active -->|
> >> 
> 
> Is this figure ok?