Subject: Re: IPP> Re: draft-mutz-http-attributes-02.txt

From: [email-masked] (Robert Herriot)
Date: Thu, 5 Jun 1997 19:23:32 -0700

None of these solutions solve the problem of the Printer's 
resolutions-supported attribute which, hopefully, tells the
client exactly what resolutions the Printer supports without
any extraneous values and without a complicated structure
for the attribute.

Bob Herriot

> From [email-masked] Thu Jun  5 19:07:24 1997
> 
> I prefer not burdening all apps with 2 resolution numbers when most
> use square resolutions.
> 
> Once way around this:  Specify "res" to mean horizontal resolution and
> add "res-vert" to indicate vertical resolution.
> 
> If only res is indicated, then a client could assume square pixels.
> 
> I think this is sufficiently straightfoward.  Comment?
> 
> Andy
> 
> 
> > 
> > IPP, FAX, and HTTP need to know about resolution of the recipient
> > device; I don't think we need three different ways to deal with it.
> > 
> > Why not just be straightforward and specify resolution in two
> > directions as integers or rationals?
> > 
> > Larry
> > -- 
> > http://www.parc.xerox.com/masinter
> > 
> 
> 
> --
> ---------------------------------------------------------------
> Andrew Mutz                          |   email:  [email-masked] 
> Internet Imaging Operation           |   Phone:  +1 408 447 4439
> Internet Technology Group            |   Page:   +1 800 607 9639
> 11000 Wolfe Road 42UO                |   
> Cupertino, California, USA.          |   Radio:  KF6FUT
> ---------------------------------------------------------------
>

---

From: Larry Masinter <[email-masked]>
Date: Thu, 5 Jun 1997 19:31:12 PDT

> any extraneous values and without a complicated structure

I think this is the same problem fax has, though.
Why would a list of pairs of integers (x-res/y-res)
or integer & ratio (x-res, aspect ratio) have 'extraneous
values'? Or be a 'complicated structure'?