Subject: Re: IPP>PRO - Print by reference

From: Scott Isaacson <[email-masked]>
Date: Fri, 30 May 1997 13:07:51 -0600

Great summary.  I agree.

>>> "Scott Lawrence" <[email-masked]> 05/30 12:16 PM >>>

>>>>> "LM" == Larry Masinter <[email-masked]> writes:

LM> The difficult issue in print-by-reference is how the sender
LM> supplies the credentials if any at all are required. There
LM> is no single standard for identity in Internet protocols, and
LM> there's no standard encapsulation of credentials.

  Agreed; which, I presume, is why Roger K deBry [RKD] suggested that
  only 'publicly available' [a question-begging term, IMHO] documents
  could be printed by reference:

RKD> The two conditions required are that the document be in a
RKD> standard printable format and that the document be publicaly
RKD> available.

  My answer is to say that no credentials of the user are employed by
  the printer to obtain the referenced document; instead, whatever
  credentials of its own the printer has are used.  This degenerates
  to Rogers' model when the printer has no credentials of any kind
  (but note that the document repository might choose to consider the
  source IP address or domain name of the printer to be a form of weak
  but acceptable credential).  You might need an extra status or two
  to communicate the inability of the printer to access the referenced
  document, but I suspect you need that no matter how you do this.

--
Scott Lawrence           EmWeb Embedded Server       <[email-masked]>
Agranat Systems, Inc.        Engineering            http://www.agranat.com/

---

From: Larry Masinter <[email-masked]>
Date: Fri, 30 May 1997 13:20:43 PDT

I think that you might want to allow a 'reference'
to be a compound attribute consisting of a URL (the
location of the referenced resource) and the credentials
(the authority by which the reference is being accessed),
but leave the enumeration of possible credential types
empty for now; alternatively, you could define a reference
to be a URL (the location of a referenced resource) but
independently supply URL/credential pairs, as part of the
print submit.

But adding a protocol element which requires data access
for data which is frequently not 'public' without making
any accomodation at all for secure transmission of credentials
is probably not adequately addressing the security concerns:
it will encourage users to make private documents 'public'
merely for the capability of printing them; as such, it
would countermand the imperative to make the Internet more
secure, not less.

Let me say this a different way:
  Don't try to do print-by-reference without doing what's
  necessary to use it securely.

Larry 
-- 
http://www.parc.xerox.com/masinter