Subject: Re: IPP> DIR

From: [email-masked] (Yasunari Kitagaki)
Date: Fri, 23 May 1997 16:15:48 +0900

I have some comments.

>First, the URL:
>
>Using Windows, I trust that applications register the URIs they can handle,
>Netscap register ftp:// and http://, our Directory Browser register LDAP://
>etc. 
>I would like my Internet Printing application to register IPP:// so that
>Windows can hand it all print jobs.
>
First I address the proxy/firewall problem. Most current proxy/firewall
have no knowlege of the "IPP" sheme. 
 To print over firewall, "ipp://" not practical.

>And yes, you need to define a STRUCTURAL object Class printer with a new
>OID. It should probably be a subclass of device.
>
>Then BNF for the attributes, and assigned OIDs are more important than the
>API used to initialize the object.
>
I agree this point. 
But attribute syntax should be simple for simple implementation, I think.

>As for security, the IETF-ASID group is just now specifying to how to use
>TLS with LDAP (a one port solution), this may be suited for IPP.
IETF-ASID  group is specifying the LDAP v3 related topic.
Current version of LDAP does't need to assign OID, but from v3 draft, I
guess assigning OID is requred. X.500/LDAP mapping should work with
IETF-ASID group.

Yas
--------------------------------------------------------
Yasunari Kitagaki
Network Engneer-Systems Development Center-Minolta Co., Ltd.
e-mail:[email-masked]
Tel:+81-726-85-6184
FAX:+81-726-85-6185
1-2,  Sakura-Machi,  Takatsuki-Shi,  Osaka 569,  Japan

---

From: "Frode Hernes" <[email-masked]>
Date: 23 May 1997 13:03:22 Z

Hi,
>  To print over firewall, "ipp://" not practical.
It should be easy to enable another protocol through the firewall (using another port), an 
intelligent firewall may descide to block printing anyhow, because the actual protocol used 
is ipp, not http. If the ipp protocol is as successful as I expect it to be, most firewalls will come 
pre-configured to handle this anyway.

Frode.

- - - - - - - - - - - - -
Frode Hernes
MaXware

   12614 Builders Road
   Herndon, VA 20170
   Tel:(703) 435 2587
   Mobile:(703) 919 5166
   Fax:1 (800) 355 2071
   X.400:g=Frode;s=Hernes;o=MaXware;a=Telemax;c=No
   Mailto:[email-masked]

MaXware A.S:
   mailto:[email-masked]
   http://www.maxware.no