Subject: IPP> Protocol Definition

From: Randy Turner <[email-masked]>
Date: Thu, 10 Apr 1997 14:43:42 -0700

In the last two meetings (Austin & IETF Plenary in Memphis), we
have talked about HTTP as a transport for IPP, and in my 
proposal I have also used the "application/ipp" MIME type
as a delivery mechanism for "tunneling" the actual IPP-specific
protocol through HTTP. In each scenario we have discussed, we
have always talked about encapsulating an "IPP payload" and
I am working on exactly how to do this. My instinctive 
reaction to unambiguously specifying this protocol, and to
make it transport-independent, is to specify the protocol
using ASN.1. It seems like a good contender although its
syntax sometimes ruffles a few feathers within the PWG; still,
for the purposes of encapsulation, it is ideally suited for
this purpose.

I would like to propose that we specify the IPP protocol 
itself using ASN.1 language.

Comments ?  (yeah, right, like there won't be comments on this one...)

Randy

-- 
Randy Turner
Network Architect
Sharp Laboratories of America
[email-masked]

---

From: [email-masked] (Robert Herriot)
Date: Thu, 10 Apr 1997 18:10:54 -0700

> From [email-masked] Thu Apr 10 14:55:11 1997
> 

I am very unenthusiatic about ASN.1 because of its overhead.  In the
model group we have purposefully used keywords that are a string of
characters so that we could have a simple protocol that avoids OIDs and
ASN.1.

I would prefer that we stay with text and use the syntax rules from
rfc 2068, even for the IPP protocol, whatever it turns out to be.

Bob Herriot

---

From: Roger K Debry <[email-masked]>
Date: Fri, 11 Apr 1997 09:37:14 -0400

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

I second Bob's opinmoion. I prefer not to use ASN.1

-------------------- Forwarded by Roger K Debry/Boulder/IBM on 04/11/97 07:33
AM ---------------------------

        ipp-owner @ pwg.org
        04/10/97 07:19 PM

To: rturner @ sharplabs.com@internet, ipp @ pwg.org@internet
cc:
Subject: Re: IPP> Protocol Definition

Bob Herriot

---

From: Patrick Powell <[email-masked]>
Date: Fri, 11 Apr 1997 07:18:43 -0700 (PDT)

> Comments ?  (yeah, right, like there won't be comments on this one...)

<Professional Comment:>
  I feel that,  based on experience and working with
various diverse ASN.1 generation and/or parsing programs,
the that it is not a suitable method.

<Personal Comment:>
  Over my cold, stiff bleeding fingers on the keyboard!
No Way!  Having suffered the slings,  arrows, bricks,
and pain of ASN.1,  never again!  Simple text, simple
parsing, etc. etc.

<Resolution:>
If you want to us ASN.1 SYNTAX or NOTATION text format
I could see a point of departure.

Patrick Powell