Subject: IPP>PRO ideas for protocol meeting agenda (please comment)

From: [email-masked] (Robert Herriot)
Date: Wed, 5 Mar 1997 19:15:11 -0800

At the moment, I think that the agenda should be driven by the main
outstanding issues.  The five that we have inherited from the main
group do not seem to be high level issues to solve immediately.  I have
written down some high level issues that I think we need to resolve.
 
I suggest that our agenda be to resolve these issues. 
 
If anyone has other ideas about the agenda or additional issues, please send 
them by 5pm PST Thursday 3/6. 

I see this meeting taking very different directions depending on the
answers to some of the issues below.
 
Issues:  
 
   Do we first define a generic mapping (e.g. MIME) which in turn is mapped 
   to one or more protocols? If not MIME, then what?  
    
   What are the specifics of this mapping? 
    
      Mapping of operations and parameters to protocol
 
      Mapping of attributes and values to protocol.
 
   Is HTML supported as a separate generic mapping?
    
   Is one protocol HTTP? 
   
   Is there another, such as over a socket.

Bob Herriot

---

From: Randy Turner <[email-masked]>
Date: Thu, 06 Mar 1997 09:02:52 -0800

Another philosophical discussion we need to think about is whether
or not we allow the IPP model to dictate the type of transport
we would like to use, or do we constrain the IPP model document
to preferred transport mechanisms.

Randy

-- 
Randy Turner
Network Architect
Sharp Laboratories of America
[email-masked]

---

From: Carl-Uno Manros <[email-masked]>
Date: Thu, 6 Mar 1997 09:08:36 PST

>them by 5pm PST Thursday 3/6. 

Bob,

a couple of issues which I consider to be high level and which I would like
to get tackled are:

1) How difficult or easy is it to take abstract operations from the model
and break them up into several operations in the protocol, vs. how easy is
it to combine several abstract operations from the model and aggregate them
into one operation in the protocol? (The question of granularity of
operations in the model vs. in the protocol).

2) How do you bootstrap into using security protocols such as RFC 2069 and
SSL? This might have some impact on both model and protocol.  Also, is
anybody planning to actually implement RFC 2069?

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]