Subject: Re: IPP> PRO - Suggested text for form-data

From: Roger K Debry <[email-masked]>
Date: Thu, 20 Mar 1997 09:45:59 -0500

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

Larry ... I agree with Bob, I think we really need several examples to
illustrate the use of this encoding.  Although they may not have to be part of
the RFC, I'd like to see some examples using IPP operations so that I can
really see what is intended.   It's not clear to me from what is written.

---------------------- Forwarded by Roger K Debry/Boulder/IBM on 03/20/97 07:41
AM ---------------------------

        ipp-owner @ pwg.org
        03/19/97 08:28 PM

To: masinter @ parc.xerox.com@internet
cc: ipp @ pwg.org@internet
Subject: Re: IPP> PRO - Suggested text for form-data

I have a few questions about form-data.

Am I correct in assuming that if a form does not have
<FORM ENCTYPE="multipart/form-data", the data is send as a string
of several 'name=value', e.g. "foo=xxx&bar=yyy"?

When form-data is sent, what parts of the form are encoded in the
field data?  From examples in rfc1867, it appears to me that the
name of the field is encoded in the content-disposition field and that
the value is in the entity body. Am I right?  Are any other parts of
a form field returned with form-data?

The examples given in the protocol meeting implied that a selection
list would return the "name" of the value rather than the actual
string displayed to the user.

The examples in rfc1867 help, but they don't cover many types of fields.

Can you provide more examples or tell me how other types of fields
are handled?

Thanks.

Bob Herriot

---

From: Larry Masinter <[email-masked]>
Date: Thu, 20 Mar 1997 14:42:08 PST

> really see what is intended.   It's not clear to me from what is written.
OK

> of several 'name=value', e.g. "foo=xxx&bar=yyy"?

I don't think IPP should consider using the "x-www-url-encoded" method
for submitting form data ever.

> a form field returned with form-data?

Yes, the names of the fields and the values are encoded as you indicate,
and nothing else.

> string displayed to the user.

If the form field is a text field, then it is the actual string
entered by the user, but in other cases, you're right, it is the
'name' of the value rather than what the user saw.

> Can you provide more examples or tell me how other types of fields

This is standard web technology; see
   ftp://ftp.parc.xerox.com/pub/masinter/file-upload-impl.txt

for a list of packages that implement parsing for multipart/form-data.
I'd guess that most of the packages include examples.

Larry