Subject: IPP> "IPP" == "DPA" -Reply

From: Scott Isaacson <[email-masked]>
Date: Thu, 20 Mar 1997 10:23:59 -0700

DPA seems like an "everthing in it from the beginning" type of standard
with implementations that are "NOT everything in it" 

I was hoping that IPP would follow the IETF approach: keep it simple and make it a
reality.  In other words, IPP should be "just the basics from the beginning" with
implmentations that are also "just the basics"  Then there is some sort of growth path
with new versions with more attributes etc...   

Look at HTML, HTTP, SMTP, FTP...

THE REASON WHY THEY WIN IS BECAUSE THEY ARE STUPIDLY SIMPLE.  THEN THEY GET ACCEPTED AND
THEN THEY GROW rather than coming in with EVERYTHING in the spec, NOTHING gets
implemented, and there is NO SUCCESS

Some days I am tempted to rip the whole model document right in half
and just leave jobs status and printer status attributes.  We all know
that is too simple, but since we all lean (myself included) to be too
complex maybe we just need some balance. 

Scott

>>> JK Martin <[email-masked]> 03/20/97 03:27am >>>
After reviewing Tom Hasting's most recent issues document, it is
really starting to appear that "IPP" is simply the 1990's name
for "DPA" in terms of scope and complexity.

Does anyone else out there share this view?

	...jay

---

From: Patrick Powell <[email-masked]>
Date: Sat, 22 Mar 1997 16:03:36 -0800 (PST)

Scott,  having looked at the overall IPP thing,  I think that
the IPP Model is burdened by trying to be compatible with too much
existing stuff.

I am sorry that I missed Friday's meeting,  on the phone,  but
when I came into my office there were construction workers
moving our lab out.

Apparently they want to paint during the holidays and figured that
nobody would be here.  I spent Friday moving equipment and putting
plastic sheets over $5,000,000.00 worth of network gear,  that they
forgot all about.

Printing looks like a welcome vacation.

By the by - we just finished moving stuff at 2:30 Saturday morning....
Sigh...

Patrick Powell