Subject: IPP>MOD - Standard API required???

From: [email-masked]
Date: Mon, 3 Mar 1997 09:54:22 -0500

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

We have stated that applications and end-users will use IPP, but we haven't
ever discussed that IPP will have an API. Do we assume that each implementation
will provide a unique API or do we assume that we will define a standard API?

---

From: Carl-Uno Manros <[email-masked]>
Date: Mon, 3 Mar 1997 09:47:34 PST

>will provide a unique API or do we assume that we will define a standard API?

Roger,

defining a standard API for IPP might be a good idea in general, but I
would strongly recommend that we focus our attention on getting the model
and protocol sorted out first.

To my knowledge, IETF does not deal with standards for APIs, so the PWG
would need to look at organizations such as IEEE or X/Open to host any such
future work.

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]