Subject: RE: IPP> New HTTP Methods vs POST -Reply

From: [email-masked]
Date: Tue, 11 Feb 1997 15:16:05 -0500

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

Yes, I like this too.  I'll add it.

---------------------- Forwarded by Roger K Debry/Boulder/IBM on 02/11/97 01:16
PM ---------------------------

        IINUS1.SMTP2 @ D03AU017
        02/11/97 01:09 PM
Please respond to IINUS1.SMTP2 @ VM

To: Roger K Debry/Boulder/IBM
cc:
Subject:  RE: IPP> New HTTP Methods vs POST -Reply

Received: from alpha.xerox.com by vnet.IBM.COM (IBM VM SMTP V2R3) with TCP;
   Tue, 11 Feb 97 15:07:19 EST
Received: from mailhost.cp10.es.xerox.com (*13.240.124.12*) by alpha.xerox.com
with SMTP id <14980(3)>; Tue, 11 Feb 1997 12:07:19 PST Received: from garfield
(garfield.cp10.es.xerox.com) by mailhost.cp10.es.xerox.com (4.1/SMI-4.1) *id
AA29619; Tue, 11 Feb 97 12:08:07 PST Received: from cpq5100-26 by garfield
(SMI-8.6/SMI-SVR4) *id MAA06514; Tue, 11 Feb 1997 12:05:16 -0800 Message-Id:
<3.0.32.19970211120752.008ee6f8@garfield> X-Sender: cmanros@garfield X-Mailer:
Windows Eudora Pro Version 3.0 (32) Date: Tue, 11 Feb 1997 12:07:53 PST To:
[email-masked] From: Carl-Uno Manros <[email-masked]> Subject:
RE: IPP> New HTTP Methods vs POST -Reply Cc: [email-masked]
Mime-Version: 1.0 Content-Type: text/plain; charset="us-ascii"

At 07:31 AM 2/11/97 PST, [email-masked] wrote:
>Classification:
>Prologue:
>Epilogue: Roger K deBry
>Senior Techncial Staff Member
>Architecture and Technology
>IBM Printing Systems
>email: [email-masked]
>phone: 1-303-924-4080
>
>Babek, sounds encouraging.  I was going to make a few changes to the
>white paper anyway to reflect your notion of getting the job handle before
>sending
>the data. I thought that everyone liked this scheme.

Roger,

another part that I liked was that the attribute stuff gets sent before the
actual document. This would allow validation of the print request
parameters, and hence a possible refusal if the job cannot be done, before
the actual document data are sent, which would benefit both the user and
the print service.

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: Randy Turner <[email-masked]>
Date: Tue, 11 Feb 1997 13:25:21 -0800

I also basically agree with the current POST operational ideas:

	POST for start-job 
	POST print job data
	POST end-job

for the start-job POST, I would like to see the IPP server return
preformatted URLs for subsequent operations to this particular
server job, such as status requests, cancel request, etc.

The IPP "standard" part of this specification would only specify
the order that these URLs are transmitted by the server, but not
the format of the individual URL components.

i.e.,

POST start-job