Subject: IPP> MOD - Comments on printer-state, printer-state-reasons viz a viz Printer MIB

From: Tom Hastings <[email-masked]>
Date: Thu, 20 Feb 1997 04:37:31 PST

I'd like to discuss this issue on printer-state this Friday, 2/21 at the 1:00pm
PST (4:00 pm EST) IPP Model telecon.

Thanks,
Tom

>Date: Wed, 19 Feb 1997 21:33:01 -0800
>To: ipp
>From: Tom Hastings <[email-masked]>
>Subject: MOD - Comments on printer-state, printer-state-reasons viz a viz
Printer MIB
>Cc: pmp
>
>I've posted some comments on the printer-state, printer-state-reasons, and
>printer-state-as-text IPP attributes:
>
>ftp://ftp.pwg.org/pub/pwg/ipp/new_MOD/
>
>-rw-r--r--   1 pwg      pwg        20992 Feb 20 05:17
printer-state-comments-tnh.doc
>-rw-r--r--   1 pwg      pwg        19424 Feb 20 05:18
printer-state-comments-tnh.pdf
>
>Bob and I are proposing a drastically reduced set of printer states:
unknown, idle, processing (Bob prefers: printing), and mixed.  
>
>The printer-state-reasons attribute indicates:
>
>  (1) orthogonical states, such as printer disabled from accepting Print
operations 
>      and printer paused (by operator) so maps cleanly to ISO DPA
>  (2) printer conditions (binary change events from the Printer MIB).
>
>I've copied the pmp list as well, to see if they agree with the idea
>of how to represent all of the Printer MIB binary change events, both
>critical and warning as values of the Printer's printer-state-reasons
attribute.
>
>Please send comments to the ipp list with "MOD -" as the first 5 characters
of the
>subject line.
>Thanks,
>Tom

---

From: Tetsuya Morita <[email-masked]>
Date: Fri, 21 Feb 1997 00:47:32 +0900

Tom,

Some comments on your "printer-state-comments-tnh.doc".

 > unknown, idle, processing (Bob prefers: printing), and mixed.  

If you delete 'needs-attention' and move it to 'printer-state-reasons',
you should change the definition of role of 'printer-state-reasons'.
They were defined as the reasons in the state of 'needs-attention'.
It is noted in 5.6.1.2 printer-state-reasons on model-1.3.

What is the actual definitions and the difference in client's usage 
of 'printer-state' and 'printer-state-reasons'?
Now I am confused on that point.

 > >  Tom's States      Ricoh's States  Comments
 > > ============================================================================
 > >   shutdown          power-off      Same meaning
 > now proposed to be a printer-state-reason, ok?
 >
 > >   processing        executing      Same meaning
 > >   needs-attention   error          needs-attention and needs-key-operator
 > included
 > now proposed to be a printer-state-reason, ok?
 > >   unknown           unknown        Same meaning
 > >   idle              idle           Same meaning

I would like to answer your question after the both definitions are
cleared.

Thanks,

---
Tetsuya Morita
Ricoh Company Ltd.
Printer Business Center