Subject: IPP> FW: MyPost vs. Post

From: [email-masked]
Date: Tue, 25 Feb 1997 10:21:38 -0500

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

Babek, so would you propose one new method, say "PRINT" with sub-operations to
express the IPP methods, or would you propose several new HTTP methods, one for
each IPP method?
---------------------- Forwarded by Roger K Debry/Boulder/IBM on 02/25/97 08:17
AM ---------------------------

        ipp-owner @ pwg.org
        02/24/97 08:24 PM

To: Roger K Debry/Boulder/IBM, ipp @ pwg.org@internet
cc:
Subject: IPP> FW: MyPost vs. Post

Seems like Win32 Internet APIs allows inventing a new HTTP method in the
client side as well.

>-----Original Message-----
>Sent: Monday, February 24, 1997 7:15 PM
>To: Babak Jahromi
>Subject: RE: MyPost vs. Post
>
>In that case the answer is yes for WinInet. --
>When you call HttpOpenRequest(), the second argument is the verb which can be
>anything -- a GET, a POST, or whatever else you will pass to that function.
>--Wininet Development
>
>----------
>From:  Babak Jahromi
>Sent:  Monday, February 24, 1997 6:57 PM
>Subject:  RE: MyPost vs. Post
>
>
>What I have in mind is to potentially define a new "post" command that both
>client and the server would understand and use.   Today Windows Internet
>clients (like the browser) use Wininet.dll APIs to talk to an HTTP server. So
>to invent a new HTTP method, ideally the client can tell the Wininet APIs to
>use this new custom method, and on the server side we can implement an ISAPI
>filter that horors the new method.
>
>Babak
>

---

From: Babak Jahromi <[email-masked]>
Date: Tue, 25 Feb 1997 10:00:58 -0800

At this point Microsoft in not inventing a new HTTP printing method for
NT 5.0. I was only talking about the future possiblities. I am not even
convinced inventing a new HTTP method would by us anything. But it seems
like we can invent new methods if it turns out to be beneficial, and
still depend on stock Web servers and clients.

Babak

>From:	[email-masked] [SMTP:[email-masked]]
>Sent:	Tuesday, February 25, 1997 7:22 AM
>To:	Babak Jahromi; [email-masked]

---

From: Babak Jahromi <[email-masked]>
Date: Tue, 25 Feb 1997 11:42:39 -0800

Let me calrify a point regarding the support in "stock" clients for new
HTTP methods:

I was not including the browsers here, rather I was referring to the
underlying APIs that clients programs can call to issue these methods
(browsers would just be another client programs in this frame work). I
was basically saying that Win32 Internet/Intranet APIs do allow the use
of a new HTTP method. So anyone, perhaps the IPP printer client module,
can depend on these APIs to issue a custom IPP method over HTTP.

Again, not that I believe we need to do this at this point.

Babak

>Sent:	Tuesday, February 25, 1997 10:01 AM
>To:	[email-masked]'; [email-masked]
>Subject:	RE: IPP> FW: MyPost vs. Post
>
>
>At this point Microsoft in not inventing a new HTTP printing method for NT
>5.0. I was only talking about the future possiblities. I am not even
>convinced inventing a new HTTP method would by us anything. But it seems like
>we can invent new methods if it turns out to be beneficial, and still depend
>on stock Web servers and clients.
>
>Babak
>