Subject: IPP> SEC - Re: Minutes from SEC meeting in El Segundo, February 7

From: Carl-Uno Manros <[email-masked]>
Date: Wed, 12 Feb 1997 09:33:27 PST

At 08:06 PM 2/11/97 PST, Larry Masinter wrote:
>The most important NEW security issues (where you don't just
>have to pick which thing to do) are: how to accomplish
>third-party credentials when doing print-by-reference, and
>secondly, how to establish credentials for job control
>after job submission even when there isn't authentication.
>
>I didn't see those in your security list, but maybe I missed
>them.
>

Larry,

in answer to your first concern, we did discuss that briefly, but
decided that the retrieval of the file is not part of the actual 
Internet Printing Protocol, it is determined by the URL of
the reference. We therefore left that out of the initial discussion,
but even so, it would be nice to find a solution to the problem in 
general. Do you have any proposal on where we might find one?

I am not quite sure I understand quite what you mean with your second
comment. Users typically only have access to their own jobs, and they
will be given a job-id from the "printer" for each job they submit.

Carl-Uno

Carl-Uno Manros
Principal Engineer - Advanced Printing Standards - Xerox Corporation
701 S. Aviation Blvd., El Segundo, CA, M/S: ESAE-231
Phone +1-310-333 8273, Fax +1-310-333 5514
Email: [email-masked]

---

From: Larry Masinter <[email-masked]>
Date: Wed, 12 Feb 1997 19:44:18 PST

I was imagining that you could come up with a security
paradigm that the authorization to modify a job once
submitted might be independent of the authorization and
authentication necessary to submit the job in the first place.
That is, the submission process itself might return some
credentials for subsequent job manipulation operations.

I'm worried that unless we make progress on authorization,
we'll either have a free-for-all (no security) or else a lack
of interoperability (there is no global authentication domain
that works across the Internet).

Larry