Subject: IPP>MOD - Updated Diagram

From: [email-masked]
Date: Wed, 26 Feb 1997 18:25:37 -0500

Classification:
Prologue:
Epilogue: Roger K deBry
Senior Techncial Staff Member
Architecture and Technology
IBM Printing Systems
email: [email-masked]
phone: 1-303-924-4080

Here is an updated diagram based on Babek's comments and those
made during today's phone call.  Comments???

                             +-------------+
                             | Application |
                             +-----+-------+
                                   |
                      o      +-----+-------+
                     \|/     |   Spooler   |
                     / \     +------+------+
                    End-User        |
                    +-----+  +------+-------+
                    | GUI |  | Print Driver |
                    +--+--+  +------+-------+
                       |            |
                   +---+------------+---+
       D   S       |      IPP Client    |
       I   E       +---------+----------+
       R   C                 |
       E   U
       C   R    --------- Transport -----------
       T   I
       O   T                 |
       R   Y        +--------+----------+
       Y            |     IPP Server    |
                    +--------+----------+
                             |
                    +--------+----------+
                    |   Print Service   |
                    +--------+----------+
                             |
                       Output Device(s)

---

From: [email-masked] (Robert Herriot)
Date: Wed, 26 Feb 1997 18:03:56 -0800

Although your picture now reflects Windows applications more
accurately, it is now too Windows specific.  If the spooler and driver
box were eliminated, then this diagram would indicate that a client
application interacts with the ipp client (library). For Windows the
application consists of a spooler, driver and print provider, but that
is probably more detail than our document needs.

Also, the browser is just a special application, though it may be 
important enough to show separately.

Bob Herriot

> From [email-masked] Wed Feb 26 15:27:55 1997
>

---

From: [email-masked]
Date: Thu, 27 Feb 1997 10:48:59 -0500

Classification:
Prologue:
Epilogue: Roger K deBry

Bob, because of the number of windows clients and the desktop appIications that
run on windows clients,  I believe that the Windows case is too important to
simplify
as you've suggested. However the diagram could possibly show spooler and
device driver as optional components.

Any one else have strong feelings on this?
---------------------- Forwarded by Roger K Debry/Boulder/IBM on 02/27/97 08:42
AM ---------------------------

        ipp-owner @ pwg.org
        02/26/97 07:07 PM

To: Roger K Debry/Boulder/IBM, ipp @ pwg.org@internet
cc:
Subject: Re: IPP>MOD - Updated Diagram

---

From: [email-masked] (Robert Herriot)
Date: Thu, 27 Feb 1997 12:34:27 -0800

If you are going to show the Windows case, then there are two ways.  In
both cases an application connects directly with an IPP client. Then
either have another case with the intervening  Windows pieces, or have
a separate diagram to explode the application box for the Windows
case.

> From [email-masked] Thu Feb 27 07:50:58 1997
> From: [email-masked]
> To: <[email-masked]>, <"robert.herriot@ENG"@??.ibm.com>,
>         <[email-masked]>
> Date: Thu, 27 Feb 1997 10:48:59 -0500
> Mime-Version: 1.0
> Sender: [email-masked]
> X-Lines: 37
> 
> Classification:
> Prologue:
> Epilogue: Roger K deBry