Subject: IPP> BOF Presentation Comments

From: "Harry Lewis <[email-masked]>" <[email-masked]>
Date: Tue, 3 Dec 96 10:41:04 MST

I reviewed the 3 slide BOF presentation and have the following comments.

The first "foil" is a bit tongue tied in that it references Internet printing
AFTER initial set-up but later includes installation, configuration etc in
the IPP definition. Also, I think this paragraph makes unnecessary and unclear
distinctions between remote, local and lan printing. Below, I will include
the current wording followed by my recommended rewrite. Note, I also removed
the word "paradigm" because I believe Internet printing will be viewed as a
new paradigm.

> Internet Printing is the application of World Wide Web tools, programs,
> servers and networks to allow "end-users" to print to a remote printer
> using, after initial setup or configuration, the same methods, operations
> and paradigms as would be used for a locally attached or a local area
> network attached printer. This includes the use of HTTP servers and
> browsers for providing static, dynamic and interactive printer locating
> services, user installation, selection, configuration and status inquiry
> of remote printers and jobs.

Internet Printing is the application of World Wide Web tools, programs,
servers and networks to allow "end-users" to print using methods and
operations similar to those currently used for locally attached or LAN
printing in the platform dependent OS. Internet Printing will include the
use of HTTP servers and browsers for providing static, dynamic and
interactive print services location, printer installation, selection and
configuration as well as remote printer and print job monitoring.

Harry Lewis - IBM Printing Systems

---

From: Don Wright <[email-masked]>
Date: 3 Dec 96 14:08:12 EST

I made Harry's suggested change except I changed "...browsers
for providing static..." to "...browsers to provide static..."  Rolls off
the tongue a little better.

Don

To: ipp%pwg.org @ interlock.lexmark.com @ SMTP
cc:  (bcc: Don Wright)
From: harryl @ vnet.ibm.com>" <[email-masked] 
("Harry Lewis) @ SMTP
Date: 12/03/96 10:41:04 AM
Subject: IPP> BOF Presentation Comments

---

From: [email-masked] (Robert Herriot)
Date: Tue, 3 Dec 1996 14:02:05 -0800

I have reviewed the 3 foils and I have the following suggestions.

I still think that the first foil is too complicated, and I am not sure
I even understand the meaning of half of it. I have tried to simplify it
into an easy-to-read bullet format while keeping the intent that I
understand.

My suggestion for the first foil is:

Internet Printing
   o uses World Wide Web tools, programs, servers and networks.
   o works for printers that are attached locally or via a network.
   o uses HTTP servers and browsers to provide print operations which include
      o browsing for printers
      o printing jobs
      o cancelling jobs
      o monitoring and managing jobs and printers
      o configuring printers

If I have left out some important ideas above, they can be added to this
format.

Overall, the bullets need to have parallel parts of speech.

On foil 2, alerting is mentioned for the operator but not for the end-user.
The 3 bullet items under submitting a print job don't seem to be parallel.
"From standard applications" and "Background or batch applications" seem
to be nearly the same, i.e. "from applications". The "via reference" seems
to be very different and I assume it is contrasting "with document content"
which is not mentioned.  I would suggest two bullets:
 
     o from applications
     o with document content or a reference to it

"Changing job and printer status" An operator cannot change job or
printer status, but can change other attributes of each object. The
phrase probably should be "changing some printer and job attributes."

There needs to be a new bullet item that says that an administrator 
can configure a printer.

On foil 3, what does "operator requirements" refer to?

I think that "Independent" and two sub items should be changed to
"Platform Independent for client and server".  

What does "enabled" mean for I18N? Perhaps it is enough to make
the item and sub item be just "Internationalized".

Bob Herriot

> From [email-masked] Tue Dec  3 11:14:19 1996
> To: "harryl%vnet.ibm.com" <[email-masked]>
> Cc: "ipp%pwg.org" <[email-masked]>
> From: Don Wright <[email-masked]>
> Date:  3 Dec 96 14:08:12 EST
> Subject: Re: IPP> BOF Presentation Comments
> Mime-Version: 1.0
> Sender: [email-masked]
> X-Lines: 45
>

---

From: Carl-Uno Manros <[email-masked]>
Date: Tue, 3 Dec 1996 15:28:16 PST

I tend to agree with Bob that we need a number of clear and crisp bullits
that convey the right kind of message, while trying to avoid formulations
that could be misinterpreted.

What I hope to get out of the requirements presentation is a clear
explanation of the kind of scenarios that we try to address. Would it be
possible to re-use some of the scenario figures from the original IBM
document to lighten this up a bit with some graphics rather than just plain
text bullits?  We have 30 minutes allocated to this  part of the agenda and
3 slides seem a bit scarce anyway. If we need more material, I suggest that
we present the text from our proposed IETF Charter (although there is a
considerable overlap).  

Also, I expected us to cover why we are not building on the old RFC 1179
(the X/Open material has now been posted to the PWG server by Tom Hastings),
and possibly also why we are not explicitly considering using the SVR LOC
solution. If these subjects do not get covered here, I suggest they needs to
get covered in Scott's presentation afterwards. (I consider it better to
grab the bull by the horns right away, rather than wait until it is brought
up by one of the BOF visitors).

Carl-Uno

---

From: Don Wright <[email-masked]>
Date: 4 Dec 96 8:12:06 EST

Carl-Uno:

As I had previously stated, I plan to include the LPD issues but
was waiting for input from Tom Hastings.  As far as SVR LOC versus
LDAP, I think stating a requirement for being able to find the 
desired printer is proper for the requirements statement; implementation
choices should either be covered by Scott or left as issues that
the WG will have to deal with.

My assumption up front was that the Charter discussion was going
to occur in close proximity to the requirements presentation
and I didn't want to cover too much of that material in the requirements
section.  I think the Charter discussion should be more focused on
how we plan to address the requirements and should therefore
cover planned implementation details.

What do you think?

In regards to Bob's comments -- warning soap box ahead ---
about the first chart:

As far as I am aware, there is no rule that says presentation 
charts may not contain complete sentences, clauses, non-trivial
parts of speech, etc.  I think defining something like Internet
Printing in complete sentences is more precise than simply
a list of bullets.  Maybe we need both?

Don

To: ipp%pwg.org @ interlock.lexmark.com @ SMTP
cc:  (bcc: Don Wright)
From: cmanros%cp10.es.xerox.com @ interlock.lexmark.com (Carl-Uno Manros) @ SMTP
Date: 12/03/96 03:28:16 PM
Subject: Re: IPP> BOF Presentation Comments

Carl-Uno

---

From: [email-masked]
Date: Wed, 4 Dec 1996 08:55:40 -0500

Classification:
Prologue:
Epilogue:

My comments follow ...
---------------------- Forwarded by Roger K Debry/Boulder/IBM on 12/04/96 06:26
AM ---------------------------

        ipp-owner @ pwg.org
        12/03/96 04:49 PM

To: ipp @ pwg.org@internet
cc:
Subject: Re: IPP> BOF Presentation Comments

<<RKD>> I also agree ...

<<RKD>> I agree ... of course, I'm a picture oriented
<<RKD>> person. Probably comes from reading too many
<<RKD>> comic books as a kid. My personal presentation
<<RKD>> style is to use pictures and talk the words. Of
<<RKD>> course you want people to walk away with a set
<<RKD>> of words, but that is why we published a req'ts
<<RKD>> document.

Carl-Uno

>   o uses HTTP servers and browsers to provide print operations which include
<<RKD>> We should not preclude new print clients specifically
<<RKD>> written to provide IPP function, nor the imbedding of
<<RKD>> IPP support directly into the operating systems.
>      o browsing for printers
<<RKD>> I prefer locating printers based on attributes
>Overall, the bullets need to have parallel parts of speech.

<<RKD>> yes - for example under end user the current foil
<<RKD>> says finding and location ...should be finding and
<<RKD>> locating.

<<RKD>> Once again I'm concerned about being too browser
<<RKD>> specific. The operations mentioned here could be
<<RKD>> be done from a unique print client, from a driver,
<<RKD>> or by code imbedded in the operating system.

<<RKD>> Is submitting a print job from a standard application
<<RKD>> meant to imply the use of print drivers (the desktop
<<RKD>> model? Maybe you need to say this to clarify the
<<RKD>> distinction between this and background or batch
<<RKD>> printing. This would solve Bob's concern below.
>There needs to be a new bullet item that says that an administrator

<<RKD>> I would replace authorization lists with
<<RKD>> acess control lists, since ACL is the term
<<RKD>> that we use in the specifiation.

>On foil 3, what does "operator requirements" refer to?
<<RKD>> I suspect that this should be end-user, and refers
<<RKD>> to the fact that the specification initially will
<<RKD>> only address the end-user requirments.

---

From: "Harry Lewis <[email-masked]>" <[email-masked]>
Date: Wed, 4 Dec 96 08:44:07 MST

I agree with Don -(my formal recommendation at bottom of this note).

>a list of bullets.  Maybe we need both?

in that I think leading off with a "paragraph" gives the presentation
a good ramp into the finer detail.

I did like some of Bob's additional points -

>>      o monitoring and managing jobs and printers

and don't see why they can't be a separate slide or worked into the
other slides.

I like the idea of leading off with the paragraph which Don wrote and
I modified (or some further modification thereof). I've taken another
run at it... below:

  * Internet Printing is the application of World Wide Web tools,
  * programs, servers and networks to provide a print environment
  * which is used and managed via the internet yet operates in a manner
  * familiar to those using today's platform dependent print subsystems.
  *
  * Internet Printing will include the use of HTTP servers and browsers to
  * provide static, dynamic and interactive print services location, printer
  * installation, selection and configuration as well as remote printer and
  * print job monitoring and control.