Subject: RE: IPP> Desperately seeking info on HTTP servers and CGI scripts

From: Babak Jahromi <[email-masked]>
Date: Wed, 4 Dec 1996 16:59:41 -0800

I think the ISAPI interface will have to be considered as well.

Babak

>----------
>From: 	Chuck Adams[SMTP:[email-masked]]
>Sent: 	Wednesday, December 04, 1996 4:45 PM
>To: 	Tom Hastings
>Cc: 	[email-masked]
>Subject: 	Re: IPP> Desperately seeking info on HTTP servers and CGI scripts
>
>Tom Hastings wrote:
>> 
>> Apparently there are a lot of books on HTTP.  However, they have a lot of
>> detail and it has been reported that it is hard to find out about
>> HTTP servers and CGI scripts.
>> 
>> The IPP project has agreed as a goal that the IPP protocol can be
>>implemented
>> in an HTTP server as a CGI script that interfaces with a printer or print
>> system using whatever protocol that printer or print system supports so
>>that
>> no modifications have to be made to the HTTP server, except installing the
>> CGI script.
>> 
>> Presumably you need a separate CGI script for each such printer or print
>> system job submission protocol.
>> 
>> So where can we find out more about what CGI scripts are and what kinds
>> of things can be written in them?  Are there RFCs?  Library books?
>
>	I have a copy of "Build a Web Site: The Programmer's
>	Guide to Creating, Building and Maintaining a Web 
>	Presence" by net.Genesis and Devra Hall, Prima Publishing,
>	ISBN: 0-7615-0064-2.  It is an introductory book on
>	CGI scripts and WEB sites.
>
>Chuck Adams
>Tektronix, Inc.
>

---

From: Tom Hastings <[email-masked]>
Date: Wed, 4 Dec 1996 17:39:22 PST

Babak,

I'm not familiar with the ISAPI, can you tell us more?
Is there a document or web URL that we can access?

Thanks,
Tom

---

From: Judith Slein <[email-masked]>
Date: Thu, 5 Dec 1996 07:28:45 PST

NCSA has a lot of information on CGI available online at:
http://hoohoo.ncsa.uiuc.edu/cgi/

Spec for CGI/1.1 (Internet Draft, now expired):
http://www.ast.cam.ac.uk/~drtr/cgi-spec.html

At 04:20 PM 12/4/96 PST, Tom Hastings wrote:
>The IPP project has agreed as a goal that the IPP protocol can be implemented
>system using whatever protocol that printer or print system supports so that
>We want to prototype the IPP protocol as we develop it.
>
>Thanks,
>Tom
>
>
>
Name:		Judith A. Slein
E-Mail:		[email-masked]
Phone:  	8*222-5169
Fax:		(716) 265-7133
MailStop:	128-29E

---

From: [email-masked] (Jeff Copeland)
Date: Thu, 5 Dec 96 10:17:29 MST

I've used two CGI books with some success:

_HTML & CGI Unleashed_ (by December & Ginsburg, Samsnet, 
ISBN 0-672-30745-6), though some of it is dated.

_CGI Progamming on the World Wide Web_ (by Gundavaram,
O'Reilly, ISBN 1-56592-168-2), which covers some 
material not in the former, and is probably a better
CGI book.

JLC