Subject: IPP> Re: New Internet-Draft Request [ job-state-reasons being empty]

From: Tom Hastings <[email-masked]>
Date: Sun, 24 Nov 1996 08:27:08 PST

At 23:54 11/22/96 PST, Robert Herriot wrote:
>More comments on Ipp93rev.doc
>
>line 1347: the syntax for job state reasons should be (#type2Enum) because
there can be 0 reasons.

While I agree that job-state-reasons has a natural interpretation
when there are no values, namely that there are no reasons associated
with the current job state (and the semantics say that no reasons is
valid), Carl-Uno and I think that it is simpler and more consisten to
always require a value for job, printer (and Job template) attributes.
So we prefer to add a "none" value to job-state-reasons and keep the
syntax as (1#type2Enub).  Then every attribute that is a list, must
have at lease one member.  Ok?

Tom (and Carl-Uno)

---

From: [email-masked] (Robert Herriot)
Date: Mon, 25 Nov 1996 16:56:44 -0800

I prefer that we keep this as an issue.  Although I
understand your reasons for not wanting empty values, there
may be good reason for attributes whose values are a set of 0 or
more values. 

The issue is that you would like to represent the NULL Set by
a set having a special member which cannot coexist with other members.
This solution may add more complexity than we are removing.

Bob Herriot

> From [email-masked] Mon Nov 25 16:42:21 1996
> X-Sender: hastings@zazen
> X-Mailer: Windows Eudora Pro Version 2.1.2
> Mime-Version: 1.0
> Date: Sun, 24 Nov 1996 08:27:08 PST
> To: robert.herriot@Eng (Robert Herriot)
> From: Tom Hastings <[email-masked]>
> Subject: IPP> Re: New Internet-Draft Request [ job-state-reasons being empty]
> Cc: [email-masked], [email-masked]
> Sender: [email-masked]
> X-Lines: 18
>