Subject: Are "embellishments" really desirable right now?

From: [email-masked] (JK Martin)
Date: Fri, 22 Nov 96 17:16 EST

Bob Herriot wrote:

> I agree with Tom that if the values of number-up are really an enum
> with values of none, 1, 2, 4, then 'none' means normal printing and 1,
> 2 and 4 mean default embellishments with 1, 2 or 4 pages per
> impression.  The embellishments attribute is an extra if we believe
> that printers support multiple embellishments.

This whole area of "embellishments" (aka formatting styles) is somewhat
getting away from the "protocol" aspects of IPP, is it not?

I mean, what we're talking about here is an entire domain of how
a job can be formatted independent of content and/or data type.

This can be a *real* rathole...unless we can specify clearly usable
extensibility, preferably by example.

If we're not careful, the whole issue of watermarks and generic forms
processing could loom its head, and if that happens, we'd better be
able to respond.

	...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03015-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

---

From: Tom Hastings <[email-masked]>
Date: Fri, 22 Nov 1996 15:11:54 PST

I agree, lets avoid ratholes.

Looks like we should probably avoid adding an emplishments attribute
as a separate job attribute right now.

Bob is happy with the four values for number-up and making it a
type3Enum: "none", "1", "2", and "4".  Bob wrote:

>I agree with Tom that if the values of number-up are really an enum with
values >of none, 1, 2, 4, then 'none' means normal printing and 1, 2 and 4 mean 
>default embellishments with 1, 2 or 4 pages per impression.  
>The embellishments attribute is an extra if we believe that printers 
>support multiple embellishments.

Anyone objection out there if we don't add an emblishments job attribute 
for version 1.0?

Tom

>Return-Path: <[email-masked]>
>Date: Fri, 22 Nov 1996 14:16:00 PST
>From: [email-masked] (JK Martin)
>To: [email-masked]
>Subject: Are "embellishments" really desirable right now?
>Sender: [email-masked]
>
>Bob Herriot wrote:
>

---

From: [email-masked] (Robert Herriot)
Date: Fri, 22 Nov 1996 16:59:22 -0800

I agree. I was not suggesting that embellishments should be an IPP attribute in this version.

Number-up typically has some default embellishment and I think that is sufficient for most people.

The primary issue is how to denote that number-up is not wanted. Tom and I suggested 'none' because
1 could suggest number-up default embellishments with 1 page per impression.

Bob Herriot
> From [email-masked] Fri Nov 22 14:16:08 1996
> Date: Fri, 22 Nov 96 17:16 EST
> Content-Length: 1307
> X-Lines: 29

---

From: [email-masked] (JK Martin)
Date: Fri, 22 Nov 96 23:26 EST

Bob,

> Number-up typically has some default embellishment and I think that is sufficient for most people.

Actually, I was thinking that Number-up was itself an embellishment.
Not that I don't think Number-up is important, though!  It's just
that we need to take a position on embellishments in general.  If
you think Number-up is important enough to special-case it (and it
very well might be), then fine.

	...jay