Subject: IPP> job attributes et by Printer

From: [email-masked]
Date: Mon, 25 Nov 1996 10:12:48 -0500

Classification:
Prologue:
Epilogue:

Bob, can you explain the rationale behind setting job information attributes
such as notification address in the Printer, thus requiring a separate set of
operation attributes to be defined to set them?  I find this confusing. If the
intent is that the client and not the end-user sets these attributes, can't
this be taken care of in the implementation of the client code?

---

From: [email-masked] (Robert Herriot)
Date: Mon, 25 Nov 1996 15:41:00 -0800

My intent is that certain attributes be set by a Printer to the
most authentic value that a server can obtain.  The operation
attributes are a possible source of these values. I would prefer
that the information come from something outside of the entity body.

If these attributes are settable by a client, then the Printer
doesn't know whether a trusted part of the client set them.  

The operation attributes are useful because a client supplies them for
any operation including Print.  Only with Print does a Printer possibly
copy those values into job attributes.

Bob Herriot
 
> From [email-masked] Mon Nov 25 15:24:03 1996
> From: [email-masked]
> X400-Originator: [email-masked]
> X400-Recipients: non-disclosure:;
> X400-Mts-Identifier: [/ADMD=IBMSMTP/C=US/;5030100002247146000002]
> X400-Content-Type: P2-1988 (22)
> To: <robert.herriot@Eng>
> Cc: <[email-masked]>
> Subject: IPP> job attributes et by Printer
> Date: Mon, 25 Nov 1996 10:12:48 -0500
> Sender: [email-masked]
> Content-Length: 411
> X-Lines: 9
> 
> Classification:
> Prologue:
> Epilogue:
>