Subject: Proposed Charter for Internet Printing Protocol WG

From: Carl-Uno Manros <[email-masked]>
Date: Wed, 20 Nov 1996 16:07:46 PST

Harald and Keith,

We have now refined the earlier PWG Charter into a Proposed Charter for a WG
in the IETF, and would like your feedback if this is now OK.

Note that we recommend changing the title of the group to IPP, rather than
LDPA as previously suggested.

I have also included a revised agenda for the BOF meeting (including a title
change).
 
Is there still a chance that we can still get the WG formed in time for the
San Jose meeting (our preference) or did we miss that boat? If so, can the
BOF be changed to become a WG meeting? If we become a WG in time for the
IETF meeting, the agenda needs some further updating. For that reason I have
not yet sent the revision to the IETF.

We are still polishing the texts on the two Internet-Drafts mentioned in the
Charter Draft. They will be finalized and sent to the IETF over the week-end.

I have about 15 people so far that has confirmed to me that they will show
up in San Jose for this subject. I have no doubt that we will get quite a
few more that I do not know about yet. This subject is certainly moving ahead.

Greetings,

Carl-Uno

-----

IETF Internet Printing Protocol (ipp) WG

Chair(s):
        Carl-Uno Manros   <[email-masked]>
 
Applications Area Director(s): 
        Keith Moore        <[email-masked]>
        Harald Alvestrand  <[email-masked]>
 
Area Advisor:
        TBD

Mailing List Information:
        General Discussion: <[email-masked]>
        To Subscribe:       <[email-masked]>
        Archive:            ftp://ftp.pwg.org/pub/pwg/ipp/

Editor:
        Scott Isaacson      <[email-masked]>
 
Description of Working Group:

Internet printing involves using Internet technologies and services 
to find networked resources, such as printers, and then submit jobs
using those resources.  

The goal of this working group is to define a new application level 
distributed printing protocol as well as defining naming and service 
registration attributes for printing.  The protocol shall support a 
global, distributed environment where print service users (clients, 
applications, drivers, etc.) cooperate and interact with print service 
providers (servers, printers, gateways, etc.). 

The working group will leverage existing (and emerging) technologies 
for: authentication, authorization, privacy, and commercial transactions. 
For location of printers, the working group will leverage existing 
standards for directories.

The working group shall strive to coordinate its activities with other 
printing-related standards bodies.

The new job submission protocol should strive not to preclude any 
types of output devices (e.g., fax, printer, gateway).  Also, the 
working group will define extensibility paths to maximize interoperability 
and minimize conflict.

The Internet Printing Protocol will be designed to make use of Web 
browsers, HTTP, and LDAP for directory look-ups. 

The Internet Printing Protocol is intended to supplant RFC 1179 'Line 
Printer Daemon Protocol' as the preferred printing protocol. LPR/LPD 
was designed a long time ago with line printers in mind and does not 
fit with current needs.

Deliverables and Milestones:

Done          - Mailing list and archive

November 1996 - Submit first set of Internet-Drafts
	
December 1996 - IETF meeting in San Jose, CA, USA

March 1997    - Submit Internet-Drafts

April 1997    - Review of specification in IETF meeting in Memphis, TN, USA

May 1997      - At least 2 implemented prototypes

May 1997      - Submit document(s) to the IESG for Proposed Standard

Internet-Drafts:

   IPP-requirements (title TBD)
   IPP-draft        (title TBD)

---------

Agenda for BOF on Internet Printing Protocol in IETF San Jose Meeting

December 12, 1996, 1:00 - 3:00 pm.

Introduction				                (10 mins)

History and Requirements				(30 mins)

        - Existing standards for printing
        - Current user and technology requirements
        - Proposed Charter for IPP

Proposal for the Internet Printing Protocol		(30 mins)

	- Work to date in the Printer Working Group (PWG)
        - Presentation of the IPP draft document

Discussion and Resolution of Issues (if possible)	(30 mins)

	- Needs to coordinate with other IETF projects?
	- Security Requirements for IPP?
	- Other issues?

Wrap-up					                (10 mins)
	- Summary of discussion
	- List remaining issues to be resolved
	- Home work assignments
	- Make recommendation about further progress in IETF

------

Carl-Uno Manros
Xerox Corporation
701 S. Aviation Blvd.
M/S: ESAE-231
El Segundo, CA 90245, USA
E-mail: [email-masked]

---

From: [email-masked]
Date: Fri, 22 Nov 1996 11:55:29 +0100

Carl-Uno,
I've passed the charter off to the Directorate for review, and
also to [email-masked] so that they got the agenda (VERY important).
There's not much practical difference between a BOF and a WG, once
you get there; you both have to provide minutes!

There's one IESG telechat before San Jose; I doubt that it makes
sense to change the status of the meeting at that time; it's so close
to the meeting that it makes sense to get a sense of how the BOF goes
before doing final decision on the charter.

              Harald A