Subject: Re: FIN> On reading the FIN draft

From: Harry Lewis <[email-masked]>
Date: Thu, 18 Jun 1998 16:03:06 -0400

With regard to trap registration... I agree. I think, if you've been following
the Notifications discussions in the PWG (which I'm sure YOU have ;-), you'll
find proposals to define PWG specific registration schemes "rejected" on the
basis that SNMPv3 supplies most of what we need. As for "things we did with the
Job MIB"... remember, it was the IETF who turned their backs on us... this is
strictly a PWG standard.

Harry Lewis - IBM Printing Systems

[email-masked] on 06/18/98 01:39:09 PM
Please respond to [email-masked]
To: Harry Lewis/Boulder/IBM@ibmus
cc: [email-masked], [email-masked]
Subject: Re: FIN> On reading the FIN draft

Notwithstanding, Paul has made an excellent point,
one that should be addressed without concern for
the Job MIB's position in the IETF food chain.

I tend to agree with Paul.  I have similar concerns
regarding the PWG's attempt to define standard ways
of subscribing to Traps--this is a truly generic
requirement for a very, very large audience, and not
just the PWG's.  If the PWG wants a "standard" mechanism
that is genuinely usable by a large audience, then we
should play the IETF game and get a new WG formed that
draws from that audience.

 ...jay

----------------------------------------------------------------------
--  JK Martin               |  Email:   [email-masked]          --
--  Underscore, Inc.        |  Voice:   (603) 889-7000              --
--  41C Sagamore Park Road  |  Fax:     (603) 889-2699              --
--  Hudson, NH 03051-4915   |  Web:     http://www.underscore.com   --
----------------------------------------------------------------------

Harry Lewis wrote:
>
> Paul, don't forget that the IETF showed no interest in the Job MIB, this
> allowed us to develop technology more well suited to our industry. We took
> advantage of this position, but maintained close contact and review with SNMP
> standards experts. The FIN MIB continues this approach even though it actually
> augments RFC1759.
>
> Harry Lewis - IBM Printing Systems
>
> [email-masked] on 06/18/98 12:51:11 PM
> Please respond to [email-masked]
> To: [email-masked], Harry Lewis/Boulder/IBM@ibmus
> cc: [email-masked]
> Subject: RE: FIN> On reading the FIN draft
>
> I DO have the concern that we need to resolve the issues arounf SNMP vs IPP.
>
> My main comment about attributes was saying that you have done a level shift
> in the document. Most MIBS say - 'here is the set of attributes for object
> set XXX'. FIN has said 'here are some of the attributes for finishers, plus
> here is a way of adding other attributes that we havent thought about yet'.
> You have defined a generic extensibiity mechanism - this is more properly
> done in the core SNMP document set - not in an individual MIB.
>
> I expected to read in the FIN MIB the definition of ALL attributes for
> finishers - they are not there (So where are they?). Compare this to 1759.
>
> > -----Original Message-----
> > From: Harry Lewis [SMTP:[email-masked]]
> > Sent: Thursday, June 18, 1998 10:52 AM
> > To: [email-masked]
> > Cc: Paul Moore
> > Subject: RE: FIN> On reading the FIN draft
> >
> > Ron - I got a bit behind... sorry I haven't jumped in... but your
> > responses to
> > Paul's concerns are excellent. Thanks. I too am glad that Paul has taken
> > time
> > to review our work.
> >
> > Paul has been a big advocate of SDP so he may be wishing we could hold up
> > FIN
> > until the PWG gets a more serious bead on SDP. We, of course, feel we have
> > run
> > the gamut and are wanting to close down and call the FIN MIB complete

---

From: Jay Martin <[email-masked]>
Date: Thu, 18 Jun 1998 16:35:36 -0400

Harry,

> Job MIB"... remember, it was the IETF who turned their backs on us... this is

With all due respect, the fact that the Job MIB is not under
the domain of the IETF has nothing to do with the concept of
developing standard techniques in an open arena.

I personally struggled with this concept while developing
the SENSE technology.  I knew all along that a system
of inexpensive, light-weight, scalable event notification
was of emminent utility around the world, across almost
every type of distributed application.

Hence, I was (and remain) quite shy about having the PWG
declare its own notification system without regard for
the needs of others.  This is but one reason I put the
brakes on the SENSE project--to wait and see if other
proposals would emerge in a reasonable time frame.
(I am now monitoring the WebDAV's ENP effort quite closely.)

Just because the IETF declined to embrace the Job MIB
shouldn't mean we have license to institute any kind
of related technology we find interesting or useful.

Give unto Caesar what is Caesar's, and all that rot...  ;-)

Please do understand, though, that I wholeheartedly
encourage members of the PWG to band together and
form a new IETF WG to address any IETF-related technology
opportunity as a separate group.

	...jay